1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Where's "Open With" in Win 7?

Discussion in 'Windows 7' started by Kenny, Jul 28, 2010.

  1. Kenny

    Kenny Flightless Bird

    In XP if I highlight a file, hold Shift and right click I have "Open With"
    in the context menu.
    It's not there in Win 7, is this by design or is it only my PC.
    Replies appreciated.

    --

    Kenny Cargill
     
  2. Peter Taylor

    Peter Taylor Flightless Bird

    On 7/28/2010 9:32 PM, Kenny wrote:
    > In XP if I highlight a file, hold Shift and right click I have "Open With"
    > in the context menu.
    > It's not there in Win 7, is this by design or is it only my PC.
    > Replies appreciated.
    >


    Try just right clicking without the shift.

    --
    Peter Taylor
     
  3. Ken Blake

    Ken Blake Flightless Bird

    On Wed, 28 Jul 2010 20:32:42 +0100, "Kenny" <me@privacy.net> wrote:

    > In XP if I highlight a file, hold Shift and right click I have "Open With"
    > in the context menu.
    > It's not there in Win 7, is this by design or is it only my PC.
    > Replies appreciated.




    It *is* there in Windows 7. The only difference is that although you
    can still hold down the Shift key, it's not necessary.
     
  4. Gene E. Bloch

    Gene E. Bloch Flightless Bird

    On Wed, 28 Jul 2010 21:35:13 +0200, Peter Taylor wrote:

    > On 7/28/2010 9:32 PM, Kenny wrote:
    >> In XP if I highlight a file, hold Shift and right click I have "Open With"
    >> in the context menu.
    >> It's not there in Win 7, is this by design or is it only my PC.
    >> Replies appreciated.
    >>

    >
    > Try just right clicking without the shift.


    I only tried one file (a txt file) and Open With appeared regardless of the
    shift key...

    So Kenny either has a real problem, or he's looking at files that don't
    have an Open With entry. If there is such a thing...

    As an experiment, I just looked at a weird file, xxx.baes (I have
    completely forgotten what that's about, if I ever knew!). It has an "Open
    With HxD" (that's a hex editor that I installed), but it has no generic
    "Open with..." entry. Maybe that corroborates my guess. Also, the shift key
    doesn't matter.

    --
    Gene E. Bloch (Stumbling Bloch)
     
  5. GlowingBlueMist

    GlowingBlueMist Flightless Bird

    On 7/28/2010 4:06 PM, Gene E. Bloch wrote:
    > On Wed, 28 Jul 2010 21:35:13 +0200, Peter Taylor wrote:
    >
    >> On 7/28/2010 9:32 PM, Kenny wrote:
    >>> In XP if I highlight a file, hold Shift and right click I have "Open With"
    >>> in the context menu.
    >>> It's not there in Win 7, is this by design or is it only my PC.
    >>> Replies appreciated.
    >>>

    >>
    >> Try just right clicking without the shift.

    >
    > I only tried one file (a txt file) and Open With appeared regardless of the
    > shift key...
    >
    > So Kenny either has a real problem, or he's looking at files that don't
    > have an Open With entry. If there is such a thing...
    >
    > As an experiment, I just looked at a weird file, xxx.baes (I have
    > completely forgotten what that's about, if I ever knew!). It has an "Open
    > With HxD" (that's a hex editor that I installed), but it has no generic
    > "Open with..." entry. Maybe that corroborates my guess. Also, the shift key
    > doesn't matter.
    >

    Running Win7 Pro here. For what it's worth I tried a handful of
    different file types and it appears that only application programs did
    not have the "Open With" option. Possibly other file types may not have
    the option but then again I did not look "real" hard for them.

    DLL, TXT, MP3 and any other file types that I tried a right-click of the
    mouse did bring up the "Open With" choice.
     
  6. Kenny

    Kenny Flightless Bird

    Thanks for the replies, the problem was of my own making.
    Gene seems to have hit it saying I was trying to open a file which had no
    "Open With".
    Had previously used Notepad to open NFO files but this particular NFO file
    had a tilde (~) after it which seems to have been the problem.

    "Ken Blake" <kblake@this.is.invalid.com> wrote in message
    news:nk5156tun9ev6i7rg4auukq138u3fh51t2@4ax.com...
    > On Wed, 28 Jul 2010 20:32:42 +0100, "Kenny" <me@privacy.net> wrote:
    >
    >> In XP if I highlight a file, hold Shift and right click I have "Open
    >> With"
    >> in the context menu.
    >> It's not there in Win 7, is this by design or is it only my PC.
    >> Replies appreciated.

    >
    >
    >
    > It *is* there in Windows 7. The only difference is that although you
    > can still hold down the Shift key, it's not necessary.
    >
     
  7. Gene E. Bloch

    Gene E. Bloch Flightless Bird

    On Thu, 29 Jul 2010 16:00:55 +0100, Kenny wrote:

    > Thanks for the replies, the problem was of my own making.
    > Gene seems to have hit it saying I was trying to open a file which had no
    > "Open With".
    > Had previously used Notepad to open NFO files but this particular NFO file
    > had a tilde (~) after it which seems to have been the problem.


    Glad to help. As you could see, I wasn't totally sure myself until I ran an
    experiment...

    Tildes are one of the ways some programs mark a backup file - instead of
    renaming x.yyy to x.bak, they use x.yyy~.

    I often do that or similar things manually, such as to rename problem.exe
    to problem.xex or problem.!exe so that I don't accidentally run it :)

    > "Ken Blake" <kblake@this.is.invalid.com> wrote in message
    > news:nk5156tun9ev6i7rg4auukq138u3fh51t2@4ax.com...
    >> On Wed, 28 Jul 2010 20:32:42 +0100, "Kenny" <me@privacy.net> wrote:
    >>
    >>> In XP if I highlight a file, hold Shift and right click I have "Open
    >>> With"
    >>> in the context menu.
    >>> It's not there in Win 7, is this by design or is it only my PC.
    >>> Replies appreciated.

    >>
    >>
    >>
    >> It *is* there in Windows 7. The only difference is that although you
    >> can still hold down the Shift key, it's not necessary.
    >>



    --
    Gene E. Bloch (Stumbling Bloch)
     
  8. JD

    JD Flightless Bird

    Gene E. Bloch wrote:
    > On Thu, 29 Jul 2010 16:00:55 +0100, Kenny wrote:
    >
    >> Thanks for the replies, the problem was of my own making.
    >> Gene seems to have hit it saying I was trying to open a file which had no
    >> "Open With".
    >> Had previously used Notepad to open NFO files but this particular NFO file
    >> had a tilde (~) after it which seems to have been the problem.

    >
    > Glad to help. As you could see, I wasn't totally sure myself until I ran an
    > experiment...
    >
    > Tildes are one of the ways some programs mark a backup file - instead of
    > renaming x.yyy to x.bak, they use x.yyy~.
    >
    > I often do that or similar things manually, such as to rename problem.exe
    > to problem.xex or problem.!exe so that I don't accidentally run it :)
    >
    >> "Ken Blake" <kblake@this.is.invalid.com> wrote in message
    >> news:nk5156tun9ev6i7rg4auukq138u3fh51t2@4ax.com...
    >>> On Wed, 28 Jul 2010 20:32:42 +0100, "Kenny" <me@privacy.net> wrote:
    >>>
    >>>> In XP if I highlight a file, hold Shift and right click I have "Open
    >>>> With"
    >>>> in the context menu.
    >>>> It's not there in Win 7, is this by design or is it only my PC.
    >>>> Replies appreciated.
    >>>
    >>>
    >>> It *is* there in Windows 7. The only difference is that although you
    >>> can still hold down the Shift key, it's not necessary.


    I am new to Win7 and have had problems with files that have the
    extension chopped off. I clicked at the left end of the taskbar and a
    window opened up. I typed in 'file extension' and several choices were
    offered. The one I liked best was: 'Show or Hide File Extension'
    Clicking that one opened a window called Folder Options. It opened at
    the View tab and I found a box checked at Hide Extensions for Known File
    Types. I unchecked it. Now I should always have the file extension visible.
     
  9. w7pro

    w7pro Flightless Bird

    Very interesting issue Kenny. I'm not sure why you would see different results with these two operating systems, however if your version of Windows 7 is Professional, then there's a feature called Windows XP Mode. It opens apps in a window that looks like Windows XP, with the performance speed of Windows 7 Pro. You can get a video demo of how it works at Microsoft Showcase: Windows 7 Professional: Run Windows XP applications. If you'd rather go to a page that also has text, Windows for Small Business: Windows XP Mode has some of the same info as the first link plus the download if you need it and an FAQ (click the "Get Answers" button under "Windows XP questions?" heading on the bottom right). This text and video page has detailed video instructions on downloading and installing Windows XP Mode, plus installing the apps you want to run. Hope this helps. Andrea H. Windows 7 Professional Outreach Team
     
  10. Gene E. Bloch

    Gene E. Bloch Flightless Bird

    On Sat, 7 Aug 2010 23:14:43 -0700, undisclosed wrote:

    > Gene E. Bloch;1795263 Wrote:
    >> On Wed, 28 Jul 2010 21:35:13 +0200, Peter Taylor wrote:
    >>
    >>> On 7/28/2010 9:32 PM, Kenny wrote:
    >>>> In XP if I highlight a file, hold Shift and right click I have "Open

    >> With"
    >>>> in the context menu.
    >>>> It's not there in Win 7, is this by design or is it only my PC.
    >>>> Replies appreciated.
    >>>>
    >>>
    >>> Try just right clicking without the shift.

    >>
    >> I only tried one file (a txt file) and Open With appeared regardless of
    >> the
    >> shift key...
    >>
    >> So Kenny either has a real problem, or he's looking at files that
    >> don't
    >> have an Open With entry. If there is such a thing...
    >>
    >> As an experiment, I just looked at a weird file, xxx.baes (I have
    >> completely forgotten what that's about, if I ever knew!). It has an
    >> "Open
    >> With HxD" (that's a hex editor that I installed), but it has no
    >> generic
    >> "Open with..." entry. Maybe that corroborates my guess. Also, the shift
    >> key
    >> doesn't matter.
    >>
    >> --
    >> Gene E. Bloch (Stumbling Bloch)

    >
    > Very interesting issue Kenny. I'm not sure why you would see different
    > results with these two operating systems, however if your version of
    > Windows 7 is Professional, then there's a feature called Windows XP
    > Mode. It opens apps in a window that looks like Windows XP, with the
    > performance speed of Windows 7 Pro. You can get a video demo of how it
    > works at 'Microsoft Showcase: Windows 7 Professional: Run Windows XP
    > applications' (http://bit.ly/Win7ProXPMode). If you'd rather go to a
    > page that also has text, 'Windows for Small Business: Windows XP Mode'
    > (http://bit.ly/WinXPMode) has some of the same info as the first link
    > plus the download if you need it and an FAQ (click the "Get Answers"
    > button under "Windows XP questions?" heading on the bottom right). This
    > text and video page has detailed video instructions on downloading and
    > installing Windows XP Mode, plus installing the apps you want to run.
    > Hope this helps. Andrea H. Windows 7 Professional Outreach Team


    Uh - I'm not Kenny...

    --
    Gene E. Bloch (Stumbling Bloch)
     

Share This Page