1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Lost desktop icons for TXT PDF HTML

Discussion in 'Windows XP' started by bilm, Aug 26, 2010.

  1. bilm

    bilm Flightless Bird

    In both desktop and explorer detail view I now have the
    default (unknown app) icon for text, pdf and html docs.
    The file associations are still correct for each of
    them. I have the correct icons for all other file
    types.

    How do I get these back?

    TIA,

    bilm
     
  2. Elmo

    Elmo Flightless Bird

    bilm wrote:
    > In both Desktop and Explorer detail view, I now have the
    > default (unknown app) icon for text, pdf and html docs.
    > The file associations are still correct for each of
    > them. I have the correct icons for all other file
    > types.
    >
    > How do I get these back?
    >
    > TIA,
    >
    > bilm


    Here are a few things to try:

    - Press F5.

    - http://www.kellys-korner-xp.com/xp_tweaks.htm
    Line 121. Increase Icon Cache
    Line 4. Repairs the Icon View

    - Try the LNK File Association fix.
    http://dougknox.com/xp/file_assoc.htm

    --

    Joe =o)
     
  3. Tim Meddick

    Tim Meddick Flightless Bird

    Open "Folder Options" in "Control Panel", then click on the tab named "File
    Types" at the top.

    Under the "File Types" tab, scroll down until you reach the [.pdf] item
    (first, then repeat process for [.htm] files) and press on the "Advanced"
    button.

    In the Advanced editing page for that file type, click on the "Change Icon"
    button, and then browse for the .exe file that opens [.pdf] files and
    therefore contains it's file icon.

    Namely; Acrobat Reader (exe name : AcroRd32.dll located in the folder
    "Program Files\Adobe\Reader 9.0\Reader") assuming you have the latest
    version of Acrobat Reader.

    Select it and you will see a selection of icons. Pick the one you
    recognise and press [ok] to exit.

    Repeat the process (which you should have got a hang of now) for files of
    type [.htm].
    But this time it's file icon is located in a file called :

    "C:/Program Files\Internet Explorer\iexplore.exe"

    *Please note that the changes may not be seen immediately, and it may take
    you to logoff / logon to see the refreshed icons.


    ALTERNATIVELY... Just double-click on the attached .reg file and click
    [ok] to import it.

    All this will do is reset the icons for just the two file types you quoted.

    Still, you will need to logoff / logon to see the changes.

    ==

    Cheers, Tim Meddick, Peckham, London. :)



    "bilm" <jetons86896@mypacks.net> wrote in message
    news:%23OgM0dVRLHA.456@TK2MSFTNGP06.phx.gbl...
    > In both desktop and explorer detail view I now have the
    > default (unknown app) icon for text, pdf and html docs.
    > The file associations are still correct for each of
    > them. I have the correct icons for all other file types.
    >
    > How do I get these back?
    >
    > TIA,
    >
    > bilm
    >
    >
    >
    >
     
  4. John Wunderlich

    John Wunderlich Flightless Bird

    "bilm" <jetons86896@mypacks.net> wrote in
    news:#OgM0dVRLHA.456@TK2MSFTNGP06.phx.gbl:

    > In both desktop and explorer detail view I now have the
    > default (unknown app) icon for text, pdf and html docs.
    > The file associations are still correct for each of
    > them. I have the correct icons for all other file
    > types.
    >
    > How do I get these back?
    >
    > TIA,
    >
    > bilm


    Sometimes this is caused by a corrupted Icon Cache. The cache is easy
    to rebuild. Try the instructions here:

    "Icons randomly change to different icons"
    <http://support.microsoft.com/kb/132668>

    HTH,
    John
     
  5. bilm

    bilm Flightless Bird

    Thanks for all the suggestions.
    I tried them all but no joy.

    I have no idea what the problem could be but if you
    think of anything else let me know.

    bilm
     
  6. Mike S

    Mike S Flightless Bird

    On 8/28/2010 5:16 PM, bilm wrote:
    > Thanks for all the suggestions.
    > I tried them all but no joy.
    >
    > I have no idea what the problem could be but if you
    > think of anything else let me know.
    >
    > bilm


    If you open the windows file explorer and right drag a text file to the
    desktop, then select "create shortcuts here" from the context menu when
    you drop it on the deskopt, what happens? Do you see anything?
     
  7. bilm

    bilm Flightless Bird

    When I do that, I see is a shadow-like copy of how it appears in
    file explorer i.e. the
    default windows icon (not icon from the associated app) along
    with "shortcut to ...txt".
    It drags to the desktop then I choose to create shortcut here and
    let up on the right mouse button.
    I then see on the desktop the (wrong) icon above the "shorcut to
    .....txt".

    bilm


    "Mike S" <mscir@yahoo.com> wrote in message
    news:i5c9f9$gfd$2@news.eternal-september.org...
    > On 8/28/2010 5:16 PM, bilm wrote:
    >> Thanks for all the suggestions.
    >> I tried them all but no joy.
    >>
    >> I have no idea what the problem could be but if you
    >> think of anything else let me know.
    >>
    >> bilm

    >
    > If you open the windows file explorer and right drag a text
    > file to the desktop, then select "create shortcuts here" from
    > the context menu when you drop it on the deskopt, what happens?
    > Do you see anything?
    >
     
  8. Tim Meddick

    Tim Meddick Flightless Bird

    Did you not try the .reg repair file, attached to my last post in this
    thread?

    ==

    Cheers, Tim Meddick, Peckham, London. :)




    "bilm" <jetons86896@mypacks.net> wrote in message
    news:eMhdQTTSLHA.2100@TK2MSFTNGP04.phx.gbl...
    > When I do that, I see is a shadow-like copy of how it appears in file
    > explorer i.e. the
    > default windows icon (not icon from the associated app) along with
    > "shortcut to ...txt".
    > It drags to the desktop then I choose to create shortcut here and let up
    > on the right mouse button.
    > I then see on the desktop the (wrong) icon above the "shorcut to
    > ....txt".
    >
    > bilm
    >
    >
    > "Mike S" <mscir@yahoo.com> wrote in message
    > news:i5c9f9$gfd$2@news.eternal-september.org...
    >> On 8/28/2010 5:16 PM, bilm wrote:
    >>> Thanks for all the suggestions.
    >>> I tried them all but no joy.
    >>>
    >>> I have no idea what the problem could be but if you
    >>> think of anything else let me know.
    >>>
    >>> bilm

    >>
    >> If you open the windows file explorer and right drag a text file to the
    >> desktop, then select "create shortcuts here" from the context menu when
    >> you drop it on the deskopt, what happens? Do you see anything?
    >>

    >
    >
     
  9. bilm

    bilm Flightless Bird

    Hi Tim,

    Yes I merged it with my registry. Had to make a small change in
    the path. It didn't fix the problem but I appreciate your effort.

    It remains unsolved.

    bilm

    "Tim Meddick" <timmeddick@o2.co.uk> wrote in message
    news:%23NP7IccSLHA.5944@TK2MSFTNGP02.phx.gbl...
    > Did you not try the .reg repair file, attached to my last post
    > in this thread?
    >
    > ==
    >
    > Cheers, Tim Meddick, Peckham, London. :)
    >
    >
    >
    >
    > "bilm" <jetons86896@mypacks.net> wrote in message
    > news:eMhdQTTSLHA.2100@TK2MSFTNGP04.phx.gbl...
    >> When I do that, I see is a shadow-like copy of how it appears
    >> in file explorer i.e. the
    >> default windows icon (not icon from the associated app) along
    >> with "shortcut to ...txt".
    >> It drags to the desktop then I choose to create shortcut here
    >> and let up on the right mouse button.
    >> I then see on the desktop the (wrong) icon above the "shorcut
    >> to ....txt".
    >>
    >> bilm
    >>
    >>
    >> "Mike S" <mscir@yahoo.com> wrote in message
    >> news:i5c9f9$gfd$2@news.eternal-september.org...
    >>> On 8/28/2010 5:16 PM, bilm wrote:
    >>>> Thanks for all the suggestions.
    >>>> I tried them all but no joy.
    >>>>
    >>>> I have no idea what the problem could be but if you
    >>>> think of anything else let me know.
    >>>>
    >>>> bilm
    >>>
    >>> If you open the windows file explorer and right drag a text
    >>> file to the desktop, then select "create shortcuts here" from
    >>> the context menu when you drop it on the deskopt, what
    >>> happens? Do you see anything?
    >>>

    >>
    >>

    >
     
  10. Tim Meddick

    Tim Meddick Flightless Bird

    You rebooted ?

    Plus, if the reg-file didn't work, you could always edit it using Notepad.

    Open the file and check the path to [AcroRd32.dll] is correct (minding that
    there are always two \\ backslashes separating the path folders in a [.reg]
    file ).


    Alternatively, why not just open :

    "Control Panel" - "Folder Options" - "File Types" (tab)

    ....and scroll down to your two file-types (.pdf & .htm) and then clicking
    on the "Advanced" button in each to edit them. Change their default icons
    by clicking on the "Change Icon" button and browsing for -

    (*.pdf) = AcroRd32.dll within folder :

    "C:/Program Files\Adobe\%program version%\Reader\"

    ....where ; %program version% stands for the version of Acrobat you are
    using (you'll see when you browse there).

    (*.htm & *.html) = iexplore.exe within folder :

    "C:/Program Files\Internet Explorer\"

    ==

    Cheers, Tim Meddick, Peckham, London. :)




    "bilm" <jetons86896@mypacks.net> wrote in message
    news:uONcgtiSLHA.1184@TK2MSFTNGP06.phx.gbl...
    > Hi Tim,
    >
    > Yes I merged it with my registry. Had to make a small change in
    > the path. It didn't fix the problem but I appreciate your effort.
    >
    > It remains unsolved.
    >
    > bilm
    >
    > "Tim Meddick" <timmeddick@o2.co.uk> wrote in message
    > news:%23NP7IccSLHA.5944@TK2MSFTNGP02.phx.gbl...
    >> Did you not try the .reg repair file, attached to my last post
    >> in this thread?
    >>
    >> ==
    >>
    >> Cheers, Tim Meddick, Peckham, London. :)
    >>
    >>
    >>
    >>
    >> "bilm" <jetons86896@mypacks.net> wrote in message
    >> news:eMhdQTTSLHA.2100@TK2MSFTNGP04.phx.gbl...
    >>> When I do that, I see is a shadow-like copy of how it appears
    >>> in file explorer i.e. the
    >>> default windows icon (not icon from the associated app) along
    >>> with "shortcut to ...txt".
    >>> It drags to the desktop then I choose to create shortcut here
    >>> and let up on the right mouse button.
    >>> I then see on the desktop the (wrong) icon above the "shorcut
    >>> to ....txt".
    >>>
    >>> bilm
    >>>
    >>>
    >>> "Mike S" <mscir@yahoo.com> wrote in message
    >>> news:i5c9f9$gfd$2@news.eternal-september.org...
    >>>> On 8/28/2010 5:16 PM, bilm wrote:
    >>>>> Thanks for all the suggestions.
    >>>>> I tried them all but no joy.
    >>>>>
    >>>>> I have no idea what the problem could be but if you
    >>>>> think of anything else let me know.
    >>>>>
    >>>>> bilm
    >>>>
    >>>> If you open the windows file explorer and right drag a text
    >>>> file to the desktop, then select "create shortcuts here" from
    >>>> the context menu when you drop it on the deskopt, what
    >>>> happens? Do you see anything?
    >>>>
    >>>
    >>>

    >>

    >
    >
    >
     
  11. bilm

    bilm Flightless Bird

    I have finally got PDF & TXT files to display the right icons
    but I haven't managed to fix the HTMLs yet.

    I had to go through the registry by hand and make the changes.

    The PDF entries (.PDF, Adobe Acrobat,AcroExch.Document,
    application/pdf) had a non-existent path for the 'DefaultIcon'
    fields. Once I corrected that, the icons came back.

    The .txt/textfile entries were all using the default windows
    notepad no matter what changes I made via
    "Control Panel" - "Folder Options" - "File Types" (tab)
    or
    right click, properties, change 'Opens with'.
    I have my own favorite plain text program so I changed all the
    'DefaultIcon' fields accordingly and the correct icons came back.

    I've done the same for .HTML,.HTM,htmlfile,HTML Document
    but with no luck.

    bilm

    "Tim Meddick" <timmeddick@o2.co.uk> wrote in message
    news:e3oumsjSLHA.5388@TK2MSFTNGP04.phx.gbl...
    >
    > You rebooted ?
    >
    > Plus, if the reg-file didn't work, you could always edit it
    > using Notepad.
    >
    > Open the file and check the path to [AcroRd32.dll] is correct
    > (minding that there are always two \\ backslashes separating
    > the path folders in a [.reg] file ).
    >
    >
    > Alternatively, why not just open :
    >
    > "Control Panel" - "Folder Options" - "File Types" (tab)
    >
    > ...and scroll down to your two file-types (.pdf & .htm) and
    > then clicking on the "Advanced" button in each to edit them.
    > Change their default icons by clicking on the "Change Icon"
    > button and browsing for -
    >
    > (*.pdf) = AcroRd32.dll within folder :
    >
    > "C:/Program Files\Adobe\%program version%\Reader\"
    >
    > ...where ; %program version% stands for the version of Acrobat
    > you are using (you'll see when you browse there).
    >
    > (*.htm & *.html) = iexplore.exe within folder :
    >
    > "C:/Program Files\Internet Explorer\"
    >
    > ==
    >
    > Cheers, Tim Meddick, Peckham, London. :)
    >
    >
    >
    >
    > "bilm" <jetons86896@mypacks.net> wrote in message
    > news:uONcgtiSLHA.1184@TK2MSFTNGP06.phx.gbl...
    >> Hi Tim,
    >>
    >> Yes I merged it with my registry. Had to make a small change
    >> in
    >> the path. It didn't fix the problem but I appreciate your
    >> effort.
    >>
    >> It remains unsolved.
    >>
    >> bilm
    >>
    >> "Tim Meddick" <timmeddick@o2.co.uk> wrote in message
    >> news:%23NP7IccSLHA.5944@TK2MSFTNGP02.phx.gbl...
    >>> Did you not try the .reg repair file, attached to my last
    >>> post
    >>> in this thread?
    >>>
    >>> ==
    >>>
    >>> Cheers, Tim Meddick, Peckham, London. :)
    >>>
    >>>
    >>>
    >>>
    >>> "bilm" <jetons86896@mypacks.net> wrote in message
    >>> news:eMhdQTTSLHA.2100@TK2MSFTNGP04.phx.gbl...
    >>>> When I do that, I see is a shadow-like copy of how it
    >>>> appears
    >>>> in file explorer i.e. the
    >>>> default windows icon (not icon from the associated app)
    >>>> along
    >>>> with "shortcut to ...txt".
    >>>> It drags to the desktop then I choose to create shortcut
    >>>> here
    >>>> and let up on the right mouse button.
    >>>> I then see on the desktop the (wrong) icon above the
    >>>> "shorcut
    >>>> to ....txt".
    >>>>
    >>>> bilm
    >>>>
    >>>>
    >>>> "Mike S" <mscir@yahoo.com> wrote in message
    >>>> news:i5c9f9$gfd$2@news.eternal-september.org...
    >>>>> On 8/28/2010 5:16 PM, bilm wrote:
    >>>>>> Thanks for all the suggestions.
    >>>>>> I tried them all but no joy.
    >>>>>>
    >>>>>> I have no idea what the problem could be but if you
    >>>>>> think of anything else let me know.
    >>>>>>
    >>>>>> bilm
    >>>>>
    >>>>> If you open the windows file explorer and right drag a text
    >>>>> file to the desktop, then select "create shortcuts here"
    >>>>> from
    >>>>> the context menu when you drop it on the deskopt, what
    >>>>> happens? Do you see anything?
    >>>>>
    >>>>
    >>>>
    >>>

    >>
    >>
    >>

    >
     
  12. Tim Meddick

    Tim Meddick Flightless Bird

    If you are getting familiar with the inner workings of the registry (I was
    way too shy to advise you to do so), then, with regards to the HTML icons -
    I would open the [.reg] file I sent you, and analyse the settings needed to
    rectify the [.htm] or [.html] files.

    Because they are not as straightforward as [.pdf] and [.txt] files.

    The icon for [.htm] files is not governed by just the "DefaultIcon" key
    under :

    [HKEY_CLASSES_ROOT\InternetShortcut]

    ....(which should be, strangely enough, set to: "%1" ) but also "Internet
    Shortcut" files are governed by a key within the branch :

    [HKEY_CLASSES_ROOT\CLSID\.........]

    If you remember, Internet Shortcuts are sort of special, because although
    they usually have a standard Internet Explorer "e" icon, they can also have
    a "custom" icon given to it by the website they point to.

    So, again, I would ask you to look inside the reg-file I provided, and
    study the key-names in it.

    As you found for yourself, in the end, it is probably a case of
    incompletely quoted or plainly wrong icon paths that are to blame.

    ==

    Cheers, Tim Meddick, Peckham, London. :)




    "bilm" <jetons86896@mypacks.net> wrote in message
    news:%23qdoO55SLHA.620@TK2MSFTNGP06.phx.gbl...
    >I have finally got PDF & TXT files to display the right icons
    > but I haven't managed to fix the HTMLs yet.
    >
    > I had to go through the registry by hand and make the changes.
    >
    > The PDF entries (.PDF, Adobe Acrobat,AcroExch.Document,
    > application/pdf) had a non-existent path for the 'DefaultIcon'
    > fields. Once I corrected that, the icons came back.
    >
    > The .txt/textfile entries were all using the default windows
    > notepad no matter what changes I made via
    > "Control Panel" - "Folder Options" - "File Types" (tab)
    > or
    > right click, properties, change 'Opens with'.
    > I have my own favorite plain text program so I changed all the
    > 'DefaultIcon' fields accordingly and the correct icons came back.
    >
    > I've done the same for .HTML,.HTM,htmlfile,HTML Document
    > but with no luck.
    >
    > bilm
    >
    > "Tim Meddick" <timmeddick@o2.co.uk> wrote in message
    > news:e3oumsjSLHA.5388@TK2MSFTNGP04.phx.gbl...
    >>
    >> You rebooted ?
    >>
    >> Plus, if the reg-file didn't work, you could always edit it
    >> using Notepad.
    >>
    >> Open the file and check the path to [AcroRd32.dll] is correct
    >> (minding that there are always two \\ backslashes separating
    >> the path folders in a [.reg] file ).
    >>
    >>
    >> Alternatively, why not just open :
    >>
    >> "Control Panel" - "Folder Options" - "File Types" (tab)
    >>
    >> ...and scroll down to your two file-types (.pdf & .htm) and
    >> then clicking on the "Advanced" button in each to edit them.
    >> Change their default icons by clicking on the "Change Icon"
    >> button and browsing for -
    >>
    >> (*.pdf) = AcroRd32.dll within folder :
    >>
    >> "C:/Program Files\Adobe\%program version%\Reader\"
    >>
    >> ...where ; %program version% stands for the version of Acrobat
    >> you are using (you'll see when you browse there).
    >>
    >> (*.htm & *.html) = iexplore.exe within folder :
    >>
    >> "C:/Program Files\Internet Explorer\"
    >>
    >> ==
    >>
    >> Cheers, Tim Meddick, Peckham, London. :)
    >>
    >>
    >>
    >>
    >> "bilm" <jetons86896@mypacks.net> wrote in message
    >> news:uONcgtiSLHA.1184@TK2MSFTNGP06.phx.gbl...
    >>> Hi Tim,
    >>>
    >>> Yes I merged it with my registry. Had to make a small change
    >>> in
    >>> the path. It didn't fix the problem but I appreciate your
    >>> effort.
    >>>
    >>> It remains unsolved.
    >>>
    >>> bilm
    >>>
    >>> "Tim Meddick" <timmeddick@o2.co.uk> wrote in message
    >>> news:%23NP7IccSLHA.5944@TK2MSFTNGP02.phx.gbl...
    >>>> Did you not try the .reg repair file, attached to my last
    >>>> post
    >>>> in this thread?
    >>>>
    >>>> ==
    >>>>
    >>>> Cheers, Tim Meddick, Peckham, London. :)
    >>>>
    >>>>
    >>>>
    >>>>
    >>>> "bilm" <jetons86896@mypacks.net> wrote in message
    >>>> news:eMhdQTTSLHA.2100@TK2MSFTNGP04.phx.gbl...
    >>>>> When I do that, I see is a shadow-like copy of how it
    >>>>> appears
    >>>>> in file explorer i.e. the
    >>>>> default windows icon (not icon from the associated app)
    >>>>> along
    >>>>> with "shortcut to ...txt".
    >>>>> It drags to the desktop then I choose to create shortcut
    >>>>> here
    >>>>> and let up on the right mouse button.
    >>>>> I then see on the desktop the (wrong) icon above the
    >>>>> "shorcut
    >>>>> to ....txt".
    >>>>>
    >>>>> bilm
    >>>>>
    >>>>>
    >>>>> "Mike S" <mscir@yahoo.com> wrote in message
    >>>>> news:i5c9f9$gfd$2@news.eternal-september.org...
    >>>>>> On 8/28/2010 5:16 PM, bilm wrote:
    >>>>>>> Thanks for all the suggestions.
    >>>>>>> I tried them all but no joy.
    >>>>>>>
    >>>>>>> I have no idea what the problem could be but if you
    >>>>>>> think of anything else let me know.
    >>>>>>>
    >>>>>>> bilm
    >>>>>>
    >>>>>> If you open the windows file explorer and right drag a text
    >>>>>> file to the desktop, then select "create shortcuts here"
    >>>>>> from
    >>>>>> the context menu when you drop it on the deskopt, what
    >>>>>> happens? Do you see anything?
    >>>>>>
    >>>>>
    >>>>>
    >>>>
    >>>
    >>>
    >>>

    >>

    >
    >
    >
    >
    >
     

Share This Page