1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

IE not able to display documents with invalid certificate. Fix?

Discussion in 'Internet Explorer' started by Michael Moser, Mar 22, 2010.

  1. Michael Moser

    Michael Moser Flightless Bird

    I suddenly have again the effect that IE suddenly is unable to display
    documents that come with an invalid certificate (it's IE8 in my case now,
    but I had that very same effect already about a year ago with IE7 and it
    drove me nuts since many of our company internal webpages use invalid SLL
    certificates and they were suddenly not usable any more with IE).

    The effect manifest such, that there is first the warning page stating that
    "There is a problem with the website's security certificate". If I then
    click on the red "continue to this website" link I DO NOT get the requested
    webpage but rather I see a page "Internet Explorer can not display the
    webpage" with a URL that reads "res://ieframe.dll".

    My suspicion is, that this has to do with an apparently failed or half-baken
    uninstallation of Google Chrome (which I had given another test run last
    week and then de-installed it. I now recall, that I had done that also last
    year without realizing that connection). After Chrome's deinstall last week
    in many applications (e.g. Outlook) clicking onto URLs didn't work any more.
    I then had to manually fix this by editing the registry and manually
    replacing a few entries left over by Chrome with pointers to IE.

    My suspicion now is, that this sudden bad handling of non-valid webpages is
    also due to some Chrome leftovers.

    Any ideas? Suggestions? Have others encountered that as well and maybe found
    ways to fix this?
    Michael
     
  2. rob^_^

    rob^_^ Flightless Bird

    Hi Michael,

    Chrome has a habit of hijacking the Windows default web browser settings
    (there is a setting to prompt before, but you may have turned it off)

    Not knowing your Windows version we cannot give specific instructions, but
    the aim is to reset IE as your default browser... this will reset the
    registry keys that determine what programs to open links and the like with.

    From IE try Tools>Internet Options - Programs tab, there are settings there
    to prompt if IE is not the default browser. Enabling that, then the next
    time you start IE you should see a prompt and accepting it will
    automatically re-establish IE as the default.

    Vista and Win7 have control panel applets to manage default programs and
    associations.

    Invalid certs.... you have probably playing around with IE's security zone
    settings (in the hope of "getting things to work")....
    "My suspicion now is, that this sudden bad handling of non-valid webpages
    is
    > also due to some Chrome leftovers." - no... you have probably changed
    > things in IE after the fact in the hope of fixing the first issue with
    > links not working.


    Tools>Internet Options - Security tab, click "Reset all zones to default"

    Check your Intranet zone settings.... the default security setting for
    certificates in that zone allow invalid certs. Usually you let IE
    automatically detect sites that are in the Intranet zone. Your company may
    have a Group Policy in effect. Consult your Network administrators before
    customizing the list of sites in the Intranet zone.

    Also ensure that you do not have any intranet sites(servers) in the Trusted
    Sites zone. Remove them from there.

    Any public web sites that present invalid certs, be aware of. Click on the
    Smart Address bar security icon to view the details. I am not going to tell
    you how to turn off the warning, because you shouldn't. Web sites have to
    make their sites safe and secure. IE issues those warnings for public sites
    for good reason.

    Most companies have stipsteam builds of IE and can reset your browser quite
    easily. They may be able to save you the bother and get your PC and browser
    back to the way it was.

    Lucky you did not try the new Opera.

    "Michael Moser" <michael.nospam.moser@nospam.freesurf.ch> wrote in message
    news:66135303-324B-40A2-BCB1-73E64C3B4CE2@microsoft.com...
    > I suddenly have again the effect that IE suddenly is unable to display
    > documents that come with an invalid certificate (it's IE8 in my case now,
    > but I had that very same effect already about a year ago with IE7 and it
    > drove me nuts since many of our company internal webpages use invalid SLL
    > certificates and they were suddenly not usable any more with IE).
    >
    > The effect manifest such, that there is first the warning page stating
    > that "There is a problem with the website's security certificate". If I
    > then click on the red "continue to this website" link I DO NOT get the
    > requested webpage but rather I see a page "Internet Explorer can not
    > display the webpage" with a URL that reads "res://ieframe.dll".
    >
    > My suspicion is, that this has to do with an apparently failed or
    > half-baken uninstallation of Google Chrome (which I had given another test
    > run last week and then de-installed it. I now recall, that I had done that
    > also last year without realizing that connection). After Chrome's
    > deinstall last week in many applications (e.g. Outlook) clicking onto URLs
    > didn't work any more. I then had to manually fix this by editing the
    > registry and manually replacing a few entries left over by Chrome with
    > pointers to IE.
    >
    > My suspicion now is, that this sudden bad handling of non-valid webpages
    > is also due to some Chrome leftovers.
    >
    > Any ideas? Suggestions? Have others encountered that as well and maybe
    > found ways to fix this?
    > Michael
    >
    >
    >
     

Share This Page