1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

HTM files do not open

Discussion in 'Internet Explorer' started by Philip K, Jan 4, 2010.

  1. Philip K

    Philip K Flightless Bird

    Hi Everybody,
    1. I have Vista Home Premium and Internet Explorer v 8. I never set
    anything about users or administrators since I am the only one using this
    computer.
    2. I have many old graphics tutorials in HTM format which I downloaded some
    years ago when I was using Windows 98. They opened in Windows 98.
    3. I can't open them with Vista. If I use FILE > OPEN in Internet
    Explorer, I get the HTML code. If I double click on the file in Windows
    Explorer, I get a message saying that Windows Internet Explorer is not
    responding.
    4. I have a similar problem with HTM files which I have recently
    downloaded from the internet news groups.
    Are there some settings or updates to correct this problem.
    Thanking you
    Phil
     
  2. rob^_^

    rob^_^ Flightless Bird

    Hi Philip,

    Off Topic - I have had the opposite problem. Running sandboxed IE3 or 4
    versions on Vista all quirks and standards web pages look like junk...
    These are not tutorials for MS Image Composer by chance? (still my favorite
    image editor)

    Can you provide a snippet of the top 10 lines of markup from the top of
    these html files?

    I would expect that they start with <script> blocks instead of <html>, in
    which case they would make a standards compliant browser like IE8 choke.

    What you can try, to get IE8 to open these old html files is
    (Warning these settings may make IE8 go into an infinite loop. You will have
    to hot restart (PC Reset button) out of it.)

    Tools>Internet Options - Advanced tab

    uncheck "Enable third-party browser extensions" (reset this setting to your
    original settings when finished)
    uncheck "Enable automatic crash recovery"
    uncheck "Automatically recover from page layout errors with compatibility
    view"
    check "Allow active content to run in files on My Computer" (Security
    section of the Advanced tab)

    On the Security tab, Internet Zone, (these security zone settings are
    optional, they may or may not have a bearing)

    Disable "Active Scripting"

    save your settings and restart IE. !important (also). Do not display the IE8
    Developer Tool (F12) while you have these pages loaded with the above
    settings. It is bound to crash and probably freeze your PC.

    !important (very, very, very important) change these settings back once you
    have tried to load your legacy pages.

    Tip. Just press the "Restore advanced settings" button on the Advanced tab
    of Internet Options.

    You can of coarse try another browser. The latest FX version is the most
    likely one for the job, Chrome, probably, definitely not. (do not use the
    IEtabs FX extension though to view your pages in FX).

    I've notice you have an AOL email. If you have the AOL browser installed,
    then there is nothing you can do to get IE installed on the same machine to
    load these legacy files (the AOL browser adds a custom security zone to IE's
    settings, but does not remove it when it is uninstalled.) The details of why
    this is a show-stopper are too complicated to go into here.)

    If you have Visual Studio or Expression Web installed (there are 60 day free
    trials available from downloads.microsoft.com) then you can open the legacy
    pages in these IDE's to edit them and remove any invalid markup. You need an
    understanding of web standards and experience in using MS Developer products
    with Intellisense (tm). The built in error reporting in these products tells
    you what changes you have to make in order to make your legacy pages
    standards compliant.

    The fix required may be as simple as moving your <script> blocks to within
    the <head> or <body> blocks.

    Reviewing my post I think the Expression Web path is the way to go. You
    could try one of the HTML communities for cheap coding resources to convert
    the files for you. IF its the MS Image Composer help files, I can do it for
    you with my copies. I have it installed on both my Vista and Win7 machines.

    Regards.

    "Philip K" <PhilipK@aol/com> wrote in message
    news:eQ0jiBbjKHA.1536@TK2MSFTNGP06.phx.gbl...
    > Hi Everybody,
    > 1. I have Vista Home Premium and Internet Explorer v 8. I never set
    > anything about users or administrators since I am the only one using this
    > computer.
    > 2. I have many old graphics tutorials in HTM format which I downloaded
    > some
    > years ago when I was using Windows 98. They opened in Windows 98.
    > 3. I can't open them with Vista. If I use FILE > OPEN in Internet
    > Explorer, I get the HTML code. If I double click on the file in Windows
    > Explorer, I get a message saying that Windows Internet Explorer is not
    > responding.
    > 4. I have a similar problem with HTM files which I have recently
    > downloaded from the internet news groups.
    > Are there some settings or updates to correct this problem.
    > Thanking you
    > Phil
    >
    >
     
  3. Philip K

    Philip K Flightless Bird

    Hi Rob,
    1. Thanks for your reply.
    2. I stumbled into the solution.
    3. Some time ago, I installed Visual C# 2008 Express Edition. It comes
    straight from Microsoft just like Windows.
    There is a setting which should be local to Visual C#. It's under
    Tools > Options > Environment > Help >Show Help Using > Pull down list.
    All is well if you choose "Integrated Help Viewer". If you choose the
    other option, HTML is dead in the water for all applications. Apparently,
    Microsoft inadvertently made that an intergalactic setting.
    Phil
     
  4. rob^_^

    rob^_^ Flightless Bird

    Hi Phil,

    Thanks for the feedback. Yep the MSDN Help viewer is a WebBrowser Control
    and defaults to the IE7 rendering mode. You see in my Answer that I thought
    it was something more ancient than 2008. The Expression Editions from MS
    aren't Gold Quality and are only Samplers, not something you would use for
    production environments at work.

    Oh. Have you installed Visual Studio 2008 since. There is also a tweak that
    you need if you are using the Visual C++ Template Wizards. Post back if you
    want that info or search for 'IE8 VC Wizards'

    Great.

    "Philip K" <PhilipK@aol/com> wrote in message
    news:#4VwIw0jKHA.4672@TK2MSFTNGP06.phx.gbl...
    > Hi Rob,
    > 1. Thanks for your reply.
    > 2. I stumbled into the solution.
    > 3. Some time ago, I installed Visual C# 2008 Express Edition. It comes
    > straight from Microsoft just like Windows.
    > There is a setting which should be local to Visual C#. It's under
    > Tools > Options > Environment > Help >Show Help Using > Pull down list.
    > All is well if you choose "Integrated Help Viewer". If you choose the
    > other option, HTML is dead in the water for all applications.
    > Apparently, Microsoft inadvertently made that an intergalactic setting.
    > Phil
    >
    >
     
  5. Philip K

    Philip K Flightless Bird

    Hi,
    Thanks for your feedback and confirmation.
    Right now, I'm struggling just to get on board on C# Windows Forms. I
    thought that it would be easy after having programmed in Fortran and some
    C++.
    It's turning out to be very difficult.
    Thanks again.
    Phil
     

Share This Page