1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Auto-play not working - CD-ROMS and USB drive (tried manysuggestions)

Discussion in 'Windows XP' started by Robert Hall, Jul 28, 2010.

  1. Robert Hall

    Robert Hall Flightless Bird

    Everything I have tried is below.

    When I put a CD in the computer, or plug in a USB flash drive, I don't
    get a window asking me what I want to do (play music, open folder to
    view files, nothing, etc.) I tested the USB drive on my other
    computer, and I get the dialog.

    The devices show up in My Computer. If I right click and select
    properties, auto-play is enabled for all file types.

    Microsoft suggestions tried: http ://support.microsoft.com/kb/330135
    1. Roxio Easy CD Creator is not installed.
    2. HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\CDRom Autorun
    = 1
    3. HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies
    \Explorer NoDriveTypeAutoRun = 91
    4. HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion
    \Winlogon allocatecdroms = 0
    5. The ASUS DRW-014L1T cd/dvd drive has the latest drivers, and is
    compatible with XP.

    Microsoft autoplay repair wizard: http ://www.microsoft.com/downloads/
    details.aspx?familyid=c680a7b6-e8fa-45c4-
    a171-1b389cfacdad&displaylang=en#Instructions
    1. Downloaded and ran autofix - if reported a repair, and said to
    reboot. No change. Ran tool again, now it says it already ran, and I
    need to log on/off before running it again. I logged off/on and also
    rebooted several times, and I still get this message.
    THIS TOOL IS BUGGY!

    Googled suggestions not redundant with the above -

    The Microsoft tool APPMDiag is supposed to do a postmortem report on
    it's last autoplay when you remove a device - nothing appears in the
    window when I take out a USB flash drive or a music CD.

    Running gpedit.msc (to open the Group Policy window) :
    1. Local computer policy - User configuration - Administrative
    templates - System - Turn off autoplay = disabled
    2. Local computer policy - Computer configuration - Administrative
    templates - System - Turn off autoplay = disabled

    Any other ideas?
     
  2. Grinder

    Grinder Flightless Bird

    Re: Auto-play not working - CD-ROMS and USB drive (tried many suggestions)

    On 7/28/2010 12:18 PM, Robert Hall wrote:
    > Everything I have tried is below.
    >
    > When I put a CD in the computer, or plug in a USB flash drive, I don't
    > get a window asking me what I want to do (play music, open folder to
    > view files, nothing, etc.) I tested the USB drive on my other
    > computer, and I get the dialog.
    >
    > The devices show up in My Computer. If I right click and select
    > properties, auto-play is enabled for all file types.
    >
    > Microsoft suggestions tried: http ://support.microsoft.com/kb/330135
    > 1. Roxio Easy CD Creator is not installed.
    > 2. HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\CDRom Autorun
    > = 1
    > 3. HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies
    > \Explorer NoDriveTypeAutoRun = 91
    > 4. HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion
    > \Winlogon allocatecdroms = 0
    > 5. The ASUS DRW-014L1T cd/dvd drive has the latest drivers, and is
    > compatible with XP.
    >
    > Microsoft autoplay repair wizard: http ://www.microsoft.com/downloads/
    > details.aspx?familyid=c680a7b6-e8fa-45c4-
    > a171-1b389cfacdad&displaylang=en#Instructions
    > 1. Downloaded and ran autofix - if reported a repair, and said to
    > reboot. No change. Ran tool again, now it says it already ran, and I
    > need to log on/off before running it again. I logged off/on and also
    > rebooted several times, and I still get this message.
    > THIS TOOL IS BUGGY!
    >
    > Googled suggestions not redundant with the above -
    >
    > The Microsoft tool APPMDiag is supposed to do a postmortem report on
    > it's last autoplay when you remove a device - nothing appears in the
    > window when I take out a USB flash drive or a music CD.
    >
    > Running gpedit.msc (to open the Group Policy window) :
    > 1. Local computer policy - User configuration - Administrative
    > templates - System - Turn off autoplay = disabled
    > 2. Local computer policy - Computer configuration - Administrative
    > templates - System - Turn off autoplay = disabled
    >
    > Any other ideas?


    TweakUI is a handy control panel with lots of features, including
    Autorun control. I would probably install it to see what it says about
    the current state of settings -- both by Logical Driver Letter *and*
    Device Type.

    http://www.microsoft.com/windowsxp/downloads/powertoys/xppowertoys.mspx
     
  3. relic

    relic Flightless Bird

    Re: Auto-play not working - CD-ROMS and USB drive (tried many suggestions)

    "Robert Hall" <bobhallaz@hotmail.com> wrote in message
    news:1e24363c-c91e-466b-b32f-56f151ddf89d@c10g2000yqi.googlegroups.com...
    > Everything I have tried is below.
    >
    > When I put a CD in the computer, or plug in a USB flash drive, I don't
    > get a window asking me what I want to do (play music, open folder to
    > view files, nothing, etc.) I tested the USB drive on my other
    > computer, and I get the dialog.
    >
    > The devices show up in My Computer. If I right click and select
    > properties, auto-play is enabled for all file types.
    >
    > Microsoft suggestions tried: http ://support.microsoft.com/kb/330135
    > 1. Roxio Easy CD Creator is not installed.
    > 2. HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\CDRom Autorun
    > = 1
    > 3. HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies
    > \Explorer NoDriveTypeAutoRun = 91
    > 4. HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion
    > \Winlogon allocatecdroms = 0
    > 5. The ASUS DRW-014L1T cd/dvd drive has the latest drivers, and is
    > compatible with XP.
    >
    > Microsoft autoplay repair wizard: http ://www.microsoft.com/downloads/
    > details.aspx?familyid=c680a7b6-e8fa-45c4-
    > a171-1b389cfacdad&displaylang=en#Instructions
    > 1. Downloaded and ran autofix - if reported a repair, and said to
    > reboot. No change. Ran tool again, now it says it already ran, and I
    > need to log on/off before running it again. I logged off/on and also
    > rebooted several times, and I still get this message.
    > THIS TOOL IS BUGGY!
    >
    > Googled suggestions not redundant with the above -
    >
    > The Microsoft tool APPMDiag is supposed to do a postmortem report on
    > it's last autoplay when you remove a device - nothing appears in the
    > window when I take out a USB flash drive or a music CD.
    >
    > Running gpedit.msc (to open the Group Policy window) :
    > 1. Local computer policy - User configuration - Administrative
    > templates - System - Turn off autoplay = disabled
    > 2. Local computer policy - Computer configuration - Administrative
    > templates - System - Turn off autoplay = disabled
    >
    > Any other ideas?


    Clean Install.
     
  4. Robert Hall

    Robert Hall Flightless Bird

    On Jul 28, 2:26 pm, Grinder <grin...@no.spam.maam.com> wrote:
    > On 7/28/2010 12:18 PM, Robert Hall wrote:
    >
    >
    >
    > > Everything I have tried is below.

    >
    > > When I put a CD in the computer, or plug in a USB flash drive, I don't
    > > get a window asking me what I want to do (play music, open folder to
    > > view files, nothing, etc.) I tested the USB drive on my other
    > > computer, and I get the dialog.

    >
    > > The devices show up in My Computer. If I right click and select
    > > properties, auto-play is enabled for all file types.

    >
    > > Microsoft suggestions tried: http ://support.microsoft.com/kb/330135
    > > 1. Roxio Easy CD Creator is not installed.
    > > 2. HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\CDRom Autorun
    > > = 1
    > > 3. HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies
    > > \Explorer NoDriveTypeAutoRun = 91
    > > 4. HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion
    > > \Winlogon allocatecdroms = 0
    > > 5. The ASUS DRW-014L1T cd/dvd drive has the latest drivers, and is
    > > compatible with XP.

    >
    > > Microsoft autoplay repair wizard: http ://www.microsoft.com/downloads/
    > > details.aspx?familyid=c680a7b6-e8fa-45c4-
    > > a171-1b389cfacdad&displaylang=en#Instructions
    > > 1. Downloaded and ran autofix - if reported a repair, and said to
    > > reboot. No change. Ran tool again, now it says it already ran, and I
    > > need to log on/off before running it again. I logged off/on and also
    > > rebooted several times, and I still get this message.
    > > THIS TOOL IS BUGGY!

    >
    > > Googled suggestions not redundant with the above -

    >
    > > The Microsoft tool APPMDiag is supposed to do a postmortem report on
    > > it's last autoplay when you remove a device - nothing appears in the
    > > window when I take out a USB flash drive or a music CD.

    >
    > > Running gpedit.msc (to open the Group Policy window) :
    > > 1. Local computer policy - User configuration - Administrative
    > > templates - System - Turn off autoplay = disabled
    > > 2. Local computer policy - Computer configuration - Administrative
    > > templates - System - Turn off autoplay = disabled

    >
    > > Any other ideas?

    >
    > TweakUI is a handy control panel with lots of features, including
    > Autorun control.  I would probably install it to see what it says about
    > the current state of settings -- both by Logical Driver Letter *and*
    > Device Type.
    >
    > http://www.microsoft.com/windowsxp/downloads/powertoys/xppowertoys.mspx


    I tried TweakUI. The right drives were preselected for autoplay. The
    drive types were not preselected. I selected both of them, and
    clicked apply. I still don't get the dialog when I plug in the USB
    drive.
     
  5. Robert Hall

    Robert Hall Flightless Bird

    On Jul 28, 3:27 pm, "relic" <relic...@cjb.net> wrote:
    > "Robert Hall" <bobhal...@hotmail.com> wrote in message
    >
    > news:1e24363c-c91e-466b-b32f-56f151ddf89d@c10g2000yqi.googlegroups.com...
    >
    >
    >
    > > Everything I have tried is below.

    >
    > > When I put a CD in the computer, or plug in a USB flash drive, I don't
    > > get a window asking me what I want to do (play music, open folder to
    > > view files, nothing, etc.) I tested the USB drive on my other
    > > computer, and I get the dialog.

    >
    > > The devices show up in My Computer. If I right click and select
    > > properties, auto-play is enabled for all file types.

    >
    > > Microsoft suggestions tried: http ://support.microsoft.com/kb/330135
    > > 1. Roxio Easy CD Creator is not installed.
    > > 2. HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\CDRom Autorun
    > > = 1
    > > 3. HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies
    > > \Explorer NoDriveTypeAutoRun = 91
    > > 4. HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion
    > > \Winlogon allocatecdroms = 0
    > > 5. The ASUS DRW-014L1T cd/dvd drive has the latest drivers, and is
    > > compatible with XP.

    >
    > > Microsoft autoplay repair wizard: http ://www.microsoft.com/downloads/
    > > details.aspx?familyid=c680a7b6-e8fa-45c4-
    > > a171-1b389cfacdad&displaylang=en#Instructions
    > > 1. Downloaded and ran autofix - if reported a repair, and said to
    > > reboot. No change. Ran tool again, now it says it already ran, and I
    > > need to log on/off before running it again. I logged off/on and also
    > > rebooted several times, and I still get this message.
    > > THIS TOOL IS BUGGY!

    >
    > > Googled suggestions not redundant with the above -

    >
    > > The Microsoft tool APPMDiag is supposed to do a postmortem report on
    > > it's last autoplay when you remove a device - nothing appears in the
    > > window when I take out a USB flash drive or a music CD.

    >
    > > Running gpedit.msc (to open the Group Policy window) :
    > > 1. Local computer policy - User configuration - Administrative
    > > templates - System - Turn off autoplay = disabled
    > > 2. Local computer policy - Computer configuration - Administrative
    > > templates - System - Turn off autoplay = disabled

    >
    > > Any other ideas?

    >
    > Clean Install.


    Not happening.
     
  6. Robert Hall

    Robert Hall Flightless Bird

    On Jul 28, 3:27 pm, "relic" <relic...@cjb.net> wrote:
    > "Robert Hall" <bobhal...@hotmail.com> wrote in message
    >
    > news:1e24363c-c91e-466b-b32f-56f151ddf89d@c10g2000yqi.googlegroups.com...
    >
    >
    >
    > > Everything I have tried is below.

    >
    > > When I put a CD in the computer, or plug in a USB flash drive, I don't
    > > get a window asking me what I want to do (play music, open folder to
    > > view files, nothing, etc.) I tested the USB drive on my other
    > > computer, and I get the dialog.

    >
    > > The devices show up in My Computer. If I right click and select
    > > properties, auto-play is enabled for all file types.

    >
    > > Microsoft suggestions tried: http ://support.microsoft.com/kb/330135
    > > 1. Roxio Easy CD Creator is not installed.
    > > 2. HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\CDRom Autorun
    > > = 1
    > > 3. HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies
    > > \Explorer NoDriveTypeAutoRun = 91
    > > 4. HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion
    > > \Winlogon allocatecdroms = 0
    > > 5. The ASUS DRW-014L1T cd/dvd drive has the latest drivers, and is
    > > compatible with XP.

    >
    > > Microsoft autoplay repair wizard: http ://www.microsoft.com/downloads/
    > > details.aspx?familyid=c680a7b6-e8fa-45c4-
    > > a171-1b389cfacdad&displaylang=en#Instructions
    > > 1. Downloaded and ran autofix - if reported a repair, and said to
    > > reboot. No change. Ran tool again, now it says it already ran, and I
    > > need to log on/off before running it again. I logged off/on and also
    > > rebooted several times, and I still get this message.
    > > THIS TOOL IS BUGGY!

    >
    > > Googled suggestions not redundant with the above -

    >
    > > The Microsoft tool APPMDiag is supposed to do a postmortem report on
    > > it's last autoplay when you remove a device - nothing appears in the
    > > window when I take out a USB flash drive or a music CD.

    >
    > > Running gpedit.msc (to open the Group Policy window) :
    > > 1. Local computer policy - User configuration - Administrative
    > > templates - System - Turn off autoplay = disabled
    > > 2. Local computer policy - Computer configuration - Administrative
    > > templates - System - Turn off autoplay = disabled

    >
    > > Any other ideas?

    >
    > Clean Install.


    Not happening.
     
  7. Jack

    Jack Flightless Bird

    Re: Auto-play not working - CD-ROMS and USB drive (tried many suggestions)

    "Robert Hall" <bobhallaz@hotmail.com> wrote in message
    news:6ff86720-9be5-47cd-a6e1-c862c8bd5c2c@k19g2000yqc.googlegroups.com...
    > On Jul 28, 3:27 pm, "relic" <relic...@cjb.net> wrote:
    >> "Robert Hall" <bobhal...@hotmail.com> wrote in message
    >>
    >> news:1e24363c-c91e-466b-b32f-56f151ddf89d@c10g2000yqi.googlegroups.com...
    >>
    >>
    >>
    >> > Everything I have tried is below.

    >>
    >> > When I put a CD in the computer, or plug in a USB flash drive, I don't
    >> > get a window asking me what I want to do (play music, open folder to
    >> > view files, nothing, etc.) I tested the USB drive on my other
    >> > computer, and I get the dialog.

    >>
    >> > The devices show up in My Computer. If I right click and select
    >> > properties, auto-play is enabled for all file types.

    >>
    >> > Microsoft suggestions tried: http ://support.microsoft.com/kb/330135
    >> > 1. Roxio Easy CD Creator is not installed.
    >> > 2. HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\CDRom Autorun
    >> > = 1
    >> > 3. HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies
    >> > \Explorer NoDriveTypeAutoRun = 91
    >> > 4. HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion
    >> > \Winlogon allocatecdroms = 0
    >> > 5. The ASUS DRW-014L1T cd/dvd drive has the latest drivers, and is
    >> > compatible with XP.

    >>
    >> > Microsoft autoplay repair wizard: http ://www.microsoft.com/downloads/
    >> > details.aspx?familyid=c680a7b6-e8fa-45c4-
    >> > a171-1b389cfacdad&displaylang=en#Instructions
    >> > 1. Downloaded and ran autofix - if reported a repair, and said to
    >> > reboot. No change. Ran tool again, now it says it already ran, and I
    >> > need to log on/off before running it again. I logged off/on and also
    >> > rebooted several times, and I still get this message.
    >> > THIS TOOL IS BUGGY!

    >>
    >> > Googled suggestions not redundant with the above -

    >>
    >> > The Microsoft tool APPMDiag is supposed to do a postmortem report on
    >> > it's last autoplay when you remove a device - nothing appears in the
    >> > window when I take out a USB flash drive or a music CD.

    >>
    >> > Running gpedit.msc (to open the Group Policy window) :
    >> > 1. Local computer policy - User configuration - Administrative
    >> > templates - System - Turn off autoplay = disabled
    >> > 2. Local computer policy - Computer configuration - Administrative
    >> > templates - System - Turn off autoplay = disabled

    >>
    >> > Any other ideas?

    >>
    >> Clean Install.

    >
    > Not happening.


    It will eventually if you want it fixed. Take relic's advice and fix it...
    then stop messing with it.
     
  8. Robert Hall

    Robert Hall Flightless Bird

    On Jul 28, 3:27 pm, "relic" <relic...@cjb.net> wrote:
    > "Robert Hall" <bobhal...@hotmail.com> wrote in message
    >
    > news:1e24363c-c91e-466b-b32f-56f151ddf89d@c10g2000yqi.googlegroups.com...
    >
    >
    >
    > > Everything I have tried is below.

    >
    > > When I put a CD in the computer, or plug in a USB flash drive, I don't
    > > get a window asking me what I want to do (play music, open folder to
    > > view files, nothing, etc.) I tested the USB drive on my other
    > > computer, and I get the dialog.

    >
    > > The devices show up in My Computer. If I right click and select
    > > properties, auto-play is enabled for all file types.

    >
    > > Microsoft suggestions tried: http ://support.microsoft.com/kb/330135
    > > 1. Roxio Easy CD Creator is not installed.
    > > 2. HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\CDRom Autorun
    > > = 1
    > > 3. HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies
    > > \Explorer NoDriveTypeAutoRun = 91
    > > 4. HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion
    > > \Winlogon allocatecdroms = 0
    > > 5. The ASUS DRW-014L1T cd/dvd drive has the latest drivers, and is
    > > compatible with XP.

    >
    > > Microsoft autoplay repair wizard: http ://www.microsoft.com/downloads/
    > > details.aspx?familyid=c680a7b6-e8fa-45c4-
    > > a171-1b389cfacdad&displaylang=en#Instructions
    > > 1. Downloaded and ran autofix - if reported a repair, and said to
    > > reboot. No change. Ran tool again, now it says it already ran, and I
    > > need to log on/off before running it again. I logged off/on and also
    > > rebooted several times, and I still get this message.
    > > THIS TOOL IS BUGGY!

    >
    > > Googled suggestions not redundant with the above -

    >
    > > The Microsoft tool APPMDiag is supposed to do a postmortem report on
    > > it's last autoplay when you remove a device - nothing appears in the
    > > window when I take out a USB flash drive or a music CD.

    >
    > > Running gpedit.msc (to open the Group Policy window) :
    > > 1. Local computer policy - User configuration - Administrative
    > > templates - System - Turn off autoplay = disabled
    > > 2. Local computer policy - Computer configuration - Administrative
    > > templates - System - Turn off autoplay = disabled

    >
    > > Any other ideas?

    >
    > Clean Install.


    Not happening.
     
  9. Robert Hall

    Robert Hall Flightless Bird

    On Jul 28, 3:55 pm, "Jack" <nos...@invalid.not> wrote:
    > "Robert Hall" <bobhal...@hotmail.com> wrote in message
    >
    > news:6ff86720-9be5-47cd-a6e1-c862c8bd5c2c@k19g2000yqc.googlegroups.com...
    >
    > -------- SNIP ----------
    >
    > >> Clean Install.

    >
    > > Not happening.

    >
    > It will eventually if you want it fixed. Take relic's advice and fix it....
    > then stop messing with it.


    If it will take a re-install of the O/S then it will never be fixed.
    I'll just open the CD/DVD/USB drive in My Computer.
    There is just too much software, and too much hardware configuration
    to make it worth it.
     
  10. Robert Hall

    Robert Hall Flightless Bird

    On Jul 28, 3:55 pm, "Jack" <nos...@invalid.not> wrote:
    > "Robert Hall" <bobhal...@hotmail.com> wrote in message
    >
    > news:6ff86720-9be5-47cd-a6e1-c862c8bd5c2c@k19g2000yqc.googlegroups.com...
    >
    > -------- SNIP ----------
    >
    > >> Clean Install.

    >
    > > Not happening.

    >
    > It will eventually if you want it fixed. Take relic's advice and fix it....
    > then stop messing with it.


    If it will take a re-install of the O/S then it will never be fixed.
    I'll just open the CD/DVD/USB drive in My Computer.
    There is just too much software, and too much hardware configuration
    to make it worth it.
     
  11. Patok

    Patok Flightless Bird

    Re: Auto-play not working - CD-ROMS and USB drive (tried many suggestions)

    Robert Hall wrote:
    > Everything I have tried is below.


    <snip>

    I don't have any advice to help you, but I'm genuinely curios - why
    do you need auto-play? All people I know have actively disabled it. I
    consider it highly annoying, and a security risk. From what I remember,
    one of the primary reasons I had for installing TweakUI was to make sure
    it is disabled, and (especially) flash drives would never autorun.
    I think you should consider it a blessing in disguise. :)

    --
    You'd be crazy to e-mail me with the crazy. But leave the div alone.
    --
    Whoever bans a book, shall be banished. Whoever burns a book, shall burn.
     
  12. Uwe Sieber

    Uwe Sieber Flightless Bird

  13. ju.c

    ju.c Flightless Bird

    Re: Auto-play not working - CD-ROMS and USB drive (tried many suggestions)

    Windows XP Autoplay Repairing Tutorial


    Autoplay requires the Shell Hardware Detection service, make sure
    it's set to automatic and is running. To access Services, open the
    Run box and enter: %SystemRoot%\System32\services.msc /s

    =================================================
    CD-ROM May Not Run Automatically in Windows XP
    http://support.microsoft.com/kb/314855

    The Autorun.inf file and the programs that the Autorun.inf file is
    designed to run may not run if you are logged on to Windows XP as
    a user without either Power User or Administrator rights.
    By default, only users who are logged on to Windows XP with Power
    User or Administrator rights are allowed to install software. In
    Windows XP, files that have an .inf extension are considered to be
    setup information files. As a result, the Autorun.inf file does not
    run if you do not have Power User or Administrator rights.

    =================================================
    Make sure that this registry value is set to 0:

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]
    "allocatecdroms"="0"

    And that this one is set as shown:

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Cdrom]
    "Start"=dword:00000001
    "Autorun"=dword:00000001

    =================================================
    How to restore Autoplay to its default settings:

    Enable/Disable Autoplay in Windows XP
    http://www.typhoonsoftware.com/configxp.htm

    =================================================
    Disable Autorun while keeping all the functionality of Autoplay!

    1. Copy below and paste into Notepad.

    ----------copy inside only----------
    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\IniFileMapping\Autorun.inf]
    @="@SYS:DoesNotExist"

    [-HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\MountPoints2]
    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\MountPoints2]

    ----------copy inside only----------

    2. Save-as Autorun_Disable.reg (or any name + .reg)

    3. Double-click or right-click and merge into the registry.

    The effect is immediate, no restart or logoff required.

    =================================================
    The BEST software for fixing autoplay:

    Autoplay Repair Wizard 77 KB (Freeware)
    http://www.microsoft.com/downloads/...b6-e8fa-45c4-a171-1b389cfacdad&DisplayLang=en

    AutoPlayConfig 164 KB (Freeware)
    Web: http://www.typhoonsoftware.com/autoplayconfig.htm
    Download: http://www.autoruntyphoon.com/AutoPlayConfig.zip

    Autoplay Repair 225 KB (Freeware)
    Main page: http://www-stud.uni-essen.de/~sddabacz/prog.php?id=apr
    Homepage: http://www.orangeblue.net.ms/
    Download: http://www-stud.uni-essen.de/~sddabacz/apr/APR.zip

    CleanHandlers 73 KB (Freeware)
    Web: http://windowsxp.mvps.org/autoplayhandlers.htm
    Download: http://windowsxp.mvps.org/utils/cleanhandlers_2_4.zip

    AutoRun Settings 11 KB (Freeware)
    Web: http://www.uwe-sieber.de/drivetools_e.html
    Download: http://www.uwe-sieber.de/files/autorunsettings.zip


    ju.c


    "Robert Hall" <bobhallaz@hotmail.com> wrote in message news:1e24363c-c91e-466b-b32f-56f151ddf89d@c10g2000yqi.googlegroups.com...
    > Everything I have tried is below.
    >
    > When I put a CD in the computer, or plug in a USB flash drive, I don't
    > get a window asking me what I want to do (play music, open folder to
    > view files, nothing, etc.) I tested the USB drive on my other
    > computer, and I get the dialog.
    >
    > The devices show up in My Computer. If I right click and select
    > properties, auto-play is enabled for all file types.
    >
    > Microsoft suggestions tried: http ://support.microsoft.com/kb/330135
    > 1. Roxio Easy CD Creator is not installed.
    > 2. HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\CDRom Autorun
    > = 1
    > 3. HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies
    > \Explorer NoDriveTypeAutoRun = 91
    > 4. HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion
    > \Winlogon allocatecdroms = 0
    > 5. The ASUS DRW-014L1T cd/dvd drive has the latest drivers, and is
    > compatible with XP.
    >
    > Microsoft autoplay repair wizard: http ://www.microsoft.com/downloads/
    > details.aspx?familyid=c680a7b6-e8fa-45c4-
    > a171-1b389cfacdad&displaylang=en#Instructions
    > 1. Downloaded and ran autofix - if reported a repair, and said to
    > reboot. No change. Ran tool again, now it says it already ran, and I
    > need to log on/off before running it again. I logged off/on and also
    > rebooted several times, and I still get this message.
    > THIS TOOL IS BUGGY!
    >
    > Googled suggestions not redundant with the above -
    >
    > The Microsoft tool APPMDiag is supposed to do a postmortem report on
    > it's last autoplay when you remove a device - nothing appears in the
    > window when I take out a USB flash drive or a music CD.
    >
    > Running gpedit.msc (to open the Group Policy window) :
    > 1. Local computer policy - User configuration - Administrative
    > templates - System - Turn off autoplay = disabled
    > 2. Local computer policy - Computer configuration - Administrative
    > templates - System - Turn off autoplay = disabled
    >
    > Any other ideas?
     
  14. ju.c

    ju.c Flightless Bird

    Re: Auto-play not working - CD-ROMS and USB drive (tried many suggestions)

    Re:
    Microsoft autoplay repair wizard ...
    Ran tool again, now it says it already ran, and I
    need to log on/off before running it again. I logged
    off/on and also rebooted several times, and I still
    get this message. THIS TOOL IS BUGGY!


    Just delete this text file in the "My Documents" folder:
    AutoFix_XXXX-XX-XX_XX-XX-XX.txt
    You'll be able to run the AutoFix tool again with no problem.


    ju.c


    "Robert Hall" <bobhallaz@hotmail.com> wrote in message news:1e24363c-c91e-466b-b32f-56f151ddf89d@c10g2000yqi.googlegroups.com...
    > Everything I have tried is below.
    >
    > When I put a CD in the computer, or plug in a USB flash drive, I don't
    > get a window asking me what I want to do (play music, open folder to
    > view files, nothing, etc.) I tested the USB drive on my other
    > computer, and I get the dialog.
    >
    > The devices show up in My Computer. If I right click and select
    > properties, auto-play is enabled for all file types.
    >
    > Microsoft suggestions tried: http ://support.microsoft.com/kb/330135
    > 1. Roxio Easy CD Creator is not installed.
    > 2. HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\CDRom Autorun
    > = 1
    > 3. HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies
    > \Explorer NoDriveTypeAutoRun = 91
    > 4. HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion
    > \Winlogon allocatecdroms = 0
    > 5. The ASUS DRW-014L1T cd/dvd drive has the latest drivers, and is
    > compatible with XP.
    >
    > Microsoft autoplay repair wizard: http ://www.microsoft.com/downloads/
    > details.aspx?familyid=c680a7b6-e8fa-45c4-
    > a171-1b389cfacdad&displaylang=en#Instructions
    > 1. Downloaded and ran autofix - if reported a repair, and said to
    > reboot. No change. Ran tool again, now it says it already ran, and I
    > need to log on/off before running it again. I logged off/on and also
    > rebooted several times, and I still get this message.
    > THIS TOOL IS BUGGY!
    >
    > Googled suggestions not redundant with the above -
    >
    > The Microsoft tool APPMDiag is supposed to do a postmortem report on
    > it's last autoplay when you remove a device - nothing appears in the
    > window when I take out a USB flash drive or a music CD.
    >
    > Running gpedit.msc (to open the Group Policy window) :
    > 1. Local computer policy - User configuration - Administrative
    > templates - System - Turn off autoplay = disabled
    > 2. Local computer policy - Computer configuration - Administrative
    > templates - System - Turn off autoplay = disabled
    >
    > Any other ideas?
     
  15. Robert Hall

    Robert Hall Flightless Bird

    On Jul 28, 8:09 pm, Patok <crazy.div.pa...@gmail.com> wrote:
    > Robert Hall wrote:
    > > Everything I have tried is below.

    >
    > <snip>
    >
    >    I don't have any advice to help you, but I'm genuinely curios - why
    > do you need auto-play? All people I know have actively disabled it. I
    > consider it highly annoying, and a security risk. From what I remember,
    > one of the primary reasons I had for installing TweakUI was to make sure
    > it is disabled, and (especially) flash drives would never autorun.
    >    I think you should consider it a blessing in disguise. :)
    >


    Because I don't like to have to goto My Computer when I plug in a USB
    flash drive or CD. I should get the menu, what to do? - I don't ever
    select "remember" - so it's actually not auto-playing anything...
     

Share This Page