1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Thinkpad x60 screen replacement problem / power problems......computerwon't start

Discussion in 'Notebooks' started by bman, Jan 11, 2010.

  1. bman

    bman Flightless Bird

    'll try and be as brief as possible........without leaving out
    important details.

    Thinkpad x60 Type: 1709-7HU

    I attempted to replace the broken screen......Compute worked fine with
    the existing cracked one.

    Ordered a new screen......(non OEM) didn't work sent it back
    and.......Ordered another non OEM.....also didn't work....now both
    screens the broken and new do not work.

    The computer powers on and shutsdown strait away......Can't power back
    on unless power is removed (no battery) and plugged back in.

    I noticed the small what apears to be a ground cable on the LCD ribbon
    cable, attaches to the bottom frame near the inverter...... is
    torn.....

    I replaced the ribbon cable with OEM IBM replacement.

    The computer works fine if no LCD installed or just the power to the
    LCD is on.

    Computer won't power on (starts and shutsdown 1 second approx) with
    just the ribbon cable attached to the new or old LCD (NO power to the
    LCD).

    What happened?...........Has the torn part of the ribbon cable before
    i replaced it killed the video output on the motherboard?

    Any help would be appreciated............very frustrated...........

    Thank you......
     
  2. the wharf rat

    the wharf rat Flightless Bird

    In article <1d45637c-29c6-40b5-86d6-763a7225c82c@m11g2000vbo.googlegroups.com>,
    bman <brianhubley001@gmail.com> wrote:
    >
    >What happened?...........Has the torn part of the ribbon cable before
    >i replaced it killed the video output on the motherboard?
    >


    Ummm, no, :) you probably goofed up a connection inside the top
    lid when you were replacing the LCD or have an LCD that LOOKS like the
    right part but isn't. You've tried reseating and checking the orientation
    of the lcd cable connector right?

    X60's give beep codes. Do you get any beep code?
     
  3. bman

    bman Flightless Bird

    Re: Thinkpad x60 screen replacement problem / powerproblems......computer won't start

    Well I've tried two differn't aftermarket LCD displays. both have not
    worked. Now the original display will not work either.........I have
    checked the cable connector (brand new ribbion cable from the LCD to
    the M8).

    They look like they are seated correctly after trying a few times,
    however I could check again........They are these tiny metal tabs that
    needed moving when i removed the original display. If not seated
    correctly this would explain my problem.

    No beep codes.......just powers on.....lights flash on the
    inverter......then powers off strait away......have to remove power
    cable to get it to power on again.

    Goofing up a connection in the top lid sounds possible.

    Other then the little keyboard light........There is a small what
    appears to be a sensor off the ribbon cable. Not sure what it does.
    Small H shape. It resides in the main frame behind keyboard, under the
    LCD frame.

    Thank you very much for your help. If you have any other ideas based
    on the further info i provided let me know.........thanx again.



    On Jan 10, 9:38 pm, w...@panix.com (the wharf rat) wrote:
    > In article <1d45637c-29c6-40b5-86d6-763a7225c...@m11g2000vbo.googlegroups..com>,
    >
    > bman  <brianhubley...@gmail.com> wrote:
    >
    > >What happened?...........Has the torn part of the ribbon cable before
    > >i replaced it killed the video output on the motherboard?

    >
    >         Ummm, no, :) you probably goofed up a connection inside the top
    > lid when you were replacing the LCD or have an LCD that LOOKS like the
    > right part but isn't.  You've tried reseating and checking the orientation
    > of the lcd cable connector right?
    >
    >         X60's give beep codes.  Do you get any beep code?  
     
  4. the wharf rat

    the wharf rat Flightless Bird

    Re: Thinkpad x60 screen replacement problem / powerproblems......computer won't start

    In article <d84a80f2-b4e4-4c49-a08d-8feb5820dcae@k22g2000vbp.googlegroups.com>,
    bman <brianhubley001@gmail.com> wrote:
    >
    >Thank you very much for your help. If you have any other ideas based
    >on the further info i provided let me know.........thanx again.
    >


    Bent pin in the motherboard connector?
     
  5. bman

    bman Flightless Bird

    Re: Thinkpad x60 screen replacement problem / powerproblems......computer won't start

    I have dentist type glasses to see that kind of thing in very good
    detail. Everything looks fine to me.

    I tried again today triple checking everything.

    Here are some links to picture I took of the broken cable: (maybe this
    will help, perhaps with seeing it someone will know what happened, as
    something did go very wrong......3 screens later and it still will not
    function.....even with no power going to the screen....just the brand
    new ribbon cable installed......even tried the old one again.

    http://i254.photobucket.com/albums/hh89/bmanjeep101/DSCN5618.jpg
    http://i254.photobucket.com/albums/hh89/bmanjeep101/DSCN5619.jpg

    http://i254.photobucket.com/albums/hh89/bmanjeep101/DSCN5620.jpg


    On Jan 11, 7:30 pm, w...@panix.com (the wharf rat) wrote:
    > In article <d84a80f2-b4e4-4c49-a08d-8feb5820d...@k22g2000vbp.googlegroups..com>,
    >
    > bman  <brianhubley...@gmail.com> wrote:
    >
    > >Thank you very much for your help. If you have any other ideas based
    > >on the further info i provided let me know.........thanx again.

    >
    >         Bent pin in the motherboard connector?
     
  6. the wharf rat

    the wharf rat Flightless Bird

    Re: Thinkpad x60 screen replacement problem / powerproblems......computer won't start

    In article <66031b81-af9c-4e95-b809-ed7bd26cdf56@d7g2000vbs.googlegroups.com>,
    bman <brianhubley001@gmail.com> wrote:
    >
    >something did go very wrong......3 screens later and it still will not
    >function.....even with no power going to the screen....just the brand
    >new ribbon cable installed......even tried the old one again.
    >


    Are you *sure* you got that LIF socket on the back of the LCD
    right? Those are a real pain...

    Also, ummmm, are you SURE you have the right ribbon cable? The
    one in your picture doesn't look right to me. You need FRU 91P6972. The
    thing you have labeled "mystery connector" isn't on mine...
     
  7. goldentiger

    goldentiger Flightless Bird

    Did you get the problem solved? I am having the same situation now.
    bman;1163537 Wrote:
    > 'll try and be as brief as possible........without leaving out
    > important details.
    >
    > Thinkpad x60 Type: 1709-7HU
    >
    > I attempted to replace the broken screen......Compute worked fine with
    > the existing cracked one.
    >
    > Ordered a new screen......(non OEM) didn't work sent it back
    > and.......Ordered another non OEM.....also didn't work....now both
    > screens the broken and new do not work.
    >
    > The computer powers on and shutsdown strait away......Can't power back
    > on unless power is removed (no battery) and plugged back in.
    >
    > I noticed the small what apears to be a ground cable on the LCD ribbon
    > cable, attaches to the bottom frame near the inverter...... is
    > torn.....
    >
    > I replaced the ribbon cable with OEM IBM replacement.
    >
    > The computer works fine if no LCD installed or just the power to the
    > LCD is on.
    >
    > Computer won't power on (starts and shutsdown 1 second approx) with
    > just the ribbon cable attached to the new or old LCD (NO power to the
    > LCD).
    >
    > What happened?...........Has the torn part of the ribbon cable before
    > i replaced it killed the video output on the motherboard?
    >
     

Share This Page