1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

solved IE8

Discussion in 'Internet Explorer' started by pan jap, Aug 11, 2010.

  1. pan jap

    pan jap Flightless Bird

    John/Alex

    I got the same problem but now it was solved

    This happen because IE7/8 still has a cache on proxy setting (IE: if you set proxy manually).

    The method to solve is



    1. Tools->Internet Options->Advanced->Reset
    2. Closed IE and re-opened it


    to clear everything on IE, then when you set DHCP 252 and DNS. It will work. IE will use DHCP, Firefox will use DNS.

    ..

    > On Thursday, February 05, 2009 2:17 AM Ale wrote:


    > Hi,
    >
    > I have a problem affecting every workstation in the domain. IE7 will not
    > automatically detect the proxy server using WPAD & DHCP.
    >
    > Here is the situation.
    >
    > - IE7 browser is set to "Automatically Detect Settings"
    > - DHCP is setup with option 252 providing URL to wpad.dat file
    > - URL is correct and wpad.dat file can be downloaded manually from browser
    >
    > I have run Wireshark on a PC and captured the following sequence.
    >
    > 1 - PC sends DHCP Inform request
    > 2 - Server DHCP ACK responds including option 252 and full wpad.dat URL
    > 3 - PC goes onto to perform DNS query for "wpad.mydomain.com" etc.
    >
    > Now from what I know IE7 should not attempt to do a DNS lookup if it
    > retrieved the WPAD URL from DHCP. I know for a fact it retrieved the URL but
    > for some reason it is not actually attempting to GET the wpad.dat file.
    >
    > I have scoured every forum and article on the web I could find and found
    > nothing referring to this. Most suggestions are around using DNS instead. I
    > do NOT want to use DNS.
    >
    > I have tried the following.
    >
    > - Removing all group policies from the workstation
    > - Purging entries from the following reg key:
    > HKCU\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Connections
    > - Disabling Automatic Proxy Results Caching with the following reg key:
    > HKCU\Software\Policies\Microsoft\Windows\CurrentVersion\Internet
    > Settings]"EnableAutoProxyResultCache"
    >
    > Has anyone come across anything like this? And can help?
    >
    > Many Thanks,
    > Alex.



    >> On Thursday, February 05, 2009 2:42 AM Ale wrote:


    >> Oh yes and I have also confirmed the wpad.dat URL is all in lowercase (as per
    >> http://support.microsoft.com/kb/307502)
    >>
    >> Thanks.
    >>
    >> "Alex" wrote:



    >>> On Friday, February 13, 2009 12:05 PM EightBit wrote:


    >>> Any luck with this?
    >>>
    >>> I have been working on the same issue for a while now and cannot figure out
    >>> why the PC is not using the wpad.dat files.
    >>>
    >>> "Alex" wrote:



    >>>> On Tuesday, March 10, 2009 12:52 PM john oconnor wrote:


    >>>> Hi Alex,
    >>>>
    >>>>
    >>>>
    >>>> I'm having the exact same issue, the only difference is that I use wpad with DNS and not DHCP.
    >>>>
    >>>>
    >>>>
    >>>> The issue is only happening on some sites and only on certain pages within those sites.
    >>>>
    >>>>
    >>>>
    >>>> Here are the sequence of events:
    >>>>
    >>>>
    >>>>
    >>>> 1. We have auto-detect settings with a wpad dns entry pointing to our ISA2006 proxy server
    >>>>
    >>>> 2. Launch a website and click on a link
    >>>>
    >>>> 3. Message is: Page cannot be displayed
    >>>>
    >>>> 4. Page is retrieved perfectly when using firefox with wpad or any other browser or with IE6 and wpad.
    >>>>
    >>>> When used with IE7 or IE8 it fails when auto detect is enabled. If I put in the hostname of the proxy it works ok.
    >>>>
    >>>> 5. If you try to launch another site within this now failed session you cannot view that site. If you close the session (browser) and relaunch you can get to the site i.e. google
    >>>>
    >>>> 6. Results from a packet sniff is that the workstation is trying to retrieve the page directly from teh Internet and is bypassing wpad. Obviously, the workstation does not have a rule to bypass the Firewall and thus fails.
    >>>>
    >>>>
    >>>>
    >>>> I cannot understand why it is trying to bypass wpad and get the page directly and why it only happens with IE 7 or IE 8.
    >>>>
    >>>>
    >>>>
    >>>> Any help would be great because we due to roll out shortly and I do not want to remove auto-detect/wpad because it works grea, especially for remote users.
    >>>>
    >>>>
    >>>>
    >>>> Thanks,
    >>>>
    >>>> John.



    >>>>> On Tuesday, March 10, 2009 12:54 PM john oconnor wrote:


    >>>>> Hi Alex,
    >>>>>
    >>>>>
    >>>>>
    >>>>> I'm having the exact same issue, the only difference is that I use wpad with DNS and not DHCP.
    >>>>>
    >>>>>
    >>>>>
    >>>>> The issue is only happening on some sites and only on certain pages within those sites.
    >>>>>
    >>>>>
    >>>>>
    >>>>> Here are the sequence of events:
    >>>>>
    >>>>>
    >>>>>
    >>>>> 1. We have auto-detect settings with a wpad dns entry pointing to our ISA2006 proxy server
    >>>>>
    >>>>> 2. Launch a website and click on a link
    >>>>>
    >>>>> 3. Message is: Page cannot be displayed
    >>>>>
    >>>>> 4. Page is retrieved perfectly when using firefox with wpad or any other browser or with IE6 and wpad.
    >>>>>
    >>>>> When used with IE7 or IE8 it fails when auto detect is enabled. If I put in the hostname of the proxy it works ok.
    >>>>>
    >>>>> 5. If you try to launch another site within this now failed session you cannot view that site. If you close the session (browser) and relaunch you can get to the site i.e. google
    >>>>>
    >>>>> 6. Results from a packet sniff is that the workstation is trying to retrieve the page directly from teh Internet and is bypassing wpad. Obviously, the workstation does not have a rule to bypass the Firewall and thus fails.
    >>>>>
    >>>>>
    >>>>>
    >>>>> I cannot understand why it is trying to bypass wpad and get the page directly and why it only happens with IE 7 or IE 8.
    >>>>>
    >>>>>
    >>>>>
    >>>>> Any help would be great because we due to roll out shortly and I do not want to remove auto-detect/wpad because it works grea, especially for remote users.
    >>>>>
    >>>>>
    >>>>>
    >>>>> Thanks,
    >>>>>
    >>>>> John.



    >>>>>> On Saturday, April 11, 2009 12:28 PM reinerzufall1 wrote:


    >>>>>> I've found a solution:
    >>>>>> This KB article http://support.microsoft.com/kb/928233/en-us describes
    >>>>>> a different problem but pointed to the right direction.
    >>>>>>
    >>>>>> To solve the problem follow these steps:
    >>>>>> When setting the
    >>>>>>
    >>>>>> Change the value of the entry "DhcpConnForceBroadcastFlag" under the
    >>>>>> following registry key from 1 to 0 (default value is 1).
    >>>>>> HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters
    >>>>>> \Interfaces\{GUID of your NIC}
    >>>>>> This key should already exist. If not create it as REG_DWORD (32 Bit)
    >>>>>>
    >>>>>> Then delete the entry "DefaultConnectionSettings" from the following
    >>>>>> registry key:
    >>>>>> HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet
    >>>>>> Settings\Connections
    >>>>>>
    >>>>>> Then reboot your computer (you can also just restart the services
    >>>>>> "DHCP" and "WinHttpAutoProxySvc").
    >>>>>>
    >>>>>> After that Internet Explorer queries DHCP for WPAD (Windows sends out
    >>>>>> a DHCP inform packet to the DHCP server).
    >>>>>>
    >>>>>> Hope this helps others
    >>>>>> Reiner



    >>>>>>> On Wednesday, May 13, 2009 11:09 PM Alex wrote:


    >>>>>>> You are required to be a member to post replies. After logging in or becoming a member, you will be redirected back to this page.



    >>>>>>>> On Wednesday, May 13, 2009 11:12 PM Alex wrote:


    >>>>>>>> Hi John,
    >>>>>>>>
    >>>>>>>> Confirmed this is happening with both IE7 and IE8. Unfortunately I have no answer yet as to why it is not working.
    >>>>>>>>
    >>>>>>>> I hope you have had better luck.
    >>>>>>>>
    >>>>>>>> Thanks,
    >>>>>>>> Alex.



    >>>>>>>>> On Thursday, February 18, 2010 4:04 AM Hans Peter Schoepf wrote:


    >>>>>>>>> Hello,
    >>>>>>>>>
    >>>>>>>>>
    >>>>>>>>>
    >>>>>>>>> Did someone of you found a solution for this problem?
    >>>>>>>>>
    >>>>>>>>> I have the same problem with two x64 WinXp clients.
    >>>>>>>>>
    >>>>>>>>> Both are gettings the wpad.dat information from the
    >>>>>>>>>
    >>>>>>>>> DHCP Server but it seems the IE cannt handle this
    >>>>>>>>>
    >>>>>>>>> informations well and starts to make some dns requests.
    >>>>>>>>>
    >>>>>>>>> When is insert the location of the wpad.dat file manually, the clients can use it.
    >>>>>>>>>
    >>>>>>>>> Strange things....are happening sometimes:)
    >>>>>>>>>
    >>>>>>>>> Thank you very much



    >>>>>>>>> Submitted via EggHeadCafe - Software Developer Portal of Choice
    >>>>>>>>> Excel Identifying which formulas are slowing down workbook recalaculation
    >>>>>>>>> http://www.eggheadcafe.com/tutorial...are-slowing-down-workbook-recalaculation.aspx
     
  2. Penn E. Loafer

    Penn E. Loafer Flightless Bird

    You HoopleHead EggHeader!
    Do you think someone who posted in early 2009 is coming back to read your
    comments, especially since you changed the subject?

    When are you people going to learn how to use a newsgroup/forum?

    "pan jap" <panjap1@yahoo.com> wrote in message
    news:2010811212159usenet@eggheadcafe.com...
    > John/Alex
    >
    > I got the same problem but now it was solved
    >
    > This happen because IE7/8 still has a cache on proxy setting (IE: if you
    > set proxy manually).
    >
    > The method to solve is
    >
    >
    >
    > 1. Tools->Internet Options->Advanced->Reset
    > 2. Closed IE and re-opened it
    >
    >
    > to clear everything on IE, then when you set DHCP 252 and DNS. It will
    > work. IE will use DHCP, Firefox will use DNS.
    >
    > .
    >
    >> On Thursday, February 05, 2009 2:17 AM Ale wrote:

    >
    >> Hi,
    >>
    >> I have a problem affecting every workstation in the domain. IE7 will not
    >> automatically detect the proxy server using WPAD & DHCP.
    >>
    >> Here is the situation.
    >>
    >> - IE7 browser is set to "Automatically Detect Settings"
    >> - DHCP is setup with option 252 providing URL to wpad.dat file
    >> - URL is correct and wpad.dat file can be downloaded manually from
    >> browser
    >>
    >> I have run Wireshark on a PC and captured the following sequence.
    >>
    >> 1 - PC sends DHCP Inform request
    >> 2 - Server DHCP ACK responds including option 252 and full wpad.dat URL
    >> 3 - PC goes onto to perform DNS query for "wpad.mydomain.com" etc.
    >>
    >> Now from what I know IE7 should not attempt to do a DNS lookup if it
    >> retrieved the WPAD URL from DHCP. I know for a fact it retrieved the URL
    >> but
    >> for some reason it is not actually attempting to GET the wpad.dat file.
    >>
    >> I have scoured every forum and article on the web I could find and found
    >> nothing referring to this. Most suggestions are around using DNS instead.
    >> I
    >> do NOT want to use DNS.
    >>
    >> I have tried the following.
    >>
    >> - Removing all group policies from the workstation
    >> - Purging entries from the following reg key:
    >> HKCU\Software\Microsoft\Windows\CurrentVersion\Internet
    >> Settings\Connections
    >> - Disabling Automatic Proxy Results Caching with the following reg key:
    >> HKCU\Software\Policies\Microsoft\Windows\CurrentVersion\Internet
    >> Settings]"EnableAutoProxyResultCache"
    >>
    >> Has anyone come across anything like this? And can help?
    >>
    >> Many Thanks,
    >> Alex.

    >
    >
    >>> On Thursday, February 05, 2009 2:42 AM Ale wrote:

    >
    >>> Oh yes and I have also confirmed the wpad.dat URL is all in lowercase
    >>> (as per
    >>> http://support.microsoft.com/kb/307502)
    >>>
    >>> Thanks.
    >>>
    >>> "Alex" wrote:

    >
    >
    >>>> On Friday, February 13, 2009 12:05 PM EightBit wrote:

    >
    >>>> Any luck with this?
    >>>>
    >>>> I have been working on the same issue for a while now and cannot figure
    >>>> out
    >>>> why the PC is not using the wpad.dat files.
    >>>>
    >>>> "Alex" wrote:

    >
    >
    >>>>> On Tuesday, March 10, 2009 12:52 PM john oconnor wrote:

    >
    >>>>> Hi Alex,
    >>>>>
    >>>>>
    >>>>>
    >>>>> I'm having the exact same issue, the only difference is that I use
    >>>>> wpad with DNS and not DHCP.
    >>>>>
    >>>>>
    >>>>>
    >>>>> The issue is only happening on some sites and only on certain pages
    >>>>> within those sites.
    >>>>>
    >>>>>
    >>>>>
    >>>>> Here are the sequence of events:
    >>>>>
    >>>>>
    >>>>>
    >>>>> 1. We have auto-detect settings with a wpad dns entry pointing to our
    >>>>> ISA2006 proxy server
    >>>>>
    >>>>> 2. Launch a website and click on a link
    >>>>>
    >>>>> 3. Message is: Page cannot be displayed
    >>>>>
    >>>>> 4. Page is retrieved perfectly when using firefox with wpad or any
    >>>>> other browser or with IE6 and wpad.
    >>>>>
    >>>>> When used with IE7 or IE8 it fails when auto detect is enabled. If I
    >>>>> put in the hostname of the proxy it works ok.
    >>>>>
    >>>>> 5. If you try to launch another site within this now failed session
    >>>>> you cannot view that site. If you close the session (browser) and
    >>>>> relaunch you can get to the site i.e. google
    >>>>>
    >>>>> 6. Results from a packet sniff is that the workstation is trying to
    >>>>> retrieve the page directly from teh Internet and is bypassing wpad.
    >>>>> Obviously, the workstation does not have a rule to bypass the Firewall
    >>>>> and thus fails.
    >>>>>
    >>>>>
    >>>>>
    >>>>> I cannot understand why it is trying to bypass wpad and get the page
    >>>>> directly and why it only happens with IE 7 or IE 8.
    >>>>>
    >>>>>
    >>>>>
    >>>>> Any help would be great because we due to roll out shortly and I do
    >>>>> not want to remove auto-detect/wpad because it works grea, especially
    >>>>> for remote users.
    >>>>>
    >>>>>
    >>>>>
    >>>>> Thanks,
    >>>>>
    >>>>> John.

    >
    >
    >>>>>> On Tuesday, March 10, 2009 12:54 PM john oconnor wrote:

    >
    >>>>>> Hi Alex,
    >>>>>>
    >>>>>>
    >>>>>>
    >>>>>> I'm having the exact same issue, the only difference is that I use
    >>>>>> wpad with DNS and not DHCP.
    >>>>>>
    >>>>>>
    >>>>>>
    >>>>>> The issue is only happening on some sites and only on certain pages
    >>>>>> within those sites.
    >>>>>>
    >>>>>>
    >>>>>>
    >>>>>> Here are the sequence of events:
    >>>>>>
    >>>>>>
    >>>>>>
    >>>>>> 1. We have auto-detect settings with a wpad dns entry pointing to our
    >>>>>> ISA2006 proxy server
    >>>>>>
    >>>>>> 2. Launch a website and click on a link
    >>>>>>
    >>>>>> 3. Message is: Page cannot be displayed
    >>>>>>
    >>>>>> 4. Page is retrieved perfectly when using firefox with wpad or any
    >>>>>> other browser or with IE6 and wpad.
    >>>>>>
    >>>>>> When used with IE7 or IE8 it fails when auto detect is enabled. If I
    >>>>>> put in the hostname of the proxy it works ok.
    >>>>>>
    >>>>>> 5. If you try to launch another site within this now failed session
    >>>>>> you cannot view that site. If you close the session (browser) and
    >>>>>> relaunch you can get to the site i.e. google
    >>>>>>
    >>>>>> 6. Results from a packet sniff is that the workstation is trying to
    >>>>>> retrieve the page directly from teh Internet and is bypassing wpad.
    >>>>>> Obviously, the workstation does not have a rule to bypass the
    >>>>>> Firewall and thus fails.
    >>>>>>
    >>>>>>
    >>>>>>
    >>>>>> I cannot understand why it is trying to bypass wpad and get the page
    >>>>>> directly and why it only happens with IE 7 or IE 8.
    >>>>>>
    >>>>>>
    >>>>>>
    >>>>>> Any help would be great because we due to roll out shortly and I do
    >>>>>> not want to remove auto-detect/wpad because it works grea, especially
    >>>>>> for remote users.
    >>>>>>
    >>>>>>
    >>>>>>
    >>>>>> Thanks,
    >>>>>>
    >>>>>> John.

    >
    >
    >>>>>>> On Saturday, April 11, 2009 12:28 PM reinerzufall1 wrote:

    >
    >>>>>>> I've found a solution:
    >>>>>>> This KB article http://support.microsoft.com/kb/928233/en-us
    >>>>>>> describes
    >>>>>>> a different problem but pointed to the right direction.
    >>>>>>>
    >>>>>>> To solve the problem follow these steps:
    >>>>>>> When setting the
    >>>>>>>
    >>>>>>> Change the value of the entry "DhcpConnForceBroadcastFlag" under the
    >>>>>>> following registry key from 1 to 0 (default value is 1).
    >>>>>>> HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters
    >>>>>>> \Interfaces\{GUID of your NIC}
    >>>>>>> This key should already exist. If not create it as REG_DWORD (32
    >>>>>>> Bit)
    >>>>>>>
    >>>>>>> Then delete the entry "DefaultConnectionSettings" from the following
    >>>>>>> registry key:
    >>>>>>> HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet
    >>>>>>> Settings\Connections
    >>>>>>>
    >>>>>>> Then reboot your computer (you can also just restart the services
    >>>>>>> "DHCP" and "WinHttpAutoProxySvc").
    >>>>>>>
    >>>>>>> After that Internet Explorer queries DHCP for WPAD (Windows sends
    >>>>>>> out
    >>>>>>> a DHCP inform packet to the DHCP server).
    >>>>>>>
    >>>>>>> Hope this helps others
    >>>>>>> Reiner

    >
    >
    >>>>>>>> On Wednesday, May 13, 2009 11:09 PM Alex wrote:

    >
    >>>>>>>> You are required to be a member to post replies. After logging in
    >>>>>>>> or becoming a member, you will be redirected back to this page.

    >
    >
    >>>>>>>>> On Wednesday, May 13, 2009 11:12 PM Alex wrote:

    >
    >>>>>>>>> Hi John,
    >>>>>>>>>
    >>>>>>>>> Confirmed this is happening with both IE7 and IE8. Unfortunately I
    >>>>>>>>> have no answer yet as to why it is not working.
    >>>>>>>>>
    >>>>>>>>> I hope you have had better luck.
    >>>>>>>>>
    >>>>>>>>> Thanks,
    >>>>>>>>> Alex.

    >
    >
    >>>>>>>>>> On Thursday, February 18, 2010 4:04 AM Hans Peter Schoepf wrote:

    >
    >>>>>>>>>> Hello,
    >>>>>>>>>>
    >>>>>>>>>>
    >>>>>>>>>>
    >>>>>>>>>> Did someone of you found a solution for this problem?
    >>>>>>>>>>
    >>>>>>>>>> I have the same problem with two x64 WinXp clients.
    >>>>>>>>>>
    >>>>>>>>>> Both are gettings the wpad.dat information from the
    >>>>>>>>>>
    >>>>>>>>>> DHCP Server but it seems the IE cannt handle this
    >>>>>>>>>>
    >>>>>>>>>> informations well and starts to make some dns requests.
    >>>>>>>>>>
    >>>>>>>>>> When is insert the location of the wpad.dat file manually, the
    >>>>>>>>>> clients can use it.
    >>>>>>>>>>
    >>>>>>>>>> Strange things....are happening sometimes:)
    >>>>>>>>>>
    >>>>>>>>>> Thank you very much

    >
    >
    >>>>>>>>>> Submitted via EggHeadCafe - Software Developer Portal of Choice
    >>>>>>>>>> Excel Identifying which formulas are slowing down workbook
    >>>>>>>>>> recalaculation
    >>>>>>>>>> http://www.eggheadcafe.com/tutorial...are-slowing-down-workbook-recalaculation.aspx
     
  3. Rob

    Rob Flightless Bird

    Penn E. Loafer <penn@eloafer.invalid> wrote:
    > You HoopleHead EggHeader!
    > Do you think someone who posted in early 2009 is coming back to read your
    > comments, especially since you changed the subject?
    >
    > When are you people going to learn how to use a newsgroup/forum?


    Please stop making those dumb comments.

    Any followup to an old question, especially one with a solution, is valuable
    because they will be added to the searchable archives. Does not matter
    if the original poster is still there. Others may have the same problem
    and find the answer here.
     

Share This Page