1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Security Warning

Discussion in 'Internet Explorer' started by John Persico, May 11, 2010.

  1. John Persico

    John Persico Flightless Bird

    Is there a way to stop the Explorer from giving this message:

    Do you want to review only the webpage content that was delivered securely?

    This webpage contains content ...

    This happens SOMETIMES at https: sites. I happen to be at the Dunkin'
    Donuts website and it's doing this.

    --
     
  2. rob^_^

    rob^_^ Flightless Bird

    Hi John,

    Ensure you have the default (recommended) security zone settings.

    Tools>Internet Options - Security tab, click "Reset all zones to default".

    Now DunkinDonuts is using content from their https portal and also from
    akamai.net so

    Add the following to your Trusted sites list
    *.dunkinDonuts.com
    *.akamai.net (optional - this is an ad site although you may have to add it
    to stop the warning message)

    Whoever programmed their site is an idiot.

    Regards.

    "John Persico" <reply@newsgroup.com> wrote in message
    news:#21jGWV8KHA.5412@TK2MSFTNGP06.phx.gbl...
    > Is there a way to stop the Explorer from giving this message:
    >
    > Do you want to review only the webpage content that was delivered
    > securely?
    >
    > This webpage contains content ...
    >
    > This happens SOMETIMES at https: sites. I happen to be at the Dunkin'
    > Donuts website and it's doing this.
    >
    > --
    >
    >
    >
     
  3. VanguardLH

    VanguardLH Flightless Bird

    John Persico wrote:

    > Is there a way to stop the Explorer from giving this message:
    >
    > Do you want to review only the webpage content that was delivered securely?
    >
    > This webpage contains content ...
    >
    > This happens SOMETIMES at https: sites. I happen to be at the Dunkin'
    > Donuts website and it's doing this.


    You see that prompt because the page author claiming to offer a secure page
    is lying to you. Some of the content is via SSL while some of it is not.
    If anything in a web page is not secure then the entire web page is not
    secure. It is or isn't secure, not somewhere in between.

    The problem is the owner/author of the web page probably is spewing out ads
    or other 3rd party content that they are not delivering through their own
    server so it isn't in the SSL protected data streamed to your host. It is
    called "mixed content". So go into the security zone in which you are
    rendering the web page (probably the Internet security zone) and decide how
    you want to handle mixed content.

    Internet Options -> Security tab -> pick a security zone -> Custom level
    Miscellaneous section
    Display mixed content

    If you want to let the page owner pretend they have a secure page but they
    actually have unprotected content, you can disable the prompting by
    selecting Enable (instead of Prompt). Personally I don't let anyone lie to
    me about their web page being secure so I set this to Disable. I don't get
    prompted and I don't get the insecure content.
     

Share This Page