1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Security restrictions on desktop copy of website

Discussion in 'Internet Explorer' started by Bobbi, May 27, 2010.

  1. Bobbi

    Bobbi Flightless Bird

    I'm a 2-bit webmaster. I have a copy of the website on my desktop. Having
    just installed Win XP Service Pack 3, IE7 and other windows updates, I find
    that certain security settings have apparently been changed. When I open the
    web home page on my desktop, I get the message that IE is blocking scripts
    and ActiveX controls, but there's no such message when I visit the real
    website. I know that the security settings are somewhat different for local
    and remote web pages, but I don't know which setting is affecting my viewing
    of the desktop version.
    -Bobbi
     
  2. Don Varnau

    Don Varnau Flightless Bird

    Hi,
    You're encountering the "local machine zone lockdown" feature introduced in
    XP SP2.
    http://technet.microsoft.com/en-us/library/bb457150.aspx#EHAA

    There are three workarounds for this:
    1. Give each page the "Mark of the Web"
    http://msdn2.microsoft.com/en-us/library/ms537628.aspx
    2. Rename each .HTM file to .HTA while it's on your hard drive. HTA files
    aren't as restricted.
    3. Internet Options> Advanced> Security> check "Allow active content to run
    in files on My Computer ."
    You will, of course, be giving up some of the enhanced security of the XP
    SP2 update.
    http://technet.microsoft.com/en-us/library/bb457150.aspx

    Hope this helps,
    Don
    [MS MVP- IE]


    "Bobbi" <bobbi@example.invalid> wrote in message
    news:%23SL89sb$KHA.5292@TK2MSFTNGP06.phx.gbl...
    > I'm a 2-bit webmaster. I have a copy of the website on my desktop. Having
    > just installed Win XP Service Pack 3, IE7 and other windows updates, I

    find
    > that certain security settings have apparently been changed. When I open

    the
    > web home page on my desktop, I get the message that IE is blocking scripts
    > and ActiveX controls, but there's no such message when I visit the real
    > website. I know that the security settings are somewhat different for

    local
    > and remote web pages, but I don't know which setting is affecting my

    viewing
    > of the desktop version.
    > -Bobbi
     
  3. Dan

    Dan Flightless Bird

    "Bobbi" <bobbi@example.invalid> wrote in message
    news:#SL89sb$KHA.5292@TK2MSFTNGP06.phx.gbl...
    > I'm a 2-bit webmaster. I have a copy of the website on my desktop. Having
    > just installed Win XP Service Pack 3, IE7 and other windows updates, I
    > find that certain security settings have apparently been changed. When I
    > open the web home page on my desktop, I get the message that IE is
    > blocking scripts and ActiveX controls, but there's no such message when I
    > visit the real website. I know that the security settings are somewhat
    > different for local and remote web pages, but I don't know which setting
    > is affecting my viewing of the desktop version.
    > -Bobbi
    >


    Why are you opening your web pages direct off the hard disk? Why don't you
    install a web server and use them over HTTP so they replicate the real
    website handling? What does your web hosting use? If it's IIS, and you have
    XP Pro, install IIS5.1. If it's Apache, download and install Apache. Try to
    replicate your hosts environment and view your web pages as they were
    intended over a HTTP connection, or else you risk finding things don't work
    as you expected; relative links pointing the wrong place usually being the
    most prevalent.

    --
    Dan
     
  4. Bobbi

    Bobbi Flightless Bird

    Dan-

    You're absolutely right, but I'm just a volunteer with minimal serving a
    bike club, not a group of paying clients. I want to make this as easy for me
    as possible while providing reasonable functionality for the club.

    Bobbi

    "Dan" <news@worldofspack.com> wrote in message
    news:14E6D875-5176-49CD-9BBC-0D9F4BE23891@microsoft.com...
    >
    > "Bobbi" <bobbi@example.invalid> wrote in message
    > news:#SL89sb$KHA.5292@TK2MSFTNGP06.phx.gbl...
    >> I'm a 2-bit webmaster. I have a copy of the website on my desktop. Having
    >> just installed Win XP Service Pack 3, IE7 and other windows updates, I
    >> find that certain security settings have apparently been changed. When I
    >> open the web home page on my desktop, I get the message that IE is
    >> blocking scripts and ActiveX controls, but there's no such message when I
    >> visit the real website. I know that the security settings are somewhat
    >> different for local and remote web pages, but I don't know which setting
    >> is affecting my viewing of the desktop version.
    >> -Bobbi
    >>

    >
    > Why are you opening your web pages direct off the hard disk? Why don't you
    > install a web server and use them over HTTP so they replicate the real
    > website handling? What does your web hosting use? If it's IIS, and you
    > have XP Pro, install IIS5.1. If it's Apache, download and install Apache.
    > Try to replicate your hosts environment and view your web pages as they
    > were intended over a HTTP connection, or else you risk finding things
    > don't work as you expected; relative links pointing the wrong place
    > usually being the most prevalent.
    >
    > --
    > Dan
     

Share This Page