1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Office 2010 and Basic Authentication on IIS fails to open documents

Discussion in 'Microsoft Office' started by Jascha Minow, May 6, 2010.

  1. Jascha Minow

    Jascha Minow Flightless Bird

    Hi,

    I have just upgraded my Office 2007 to 2010 (yes the RTM build) and am
    running into some serious trouble accessing documents stored on a web server
    or SharePoint server configured to only allow Basic Authentication.
    Word opens as expected but does not do anything else (no prompt, no document
    download, nothing). Accessing any Office document on a server or SharePoint
    2007/2010 server that has e.g. Integrated Windows authentication enabled,
    all is good I get prompted for credentials and the document downloads and
    opens as expected and as in Office 2007.

    Where is the setting or registry key to make Office 2010 work with IIS and
    SharePoint configured to only use Basic Authentication? This can't be gone!
    I know this is less secure but in an Intranet environment acceptable. This
    is causing major trouble and a resolution or hint is greatly appreciated!

    Thanks for a hint
    Jascha
     
  2. Semen

    Semen Flightless Bird

    RE: Office 2010 and Basic Authentication on IIS fails to open document

    For me the same :(
    Unable to open data connection to the external sharepoint portal with the
    "non-windows" credentials.
     
  3. Semen

    Semen Flightless Bird

    RE: Office 2010 and Basic Authentication on IIS fails to open document

    Try this solution:
    open "regedit"
    go to: HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Common\Internet
    Create a registry key called BasicAuthLevel as a DWORD
    And set it to 2

    It works for me.
     

Share This Page