1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Num Lock on Keyboard

Discussion in 'Windows XP' started by Omaha Tony, Feb 2, 2010.

  1. Omaha Tony

    Omaha Tony Flightless Bird

    New problem just started and don't know why. When I boot up my PC, the "num
    lock" light was always automatically on, allowing me to use the numeric keys.
    It wont come on automatically any more. I have to turn it on manually evry
    time I boot up the PC. What has caused this change and how can I get it back
    to what it used to do. Thank you.

    Tony
     
  2. mm

    mm Flightless Bird

    On Tue, 2 Feb 2010 09:18:05 -0800, Omaha Tony
    <OmahaTony@discussions.microsoft.com> wrote:

    >New problem just started and don't know why. When I boot up my PC, the "num
    >lock" light was always automatically on, allowing me to use the numeric keys.
    > It wont come on automatically any more. I have to turn it on manually evry
    >time I boot up the PC. What has caused this change and how can I get it back
    >to what it used to do. Thank you.
    >
    >Tony


    Isn't this a job for tweakui? A free download. Specify XP.

    I don't have it installed right now or I would check.
     
  3. chas2209

    chas2209 Flightless Bird

    "Omaha Tony" <OmahaTony@discussions.microsoft.com> wrote in message
    news:21C8EDD8-107C-45A3-9032-33EDFB033EB7@microsoft.com...
    > New problem just started and don't know why. When I boot up my PC, the
    > "num
    > lock" light was always automatically on, allowing me to use the numeric
    > keys.
    > It wont come on automatically any more. I have to turn it on manually
    > evry
    > time I boot up the PC. What has caused this change and how can I get it
    > back
    > to what it used to do. Thank you.
    >
    > Tony


    Hi
    There is usually a setting in the Bios to set Num Lock on at boot up

    chas2209
     
  4. boatman312

    boatman312 Flightless Bird

    On 02/02/10 12:36 PM, mm wrote:
    > On Tue, 2 Feb 2010 09:18:05 -0800, Omaha Tony
    > <OmahaTony@discussions.microsoft.com> wrote:
    >
    >> New problem just started and don't know why. When I boot up my PC, the "num
    >> lock" light was always automatically on, allowing me to use the numeric keys.
    >> It wont come on automatically any more. I have to turn it on manually evry
    >> time I boot up the PC. What has caused this change and how can I get it back
    >> to what it used to do. Thank you.
    >>
    >> Tony

    >
    > Isn't this a job for tweakui? A free download. Specify XP.
    >
    > I don't have it installed right now or I would check.
    >
    >

    Also, there's usually an option in the motherboard bios setup for the
    numlock status.
     
  5. Russ SBITS.Biz [SBS-MVP]

    Russ SBITS.Biz [SBS-MVP] Flightless Bird

    If the BIOS suggestion doesn't work I've seen this on some windows XP
    Systems
    Here is a Registry Hack that turn on Numb Lock

    Open NotePad.exe Put
    ---------------- Start -------------
    Windows Registry Editor Version 5.00

    [HKEY_USERS\.DEFAULT\Control Panel\Keyboard]

    "InitialKeyboardIndicators"="2"

    ----------- End -------------

    And save it as NumbLock.reg
    Run it on the PC
    and it should turn on your Numb lock for you
    Russ

    --
    Russell Grover - SBITS.Biz [SBS-MVP]
    Microsoft Gold Certified Partner
    Microsoft Certified Small Business Specialist
    24hr SBS Remote Support - http://www.SBITS.Biz
    Second IT Opinion http://www.personalitconsultant.com
    Free Trial Microsoft Online Services (BPOS) -
    http://www.microsoft-online-services.com


    "Omaha Tony" <OmahaTony@discussions.microsoft.com> wrote in message
    news:21C8EDD8-107C-45A3-9032-33EDFB033EB7@microsoft.com...
    > New problem just started and don't know why. When I boot up my PC, the
    > "num
    > lock" light was always automatically on, allowing me to use the numeric
    > keys.
    > It wont come on automatically any more. I have to turn it on manually
    > evry
    > time I boot up the PC. What has caused this change and how can I get it
    > back
    > to what it used to do. Thank you.
    >
    > Tony
     
  6. SC Tom

    SC Tom Flightless Bird

    "mm" <NOPSAMmm2005@bigfoot.com> wrote in message
    news:fiogm5ll5qju5koqqikt69eobu5gcatock@4ax.com...
    > On Tue, 2 Feb 2010 09:18:05 -0800, Omaha Tony
    > <OmahaTony@discussions.microsoft.com> wrote:
    >
    >>New problem just started and don't know why. When I boot up my PC, the
    >>"num
    >>lock" light was always automatically on, allowing me to use the numeric
    >>keys.
    >> It wont come on automatically any more. I have to turn it on manually
    >> evry
    >>time I boot up the PC. What has caused this change and how can I get it
    >>back
    >>to what it used to do. Thank you.
    >>
    >>Tony

    >
    > Isn't this a job for tweakui? A free download. Specify XP.
    >
    > I don't have it installed right now or I would check.
    >
    >


    That's what I thought, too, but I can't find a numlock listing.
    I know on my PC, XP remembers the shut down state- if it's off when I turn
    the PC off, it'll be off when next I boot up, even though I have it set to
    on in BIOS.
    --
    SC Tom
     
  7. Jose

    Jose Flightless Bird

    On Feb 2, 3:09 pm, "SC Tom" <s...@tom.net> wrote:
    > "mm" <NOPSAMmm2...@bigfoot.com> wrote in message
    >
    > news:fiogm5ll5qju5koqqikt69eobu5gcatock@4ax.com...
    >
    >
    >
    >
    >
    > > On Tue, 2 Feb 2010 09:18:05 -0800, Omaha Tony
    > > <OmahaT...@discussions.microsoft.com> wrote:

    >
    > >>New problem just started and don't know why.  When I boot up my PC, the
    > >>"num
    > >>lock" light was always automatically on, allowing me to use the numeric
    > >>keys.
    > >> It wont come on automatically any more.  I have to turn it on manually
    > >> evry
    > >>time I boot up the PC.  What has caused this change and how can I getit
    > >>back
    > >>to what it used to do.  Thank you.

    >
    > >>Tony

    >
    > > Isn't this a job for tweakui?   A free download.  Specify XP.

    >
    > > I don't have it installed right now or I would check.

    >
    > That's what I thought, too, but I can't find a numlock listing.
    > I know on my PC, XP remembers the shut down state- if it's off when I turn
    > the PC off, it'll be off when next I boot up, even though I have it set to
    > on in BIOS.
    > --
    > SC Tom


    There may not be a way to set it in every BIOS. The BIOS settings
    will get overridden
    first by XP, then by the user profile when the user logs in. The XP
    default is all indicators
    off.

    Let's say you could not change it in the BIOS - what would you do?

    You could change it in .DEFAULT, but that would only apply to newly
    created users, so that isn't
    quite right.

    XP remembers (possible changes) the setting when a user logs off or
    the system is shutdown
    and applies it again when the user logs in. This is why the BIOS
    setting may appear "not to work" or
    the keys seem to keep changing. Nothing is broken, they are behaving.

    You will have the same settings when you login that you had when you
    logged out or shutdown. Another
    user may have different settings.

    Each user has their own setting in their profile.

    You can adjust the default setting for each newly created user profile
    or for an individual
    profile by adjusting the value of:

    InitialKeyboardIndicators

    For the current user the location for InitialKeyboardIndicators is:

    HKCU\CONTROL PANEL\KEYBOARD

    Here are all the values for InitialKeyboardIndicators:

    * 0 - all indicators off
    * 1 - Caps Lock on
    * 2 - Num Lock on
    * 4 - Scroll Lock on

    Or, combine them by adding the values to some other number:

    * 3 - Caps Lock and Num Lock on
    * 5 - Caps Lock and Scroll Lock on
    * 6 - Num Lock and Scroll Lock on
    * 7 - Caps Lock, Num Lock, and Scroll Lock on

    For all (new) users, the location for InitialKeyboardIndicators is:

    HKEY_USERS\.DEFAULT\CONTROL PANEL\KEYBOARD
     
  8. Bruce Chambers

    Bruce Chambers Flightless Bird

    Omaha Tony wrote:
    > New problem just started and don't know why. When I boot up my PC, the "num
    > lock" light was always automatically on, allowing me to use the numeric keys.
    > It wont come on automatically any more. I have to turn it on manually evry
    > time I boot up the PC. What has caused this change and how can I get it back
    > to what it used to do. Thank you.
    >
    > Tony



    By default, the NumLock key is turned off as WinXP starts, and
    keeps it off until someone logs in and initializes a user profile. WinXP
    will remember the NumLock's last state, meaning that if you log out with
    the NumLock on, it will automatically turn on the next time you log in;
    If you log out with the NumLock off, it will be off the next time you
    log in.

    If one needs the NumLock on _before_ logging in, a registry edit
    can be used to change WinXP's default behavior:

    How to Set the NUM LOCK State at Logon in Windows XP
    http://support.microsoft.com/default.aspx?scid=kb;en-us;314879


    --

    Bruce Chambers

    Help us help you:
    http://www.catb.org/~esr/faqs/smart-questions.html

    http://support.microsoft.com/default.aspx/kb/555375

    They that can give up essential liberty to obtain a little temporary
    safety deserve neither liberty nor safety. ~Benjamin Franklin

    Many people would rather die than think; in fact, most do. ~Bertrand Russell

    The philosopher has never killed any priests, whereas the priest has
    killed a great many philosophers.
    ~ Denis Diderot
     
  9. Twayne

    Twayne Flightless Bird

    In news:21C8EDD8-107C-45A3-9032-33EDFB033EB7@microsoft.com,
    Omaha Tony <OmahaTony@discussions.microsoft.com> typed:
    > New problem just started and don't know why. When I boot up my PC,
    > the "num lock" light was always automatically on, allowing me to use
    > the numeric keys. It wont come on automatically any more. I have to
    > turn it on manually evry time I boot up the PC. What has caused this
    > change and how can I get it back to what it used to do. Thank you.
    >
    > Tony


    The tickmark to start with NumLock turned ON is missing in your CMOS BIOS
    settings. Add it back and all should work UNLESS
    the coin-sized battery on the motherboard is failing. A symptom of that is
    usually incorrect date and time displays in the TaskBar.

    Twayne
    --
    Life is the only real counselor; wisdom unfiltered
    through personal experience does not become a
    part of the moral tissue.
     
  10. Twayne

    Twayne Flightless Bird

    In news:fiogm5ll5qju5koqqikt69eobu5gcatock@4ax.com,
    mm <NOPSAMmm2005@bigfoot.com> typed:
    > On Tue, 2 Feb 2010 09:18:05 -0800, Omaha Tony
    > <OmahaTony@discussions.microsoft.com> wrote:
    >
    >> New problem just started and don't know why. When I boot up my PC,
    >> the "num lock" light was always automatically on, allowing me to use
    >> the numeric keys. It wont come on automatically any more. I have to
    >> turn it on manually evry time I boot up the PC. What has caused
    >> this change and how can I get it back to what it used to do. Thank
    >> you.
    >>
    >> Tony

    >
    > Isn't this a job for tweakui? A free download. Specify XP.
    >
    > I don't have it installed right now or I would check.


    No, it's a simple boot time setting.

    --
    --
    Life is the only real counselor; wisdom unfiltered
    through personal experience does not become a
    part of the moral tissue.
     
  11. Twayne

    Twayne Flightless Bird

    In news:ebe48e75-1617-43df-908a-b388b3eac8ce@l26g2000yqd.googlegroups.com,
    Jose <jose_ease@yahoo.com> typed:
    > On Feb 2, 3:09 pm, "SC Tom" <s...@tom.net> wrote:
    >> "mm" <NOPSAMmm2...@bigfoot.com> wrote in message
    >>
    >> news:fiogm5ll5qju5koqqikt69eobu5gcatock@4ax.com...
    >>
    >>
    >>
    >>
    >>
    >>> On Tue, 2 Feb 2010 09:18:05 -0800, Omaha Tony
    >>> <OmahaT...@discussions.microsoft.com> wrote:

    >>
    >>>> New problem just started and don't know why. When I boot up my PC,
    >>>> the "num
    >>>> lock" light was always automatically on, allowing me to use the
    >>>> numeric keys.
    >>>> It wont come on automatically any more. I have to turn it on
    >>>> manually evry
    >>>> time I boot up the PC. What has caused this change and how can I
    >>>> get it back
    >>>> to what it used to do. Thank you.

    >>
    >>>> Tony

    >>
    >>> Isn't this a job for tweakui? A free download. Specify XP.

    >>
    >>> I don't have it installed right now or I would check.

    >>
    >> That's what I thought, too, but I can't find a numlock listing.
    >> I know on my PC, XP remembers the shut down state- if it's off when
    >> I turn the PC off, it'll be off when next I boot up, even though I
    >> have it set to on in BIOS.
    >> --
    >> SC Tom

    >
    > There may not be a way to set it in every BIOS. The BIOS settings
    > will get overridden
    > first by XP, then by the user profile when the user logs in. The XP
    > default is all indicators
    > off.
    >
    > Let's say you could not change it in the BIOS - what would you do?
    >
    > You could change it in .DEFAULT, but that would only apply to newly
    > created users, so that isn't
    > quite right.
    >
    > XP remembers (possible changes) the setting when a user logs off or
    > the system is shutdown
    > and applies it again when the user logs in. This is why the BIOS
    > setting may appear "not to work" or
    > the keys seem to keep changing. Nothing is broken, they are behaving.
    >
    > You will have the same settings when you login that you had when you
    > logged out or shutdown. Another
    > user may have different settings.
    >
    > Each user has their own setting in their profile.
    >
    > You can adjust the default setting for each newly created user profile
    > or for an individual
    > profile by adjusting the value of:
    >
    > InitialKeyboardIndicators
    >
    > For the current user the location for InitialKeyboardIndicators is:
    >
    > HKCU\CONTROL PANEL\KEYBOARD
    >
    > Here are all the values for InitialKeyboardIndicators:
    >
    > * 0 - all indicators off
    > * 1 - Caps Lock on
    > * 2 - Num Lock on
    > * 4 - Scroll Lock on
    >
    > Or, combine them by adding the values to some other number:
    >
    > * 3 - Caps Lock and Num Lock on
    > * 5 - Caps Lock and Scroll Lock on
    > * 6 - Num Lock and Scroll Lock on
    > * 7 - Caps Lock, Num Lock, and Scroll Lock on
    >
    > For all (new) users, the location for InitialKeyboardIndicators is:
    >
    > HKEY_USERS\.DEFAULT\CONTROL PANEL\KEYBOARD


    That's excellent information, Jose! Thanks.

    TWayne
    --
    Life is the only real counselor; wisdom unfiltered
    through personal experience does not become a
    part of the moral tissue.
     
  12. Jose

    Jose Flightless Bird

    On Feb 4, 2:14 pm, "Twayne" <nob...@spamcop.net> wrote:
    > Innews:ebe48e75-1617-43df-908a-b388b3eac8ce@l26g2000yqd.googlegroups.com,
    > Jose <jose_e...@yahoo.com> typed:
    >
    >
    >
    >
    >
    > > On Feb 2, 3:09 pm, "SC Tom" <s...@tom.net> wrote:
    > >> "mm" <NOPSAMmm2...@bigfoot.com> wrote in message

    >
    > >>news:fiogm5ll5qju5koqqikt69eobu5gcatock@4ax.com...

    >
    > >>> On Tue, 2 Feb 2010 09:18:05 -0800, Omaha Tony
    > >>> <OmahaT...@discussions.microsoft.com> wrote:

    >
    > >>>> New problem just started and don't know why. When I boot up my PC,
    > >>>> the "num
    > >>>> lock" light was always automatically on, allowing me to use the
    > >>>> numeric keys.
    > >>>> It wont come on automatically any more. I have to turn it on
    > >>>> manually evry
    > >>>> time I boot up the PC. What has caused this change and how can I
    > >>>> get it back
    > >>>> to what it used to do. Thank you.

    >
    > >>>> Tony

    >
    > >>> Isn't this a job for tweakui? A free download. Specify XP.

    >
    > >>> I don't have it installed right now or I would check.

    >
    > >> That's what I thought, too, but I can't find a numlock listing.
    > >> I know on my PC, XP remembers the shut down state- if it's off when
    > >> I turn the PC off, it'll be off when next I boot up, even though I
    > >> have it set to on in BIOS.
    > >> --
    > >> SC Tom

    >
    > > There may not be a way to set it in every BIOS.  The BIOS settings
    > > will get overridden
    > > first by XP, then by the user profile when the user logs in.  The XP
    > > default is all indicators
    > > off.

    >
    > > Let's say you could not change it in the BIOS - what would you do?

    >
    > > You could change it in .DEFAULT, but that would only apply to newly
    > > created users, so that isn't
    > > quite right.

    >
    > > XP remembers (possible changes) the setting when a user logs off or
    > > the system is shutdown
    > > and applies it again when the user logs in.  This is why the BIOS
    > > setting may appear "not to work" or
    > > the keys seem to keep changing.  Nothing is broken, they are behaving..

    >
    > > You will have the same settings when you login that you had when you
    > > logged out or shutdown.  Another
    > > user may have different settings.

    >
    > > Each user has their own setting in their profile.

    >
    > > You can adjust the default setting for each newly created user profile
    > > or for an individual
    > > profile by adjusting the value of:

    >
    > > InitialKeyboardIndicators

    >
    > > For the current user the location for InitialKeyboardIndicators is:

    >
    > > HKCU\CONTROL PANEL\KEYBOARD

    >
    > > Here are all the values for InitialKeyboardIndicators:

    >
    > >     * 0 - all indicators off
    > >     * 1 - Caps Lock on
    > >     * 2 - Num Lock on
    > >     * 4 - Scroll Lock on

    >
    > > Or, combine them by adding the values to some other number:

    >
    > >     * 3 - Caps Lock and Num Lock on
    > >     * 5 - Caps Lock and Scroll Lock on
    > >     * 6 - Num Lock and Scroll Lock on
    > >     * 7 - Caps Lock, Num Lock, and Scroll Lock on

    >
    > > For all (new) users, the location for InitialKeyboardIndicators is:

    >
    > > HKEY_USERS\.DEFAULT\CONTROL PANEL\KEYBOARD

    >
    > That's excellent information, Jose!  Thanks.
    >
    > TWayne
    > --
    > Life is the only real counselor; wisdom unfiltered
    > through personal experience does not become a
    > part of the moral tissue.


    I've fought this battle before. ;)
     
  13. Bruce Chambers

    Bruce Chambers Flightless Bird

    Twayne wrote:
    >
    >
    > The tickmark to start with NumLock turned ON is missing in your CMOS
    > BIOS settings. Add it back and all should work ...



    Not so.

    WinXP, like its predecessors WinNT and Win2K, by design, ignores
    the BIOS settings for the NumLock key as a standard security feature.
    (I'm afraid I can't remember the "security" issue initially addressed.)
    By default, the NumLock key is turned off as WinXP starts, and keeps
    it off until someone logs in and initializes a user profile. WinXP will
    remember the NumLock's last state, meaning that if you log out with the
    NumLock on, it will automatically turn on the next time you log in; If
    you log out with the NumLock off, it will be off the next time you log in.

    If you need the NumLock on _before_ logging in, a registry edit can
    be used to change WinXP's default behavior:

    How to Set the NUM LOCK State at Logon in Windows XP
    http://support.microsoft.com/default.aspx?scid=kb;en-us;314879


    --

    Bruce Chambers

    Help us help you:
    http://www.catb.org/~esr/faqs/smart-questions.html

    http://support.microsoft.com/default.aspx/kb/555375

    They that can give up essential liberty to obtain a little temporary
    safety deserve neither liberty nor safety. ~Benjamin Franklin

    Many people would rather die than think; in fact, most do. ~Bertrand Russell

    The philosopher has never killed any priests, whereas the priest has
    killed a great many philosophers.
    ~ Denis Diderot
     
  14. Bruce Chambers

    Bruce Chambers Flightless Bird

    Twayne wrote:
    >
    > No, it's a simple boot time setting.
    >


    Only if one is running Win9x or earlier.

    --

    Bruce Chambers

    Help us help you:
    http://www.catb.org/~esr/faqs/smart-questions.html

    http://support.microsoft.com/default.aspx/kb/555375

    They that can give up essential liberty to obtain a little temporary
    safety deserve neither liberty nor safety. ~Benjamin Franklin

    Many people would rather die than think; in fact, most do. ~Bertrand Russell

    The philosopher has never killed any priests, whereas the priest has
    killed a great many philosophers.
    ~ Denis Diderot
     

Share This Page