1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Log in = ' logging out ' fix.

Discussion in 'Windows XP' started by - Bobb -, Apr 15, 2010.

  1. - Bobb -

    - Bobb - Flightless Bird

    In case you get stuck with this problem:

    Normally I boot to menu on IDE and default XP boot menu option is to boot
    SATA1. A few months while testing some beta software, I had disconnected 2
    SATA drives after doing a drive copy and had just the IDE hooked up.
    Yesterday I turned the test box on again and reconnected those drives.
    config = 1 IDE and 2 SATA's ( Seagate normally = SATA1 and Maxtor =SATA2)
    Default boot to SATA and can't see SATA1. I checked and the power SATA1 had
    not been reconnected so I did that. I then booted - menu defaults - starts
    XP - get to logon screen and I login. However drive letter assignment is
    bad. I realized that the first time I booted SATA since my 'normal drive'
    wasn't hooked up, in the BIOS my first boot option for SATA drives is the
    Maxtor. Restarted - checked - that WAS the problem. I changed the boot order
    so SATA1 is primary boot again and restart. I can login but then get "
    Logging Off" right after entering user pwd. .Removed SATA2
    Disconnected all but SATA1 and works OK. Same with IDE. But with both
    connected, IDE boots but SATA1 just gives " Logging Off" after entering user
    pwd. .
    ..
    Today I was going to repair XP ( recovery console). I need to check mail
    first and rather than disconnecting the IDE cables, I just disabled in BIOS.
    Booted SATA - it saw the IDE - correct drive letters - all better.

    =======
    if you have SATA and IDE bootable drives and IF you accidentally change boot
    order and thereby reassign drive letters for a XP disk, DISABLE the IDE
    drive in BIOS and boot SATA. once XP is working, it still sees the IDE
    drive, reassigns the "correct drive letters" = fixed.
    Made no sense to me - shouldn't DISABLED in BIOS mean 'the drive won't
    work'? , but if I toggle enabled/disabled IDE the problem came and went.
    With IDE drive disabled, I was able to boot SATA successfully AND IDE drive
    was there - with proper drive letters.
    I shutdown, rebooted, re-enabled IDE in BIOS and boots either fine now.
     
  2. VanguardLH

    VanguardLH Flightless Bird

    - Bobb - wrote:

    > In case you get stuck with this problem:


    What problem? You haven't yet introduced or defined the problem.

    > Normally I boot to menu on IDE and default XP boot menu option is to boot
    > SATA1.


    Huh? The BIOS will boot using the bootstrap code (first 446 bytes of the
    MBR) which is in the first sector in the first non-partitionable track on
    the first hard disk that the BIOS finds dependent on the disk boot order
    specified in the BIOS. So it sounds like your BIOS finds an IDE disk first
    and gets the bootstrap code from that disk. That bootstrap code then reads
    the partition table in that same MBR (master boot record) to find which one
    is designated as the "active" tagged partition. It then loads the boot
    sector from that active partition which then begins loading the OS. Only
    then do you get Microsoft's "boot menu" to select which OS to load that is
    listed in the boot.ini file (Vista+ changed this a bit but not regarding
    what the BIOS and MBR bootstrap will do).

    So my guess is that the first detected disk by the BIOS is an IDE device so
    the MBR bootstrap from there gets used to load the boot sector for Windows
    in the "active" partition on the IDE disk. The "Windows XP" selection in
    the boot.ini file points to a partition on a SATA disk where is the rest of
    Windows. Although the terminology sounds a bit backwards, you configured
    Windows so its "system partition" (used to boot the loader for the OS) is in
    a partition on an IDE disk and its "boot partition" is in a partition on a
    SATA disk. While most users install Windows where its system and boot
    partitions are the same, it is possible to install where they are different
    and even on different disks.

    > A few months while testing some beta software, I had disconnected 2
    > SATA drives after doing a drive copy and had just the IDE hooked up.


    Then were was the Windows that you loaded at that time? Previously you made
    it look like the system partition for Windows was in a partition on an IDE
    drive which loaded the rest of Windows from its boot partition that was on a
    SATA drive. If you disconnected the SATA drive, just how would Windows get
    loaded? If all you had left was the IDE disk then you must've changed your
    Windows installation so the system and boot partitions were both on the IDE
    disk (either as the same partition or as two partitions on the same disk).

    > Yesterday I turned the test box on again and reconnected those drives.
    > config = 1 IDE and 2 SATA's ( Seagate normally = SATA1 and Maxtor =SATA2)
    > Default boot to SATA and can't see SATA1.


    Because when you only had the IDE disk you had changed your installation so
    the boot partition was no longer specified as being on the SATA drive. For
    you to boot Windows using the solitary IDE disk meant that *both* the system
    and boot partitions for Windows had to be on just that IDE disk.

    If you want to abandon the boot partition that you put on the IDE disk, you
    will need to edit the boot.ini file so it points at the partition on the
    SATA disk where you previously put the boot partition for Windows.

    I checked and the power SATA1 had
    > not been reconnected so I did that. I then booted - menu defaults - starts
    > XP - get to logon screen and I login. However drive letter assignment is
    > bad. I realized that the first time I booted SATA since my 'normal drive'
    > wasn't hooked up, in the BIOS my first boot option for SATA drives is the
    > Maxtor. Restarted - checked - that WAS the problem. I changed the boot order
    > so SATA1 is primary boot again and restart. I can login but then get "
    > Logging Off" right after entering user pwd. .Removed SATA2
    > Disconnected all but SATA1 and works OK. Same with IDE. But with both
    > connected, IDE boots but SATA1 just gives " Logging Off" after entering user
    > pwd. .
    > .
    > Today I was going to repair XP ( recovery console). I need to check mail
    > first and rather than disconnecting the IDE cables, I just disabled in BIOS.
    > Booted SATA - it saw the IDE - correct drive letters - all better.
    >
    > =======
    > if you have SATA and IDE bootable drives and IF you accidentally change boot
    > order and thereby reassign drive letters for a XP disk, DISABLE the IDE
    > drive in BIOS and boot SATA. once XP is working, it still sees the IDE
    > drive, reassigns the "correct drive letters" = fixed.
    > Made no sense to me - shouldn't DISABLED in BIOS mean 'the drive won't
    > work'? , but if I toggle enabled/disabled IDE the problem came and went.
    > With IDE drive disabled, I was able to boot SATA successfully AND IDE drive
    > was there - with proper drive letters.
    > I shutdown, rebooted, re-enabled IDE in BIOS and boots either fine now.
     

Share This Page