1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

jucheck and jusched

Discussion in 'Windows 7' started by Stan Brown, Oct 2, 2010.

  1. Stan Brown

    Stan Brown Flightless Bird

    How can I tame these besasties? Almost every day I get a popup
    asking whether I want to let one or the other make changes to my
    computer. I have opened the Java console and told it not to check
    for updates, I have used msconfig to turn off "Java Platform Auto
    Update", but the next time I boot it's back again.

    It's highly annoying, because it always seems to grab focus while I'm
    in the middle of typing a paragraph, so I lose several words. "Let
    it do the update" isn't the right answer, because it will come back
    when there's another update. I want to do updates on my schedule,
    not its schedule.

    --
    Stan Brown, Oak Road Systems, Tompkins County, New York, USA
    http://OakRoadSystems.com
    Shikata ga nai...
     
  2. Nil

    Nil Flightless Bird

    On 02 Oct 2010, Stan Brown <the_stan_brown@fastmail.fm> wrote in
    alt.windows7.general:

    > How can I tame these besasties? Almost every day I get a popup
    > asking whether I want to let one or the other make changes to my
    > computer. I have opened the Java console and told it not to check
    > for updates, I have used msconfig to turn off "Java Platform Auto
    > Update", but the next time I boot it's back again.


    Java's control panel applet doesn't work properly with Vista/Win7's
    User Account Control security system. It prevents any changes you make
    using the Java Control Panel icon.

    The workaround is to use Windows Explorer to find javacpl.exe (location
    depends on the Java version - mine is in "C:/Program
    Files\Java\jre6\bin". Right-click on the file name and choose "Run as
    Administrator" and confirm. Any changes you make in this session should
    be saved.

    I hope Oracle fixes this soon. I'm sure it confuses the hell out of a
    lot of people.
     
  3. Dick Mahar

    Dick Mahar Flightless Bird

    "Stan Brown" <the_stan_brown@fastmail.fm> wrote in message
    news:MPG.27116c016b9f927e98c652@news.individual.net...
    > How can I tame these besasties? Almost every day I get a popup
    > asking whether I want to let one or the other make changes to my
    > computer. I have opened the Java console and told it not to check
    > for updates, I have used msconfig to turn off "Java Platform Auto
    > Update", but the next time I boot it's back again.
    >
    > It's highly annoying, because it always seems to grab focus while I'm
    > in the middle of typing a paragraph, so I lose several words. "Let
    > it do the update" isn't the right answer, because it will come back
    > when there's another update. I want to do updates on my schedule,
    > not its schedule.
    >
    > --
    > Stan Brown, Oak Road Systems, Tompkins County, New York, USA
    > http://OakRoadSystems.com
    > Shikata ga nai...


    Be sure that when you use the msconfig startup menu as you describe, that
    you have also used the selective startup option.
     
  4. Thee Chicago Wolf (MVP)

    Thee Chicago Wolf (MVP) Flightless Bird

    >"Stan Brown" <the_stan_brown@fastmail.fm> wrote in message
    >news:MPG.27116c016b9f927e98c652@news.individual.net...
    >> How can I tame these besasties? Almost every day I get a popup
    >> asking whether I want to let one or the other make changes to my
    >> computer. I have opened the Java console and told it not to check
    >> for updates, I have used msconfig to turn off "Java Platform Auto
    >> Update", but the next time I boot it's back again.
    >>
    >> It's highly annoying, because it always seems to grab focus while I'm
    >> in the middle of typing a paragraph, so I lose several words. "Let
    >> it do the update" isn't the right answer, because it will come back
    >> when there's another update. I want to do updates on my schedule,
    >> not its schedule.
    >>
    >> --
    >> Stan Brown, Oak Road Systems, Tompkins County, New York, USA
    >> http://OakRoadSystems.com
    >> Shikata ga nai...

    >
    > Be sure that when you use the msconfig startup menu as you describe, that
    >you have also used the selective startup option.


    msconfig should not be used. Ever. It's the worst thing to suggest.
    It's better to remove the registry entry outright.
     
  5. Thee Chicago Wolf (MVP)

    Thee Chicago Wolf (MVP) Flightless Bird

    >How can I tame these besasties? Almost every day I get a popup
    >asking whether I want to let one or the other make changes to my
    >computer. I have opened the Java console and told it not to check
    >for updates, I have used msconfig to turn off "Java Platform Auto
    >Update", but the next time I boot it's back again.
    >
    >It's highly annoying, because it always seems to grab focus while I'm
    >in the middle of typing a paragraph, so I lose several words. "Let
    >it do the update" isn't the right answer, because it will come back
    >when there's another update. I want to do updates on my schedule,
    >not its schedule.


    Easy. Oblique > regedit > navigate to
    HKLM\Software\Microsoft\Windows\CurrentVersion\Run\ and blow out
    jusched.exe.

    Then, navigate to HKLM\Software\JavaSoft\Java Update\Policy\ and set
    EnableJavaUpdate to 0.

    Done.
     
  6. johnbee

    johnbee Flightless Bird

    "Stan Brown" <the_stan_brown@fastmail.fm> wrote in message
    news:MPG.27116c016b9f927e98c652@news.individual.net...
    > How can I tame these besasties? Almost every day I get a popup
    > asking whether I want to let one or the other make changes to my
    > computer. I have opened the Java console and told it not to check
    > for updates, I have used msconfig to turn off "Java Platform Auto
    > Update", but the next time I boot it's back again.
    >
    > It's highly annoying, because it always seems to grab focus while I'm
    > in the middle of typing a paragraph, so I lose several words. "Let
    > it do the update" isn't the right answer, because it will come back
    > when there's another update. I want to do updates on my schedule,
    > not its schedule.
    >
    > --
    > Stan Brown, Oak Road Systems, Tompkins County, New York, USA
    > http://OakRoadSystems.com
    > Shikata ga nai...


    If I were you (actually if I were me as well) I would uninstall it. If it
    later on turns out to be needed, it is a trivial matter to get it again. Of
    course if you are sure you do run things written in Java that is a different
    matter. Your browser needs Javascript, but that is a different thing.

    I have suggested this before to someone, but I will again. There is a
    program named Anvir which does a super job of looking after what runs on
    your PC. The basic version is free, and all the things that try to run are
    listed in groups depending upon where they are run from. and you can
    quarantine them. They will still be listed so you can turn them on again if
    you like. I have 42 things started by the Registry alone - and I only
    actually let 4 of them run, the rest are quarantined. If some cheeky thing
    tries to get back in, Anvir gives a nice warning to you. It offers to
    replace the Windows Task Manager with itself, but I wouldn't do that. It is
    useful, though, to also get much better info about what all those processes
    are.
     
  7. Stan Brown

    Stan Brown Flightless Bird

    On Sat, 02 Oct 2010 18:07:50 -0400, Nil wrote:
    >
    > On 02 Oct 2010, Stan Brown <the_stan_brown@fastmail.fm> wrote in
    > alt.windows7.general:
    >
    > > How can I tame these besasties? Almost every day I get a popup
    > > asking whether I want to let one or the other make changes to my
    > > computer. I have opened the Java console and told it not to check
    > > for updates, I have used msconfig to turn off "Java Platform Auto
    > > Update", but the next time I boot it's back again.

    >
    > Java's control panel applet doesn't work properly with Vista/Win7's
    > User Account Control security system. It prevents any changes you make
    > using the Java Control Panel icon.
    >
    > The workaround is to use Windows Explorer to find javacpl.exe (location
    > depends on the Java version - mine is in "C:/Program
    > Files\Java\jre6\bin".


    Thanks, Nil. It's the same for me, except with (x86) because I have
    a 64-bit system.

    > Right-click on the file name and choose "Run as Administrator" and
    > confirm. Any changes you make in this session should be saved.


    I did that. But why is jusched running at all, when I turned it off
    in msconfig and msconfig still sows it as unchecked? That's the part
    I still don't understand.

    > I hope Oracle fixes this soon. I'm sure it confuses the hell out of a
    > lot of people.


    How many years has it been since the introduction of Vista? I'd
    think if they had any intention to fix it, they would have done so by
    now.

    Or*cle seems to be another Sym*ntec -- they ruin anything they touch.
    Just recently I read a thread about what they did to OpenOffice when
    they bought Sun.


    --
    Stan Brown, Oak Road Systems, Tompkins County, New York, USA
    http://OakRoadSystems.com
    Shikata ga nai...
     
  8. Stan Brown

    Stan Brown Flightless Bird

    On Sat, 2 Oct 2010 21:05:08 -0400, Dick Mahar wrote:
    >
    > "Stan Brown" <the_stan_brown@fastmail.fm> wrote in message
    > news:MPG.27116c016b9f927e98c652@news.individual.net...
    > > I have used msconfig to turn off "Java Platform Auto
    > > Update", but the next time I boot it's back again.

    >
    > Be sure that when you use the msconfig startup menu as you describe, that
    > you have also used the selective startup option.


    Good point, but I checked just now and "selective startup" is indeed
    selected.

    --
    Stan Brown, Oak Road Systems, Tompkins County, New York, USA
    http://OakRoadSystems.com
    Shikata ga nai...
     
  9. Nil

    Nil Flightless Bird

    On 04 Oct 2010, Stan Brown <the_stan_brown@fastmail.fm> wrote in
    alt.windows7.general:

    > I did that. But why is jusched running at all, when I turned it
    > off in msconfig and msconfig still sows it as unchecked? That's
    > the part I still don't understand.


    I don't know. I disabled them using the Sysinternals utility Autoruns,
    and they no longer run at startup. Did you reboot? Maybe it's kicked
    off by the Task Scheduler?

    > How many years has it been since the introduction of Vista? I'd
    > think if they had any intention to fix it, they would have done so
    > by now.


    You're probably right. On the other hand, Sun wasn't good about it,
    either - it took them about a decade to fix the issue where every time
    Java was updated, it installed the new version and left the old one
    there. I used to find people with 5 or 10 complete Java installations.
     
  10. Char Jackson

    Char Jackson Flightless Bird

    On Mon, 04 Oct 2010 10:44:46 -0400, Nil
    <rednoise@REMOVETHIScomcast.net> wrote:

    >On 04 Oct 2010, Stan Brown <the_stan_brown@fastmail.fm> wrote in
    >alt.windows7.general:
    >
    >> How many years has it been since the introduction of Vista? I'd
    >> think if they had any intention to fix it, they would have done so
    >> by now.

    >
    >You're probably right. On the other hand, Sun wasn't good about it,
    >either - it took them about a decade to fix the issue where every time
    >Java was updated, it installed the new version and left the old one
    >there. I used to find people with 5 or 10 complete Java installations.


    That bit of odd behavior went on for so long that I was starting to
    think it was by design.
     
  11. Char Jackson

    Char Jackson Flightless Bird

    On Mon, 4 Oct 2010 07:45:12 -0400, Stan Brown
    <the_stan_brown@fastmail.fm> wrote:

    >On Sat, 2 Oct 2010 21:05:08 -0400, Dick Mahar wrote:
    >>
    >> "Stan Brown" <the_stan_brown@fastmail.fm> wrote in message
    >> news:MPG.27116c016b9f927e98c652@news.individual.net...
    >> > I have used msconfig to turn off "Java Platform Auto
    >> > Update", but the next time I boot it's back again.

    >>
    >> Be sure that when you use the msconfig startup menu as you describe, that
    >> you have also used the selective startup option.

    >
    >Good point, but I checked just now and "selective startup" is indeed
    >selected.


    Any time you deselect an item in the Startup section of msconfig, it
    automatically selects Selective Startup. There's no need to manually
    select it since the two go hand in hand.
     

Share This Page