1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

is there a trick to viewing Russian Cyrillic characters?

Discussion in 'Windows XP' started by mscir, Aug 24, 2010.

  1. mscir

    mscir Flightless Bird

    I installed fonts from several sites that have Russian Cyrillic fonts,
    at least that's what I believe I'm installing. One example is here:

    http://www.freelang.net/fonts/index.php
    RUSSIAN
    Vremya Accented (40 kb)
    Bukinist KOI8 (118 kb)
    Bukinist 1251 (132 kb)
    Kurier KOI8 (20 kb)

    When I view these in a font viewer I see English characters. Is there a
    setting I have to make in Windows to view Russian Cyrillic characters,
    or am I installing non-Cyrillic characters without realizing it?

    Mike
     
  2. Patok

    Patok Flightless Bird

    mscir wrote:
    > I installed fonts from several sites that have Russian Cyrillic fonts,
    > at least that's what I believe I'm installing. One example is here:
    >
    > http://www.freelang.net/fonts/index.php
    > RUSSIAN
    > Vremya Accented (40 kb)
    > Bukinist KOI8 (118 kb)
    > Bukinist 1251 (132 kb)
    > Kurier KOI8 (20 kb)
    >
    > When I view these in a font viewer I see English characters. Is there a
    > setting I have to make in Windows to view Russian Cyrillic characters,
    > or am I installing non-Cyrillic characters without realizing it?


    No, they are Cyrillic all right. I think I had Bukinist installed on
    a previous installation, now I have some others. If you want to see the
    characters, make sure you select a proper character set in the advanced
    view option of Character Map. For instance, Unicode. What is the "font
    viewer" you're talking about - the one that shows the font in different
    sizes? That one won't show the Cyrillic part, only the Western.
    Plus, if you have some other Cyrillic language installed on the
    computer besides English, you'll discover that most of the built-in
    fonts (Times, Arial, etc) already have Cyrillic glyphs.

    --
    You'd be crazy to e-mail me with the crazy. But leave the div alone.
    --
    Whoever bans a book, shall be banished. Whoever burns a book, shall burn.
     
  3. mscir

    mscir Flightless Bird

    On 8/24/2010 8:12 PM, Patok wrote:
    > mscir wrote:
    >> I installed fonts from several sites that have Russian Cyrillic fonts,
    >> at least that's what I believe I'm installing. One example is here:
    >>
    >> http://www.freelang.net/fonts/index.php
    >> RUSSIAN Vremya Accented (40 kb)
    >> Bukinist KOI8 (118 kb)
    >> Bukinist 1251 (132 kb)
    >> Kurier KOI8 (20 kb)
    >>
    >> When I view these in a font viewer I see English characters. Is there
    >> a setting I have to make in Windows to view Russian Cyrillic
    >> characters, or am I installing non-Cyrillic characters without
    >> realizing it?

    >
    > No, they are Cyrillic all right. I think I had Bukinist installed on a
    > previous installation, now I have some others. If you want to see the
    > characters, make sure you select a proper character set in the advanced
    > view option of Character Map. For instance, Unicode. What is the "font
    > viewer" you're talking about - the one that shows the font in different
    > sizes? That one won't show the Cyrillic part, only the Western.
    > Plus, if you have some other Cyrillic language installed on the computer
    > besides English, you'll discover that most of the built-in fonts (Times,
    > Arial, etc) already have Cyrillic glyphs.


    Great Patok,
    that's what I needed to know, It sounds like I have to check the boxes
    next to Cyrillic or Latin or whatever to enable Windows to display those
    characters.
    Thanks,
    Mike
     
  4. PA Bear [MS MVP]

    PA Bear [MS MVP] Flightless Bird

    Ðе, там отÑутÑтвие выходки к характерам проÑмотра руÑÑким Cyrillic. Ð’Ñ‹
    говорите английÑкую Ñзык?

    mscir wrote:
    > I installed fonts from several sites that have Russian Cyrillic fonts,
    > at least that's what I believe I'm installing. One example is here:
    >
    > http://www.freelang.net/fonts/index.php
    > RUSSIAN
    > Vremya Accented (40 kb)
    > Bukinist KOI8 (118 kb)
    > Bukinist 1251 (132 kb)
    > Kurier KOI8 (20 kb)
    >
    > When I view these in a font viewer I see English characters. Is there a
    > setting I have to make in Windows to view Russian Cyrillic characters,
    > or am I installing non-Cyrillic characters without realizing it?
    >
    > Mike
     
  5. Mike S

    Mike S Flightless Bird

    On 8/24/2010 8:12 PM, Patok wrote:
    > mscir wrote:
    >> I installed fonts from several sites that have Russian Cyrillic fonts,
    >> at least that's what I believe I'm installing. One example is here:
    >>
    >> http://www.freelang.net/fonts/index.php
    >> RUSSIAN Vremya Accented (40 kb)
    >> Bukinist KOI8 (118 kb)
    >> Bukinist 1251 (132 kb)
    >> Kurier KOI8 (20 kb)
    >>
    >> When I view these in a font viewer I see English characters. Is there
    >> a setting I have to make in Windows to view Russian Cyrillic
    >> characters, or am I installing non-Cyrillic characters without
    >> realizing it?

    >
    > No, they are Cyrillic all right. I think I had Bukinist installed on a
    > previous installation, now I have some others. If you want to see the
    > characters, make sure you select a proper character set in the advanced
    > view option of Character Map. For instance, Unicode. What is the "font
    > viewer" you're talking about - the one that shows the font in different
    > sizes? That one won't show the Cyrillic part, only the Western.
    > Plus, if you have some other Cyrillic language installed on the computer
    > besides English, you'll discover that most of the built-in fonts (Times,
    > Arial, etc) already have Cyrillic glyphs.


    I spoke too fast, I don't know how to get Cyrillic characters using
    Times, Arial ,etc.

    I tried this: Control Panel > Regional and Language Options, Advanced
    TAB > the top combobox displays "English (United States) and the "Code
    page conversion tables" checkboxes below that have these items checked:

    10000 (MAC - Roman)
    10006 (MAC - Greek I)
    10007 (MAC - Cyrillic)
    10010 (MAC - Romania)
    10017 (MAC - Ukraine)
    10029 (MAC - Latin II)
    1047 (IBM EBCDIC - Latin-1/Open System)
    1148 (IBM EBCDIC - Internation al (500 + Euro))
    1250 (ANSI - Central Europe)
    1251 (ANSI - Cyrillic)
    1252 (ANSI - Latin I)
    1253 (ANSI - Greek)
    1254 (ANSI - Turkish)
    1255 (ANSI - Hebrew)
    1256 (ANSI - Arabic)
    1257 (ANSI - Baltic)
    1258 (ANSI/OEM - Viet Nam)
    1361 (Korean - Johab)
    20127 (US-ASCII)
    20621 (T.61)
    20866 (Russian - KOI8)
    20880 (IBM EBCDIC - Icelandic)
    21025 (IBM EBCDIC - Cyrillic (Serbian, Bulgarian))
    21866 (Ukranian - KOI8-U)
    28591 (ISO 8859-1 Latin I)
    28592 (ISO 8859-2 Central Europe)
    28593 (ISO 8859-3 Latin 3)
    28594 (ISO 8859-4 Baltic)
    28595 (ISO 8859-5 Cyrillic)
    28597 (ISO 8859-7 Greek)
    28599 (ISO 8859-9 Latin 5)
    28605 (ISO 8859-15 Latin 9)
    37 (IBM EBCDIC - U.S./Canada)
    437 (OEM - United States)
    500 (IBM EBCDIC - International)
    50220 (ISO-2022 Japanese with no halfwidth Katakana)
    50221 (ISO-2022 Japanese with halfwidth Katakana)
    50222 (ISO-2922 Japanese JIS X 0201-1989)
    50225 (ISO-2022 Korean)
    50227 (ISO-2022 Simplified Chinese)
    50229 (ISO-2022 Traditional Chinese)
    51949 (EUC-Korean)
    52936 (HZ-GB2312 Simplified Chinese)
    57002 (ISCII Devanagari)
    57003 (ISCII Bengali)
    57004 (ISCII Tamil)
    57005 (ISCII Telugu)
    57006 (ISCII Assamese)
    57007 (ISCII Oriya)
    57008 (ISCII Kannada)
    57009 (ISCII Malayalam)
    57010 (ISCII Gujarati)
    57011 (ISCII Gurmukhi)
    65000 (UTF-7)
    65001 (UTF-8)
    720 (Arabic - Transparent ASMO)
    737 (OEM - Greek 437G)
    775 (OEM - Baltic)
    850 (OEM - Multilingual Latin I)
    852 (OEM - Latin II)
    855 (OEM - Cyrillic
    857 (OEM - Turkish)
    862 (OEM - Hebrew)
    836 (OEM - Canadian French)
    866 (OEM - Russian)
    869 (OEM - Modern Greek)
    874 (ANSI/OEM - Thai)
    875 (IBM EBCDIC - Modern Greek)
    932 (ANSI/OEM - Japanese Shift-JIS)
    936 (ANSI/OEM - Simplified Chinese GBK)
    949 (ANSI/OEM - Korean)
    950 (ANSI/OEM - Traditional Chinese Big5)

    I don't know where to install or enable Unicode, or another language.
    How would you recommend I proceed so I can get Russian Cyrillic
    characters in Photoshop or Openoffice?

    Thanks,
    Mike
     
  6. Patok

    Patok Flightless Bird

    Mike S wrote:
    > On 8/24/2010 8:12 PM, Patok wrote:
    >> mscir wrote:
    >>> I installed fonts from several sites that have Russian Cyrillic fonts,
    >>> at least that's what I believe I'm installing. One example is here:
    >>>
    >>> http://www.freelang.net/fonts/index.php
    >>> RUSSIAN Vremya Accented (40 kb)
    >>> Bukinist KOI8 (118 kb)
    >>> Bukinist 1251 (132 kb)
    >>> Kurier KOI8 (20 kb)
    >>>
    >>> When I view these in a font viewer I see English characters. Is there
    >>> a setting I have to make in Windows to view Russian Cyrillic
    >>> characters, or am I installing non-Cyrillic characters without
    >>> realizing it?

    >>
    >> No, they are Cyrillic all right. I think I had Bukinist installed on a
    >> previous installation, now I have some others. If you want to see the
    >> characters, make sure you select a proper character set in the advanced
    >> view option of Character Map. For instance, Unicode. What is the "font
    >> viewer" you're talking about - the one that shows the font in different
    >> sizes? That one won't show the Cyrillic part, only the Western.
    >> Plus, if you have some other Cyrillic language installed on the computer
    >> besides English, you'll discover that most of the built-in fonts (Times,
    >> Arial, etc) already have Cyrillic glyphs.

    >
    > I spoke too fast, I don't know how to get Cyrillic characters using
    > Times, Arial ,etc.
    >
    > I tried this: Control Panel > Regional and Language Options, Advanced
    > TAB > the top combobox displays "English (United States) and the "Code
    > page conversion tables" checkboxes below that have these items checked:


    [snip]

    > I don't know where to install or enable Unicode, or another language.
    > How would you recommend I proceed so I can get Russian Cyrillic
    > characters in Photoshop or Openoffice?


    OK, so you want to input Cyrillic, not just use a document already
    written in it? In that case, I'd suggest you install a language that
    uses Cyrillic - Russian or Bulgarian. If you do that, you'll be able to
    switch languages inside the document and enter parts in English, parts
    in something else.
    The advanced tab that you're talking about concerns only the mapping
    of the non-unicode programs. Most new programs should be Unicode aware
    and you have no business changing things there. (Win XP is already
    unicode internally; if you get from somewhere a file that has a filename
    in Cyrillic, it will display properly on your system. The 65000 (UTF-7)
    and 65001 (UTF-8) that you provided in your list are Unicode.) If your
    Thunderbird is setup properly, you should be able to see Cyrillic in the
    messages you're reading - the Google translate Russian gibberish that PA
    Bear posted in a previous message, as well as my entry of the alphabet here:

    абвгдежзийклмнопрÑтуфхцчшщъьюÑ.

    To see that Cyrillic is already included in the system fonts, use the
    Character Map (Run charmap) and look at Arial - make sure that Advanced
    view is checked, and you're looking at the Unicode character set.
    Scrolling down, you'll see all kinds of glyphs, Arabic and whatnot, and
    Cyrillic among them. If you want to use just individual letters in your
    documents, you don't even need to install a language - you can copy them
    one by one from Charmap and paste them in the document. For example,
    here I pasted some Arabic letter, even though I don't have Arabic
    installed: غ

    To install more languages, use the same Regional and Language Options
    control, Languages - Details.

    --
    You'd be crazy to e-mail me with the crazy. But leave the div alone.
    --
    Whoever bans a book, shall be banished. Whoever burns a book, shall burn.
     
  7. Mike S

    Mike S Flightless Bird

    On 8/25/2010 1:55 AM, Patok wrote:
    <ship>
    > OK, so you want to input Cyrillic, not just use a document already
    > written in it? In that case, I'd suggest you install a language that
    > uses Cyrillic - Russian or Bulgarian. If you do that, you'll be able to
    > switch languages inside the document and enter parts in English, parts
    > in something else.
    > The advanced tab that you're talking about concerns only the mapping of
    > the non-unicode programs. Most new programs should be Unicode aware and
    > you have no business changing things there. (Win XP is already unicode
    > internally; if you get from somewhere a file that has a filename in
    > Cyrillic, it will display properly on your system. The 65000 (UTF-7) and
    > 65001 (UTF-8) that you provided in your list are Unicode.) If your
    > Thunderbird is setup properly, you should be able to see Cyrillic in the
    > messages you're reading - the Google translate Russian gibberish that PA
    > Bear posted in a previous message, as well as my entry of the alphabet
    > here:
    >
    > абвгдежзийклмнопрÑтуфхцчшщъьюÑ.
    >
    > To see that Cyrillic is already included in the system fonts, use the
    > Character Map (Run charmap) and look at Arial - make sure that Advanced
    > view is checked, and you're looking at the Unicode character set.
    > Scrolling down, you'll see all kinds of glyphs, Arabic and whatnot, and
    > Cyrillic among them. If you want to use just individual letters in your
    > documents, you don't even need to install a language - you can copy them
    > one by one from Charmap and paste them in the document. For example,
    > here I pasted some Arabic letter, even though I don't have Arabic
    > installed: غ
    >
    > To install more languages, use the same Regional and Language Options
    > control, Languages - Details.


    Thanks very much, that works perfectly, much appreciated.
     
  8. Mike S

    Mike S Flightless Bird

    On 8/25/2010 1:55 AM, Patok wrote:
    <snip>
    > To install more languages, use the same Regional and Language Options
    > control, Languages - Details.


    Patok,
    I installed Russian and have it displayed in the language bar in the
    task bar, for some reason the language keeps spontaneously changing from
    En to Ru, it threw me for a while when I couldn't log into any sites, I
    thought someone had hacked into my computer then changed all of my
    website logins, but after thinking about how unlikely that was I found
    out I had been typing Cyrillic the whole time when trying to make an
    OpenOffice document. How can I select English and keep it from changing
    to Russian?
    Thanks,
    Mike
     
  9. Patok

    Patok Flightless Bird

    Mike S wrote:
    > On 8/25/2010 1:55 AM, Patok wrote:
    > <snip>
    >> To install more languages, use the same Regional and Language Options
    >> control, Languages - Details.

    >
    > Patok,
    > I installed Russian and have it displayed in the language bar in the
    > task bar, for some reason the language keeps spontaneously changing from
    > En to Ru, it threw me for a while when I couldn't log into any sites, I
    > thought someone had hacked into my computer then changed all of my
    > website logins, but after thinking about how unlikely that was I found
    > out I had been typing Cyrillic the whole time when trying to make an
    > OpenOffice document. How can I select English and keep it from changing
    > to Russian?


    What you write sounds strange, I don't know what to say. Maybe you're
    inadvertently switching to Russian while typing? (Sorry if this sounds
    like a dumb idea, but one never knows.) Check to see what the key
    settings are - maybe while typing, you press the switch combination. The
    settings can be found in Regional and Language Options -> Languages ->
    Details -> Key settings.
    If this is the case, and you don't really need to be switching often,
    you can disable the keyboard switching altogether, and only click on the
    language bar to change languages.

    --
    You'd be crazy to e-mail me with the crazy. But leave the div alone.
    --
    Whoever bans a book, shall be banished. Whoever burns a book, shall burn.
     
  10. Bob I

    Bob I Flightless Bird

    Mike S wrote:

    > On 8/25/2010 1:55 AM, Patok wrote:
    > <snip>
    >
    >> To install more languages, use the same Regional and Language Options
    >> control, Languages - Details.

    >
    >
    > Patok,
    > I installed Russian and have it displayed in the language bar in the
    > task bar, for some reason the language keeps spontaneously changing from
    > En to Ru, it threw me for a while when I couldn't log into any sites, I
    > thought someone had hacked into my computer then changed all of my
    > website logins, but after thinking about how unlikely that was I found
    > out I had been typing Cyrillic the whole time when trying to make an
    > OpenOffice document. How can I select English and keep it from changing
    > to Russian?
    > Thanks,
    > Mike



    Disable or change the Hotkey to something you are not likely to press.
    Click "Key Settings" button in "Details" as above.
     
  11. HeyBub

    HeyBub Flightless Bird

    Mike S wrote:
    > On 8/25/2010 1:55 AM, Patok wrote:
    > <snip>
    >> To install more languages, use the same Regional and Language Options
    >> control, Languages - Details.

    >
    > Patok,
    > I installed Russian and have it displayed in the language bar in the
    > task bar, for some reason the language keeps spontaneously changing
    > from En to Ru, it threw me for a while when I couldn't log into any
    > sites, I thought someone had hacked into my computer then changed all
    > of my website logins, but after thinking about how unlikely that was
    > I found out I had been typing Cyrillic the whole time when trying to
    > make an OpenOffice document. How can I select English and keep it
    > from changing to Russian?
    > Thanks,
    > Mike


    You've got to set English as the default
     
  12. Mike S

    Mike S Flightless Bird

    On 8/28/2010 4:46 PM, HeyBub wrote:
    > Mike S wrote:
    >> On 8/25/2010 1:55 AM, Patok wrote:
    >> <snip>
    >>> To install more languages, use the same Regional and Language Options
    >>> control, Languages - Details.

    >>
    >> Patok,
    >> I installed Russian and have it displayed in the language bar in the
    >> task bar, for some reason the language keeps spontaneously changing
    >> from En to Ru, it threw me for a while when I couldn't log into any
    >> sites, I thought someone had hacked into my computer then changed all
    >> of my website logins, but after thinking about how unlikely that was
    >> I found out I had been typing Cyrillic the whole time when trying to
    >> make an OpenOffice document. How can I select English and keep it
    >> from changing to Russian?
    >> Thanks,
    >> Mike

    >
    > You've got to set English as the default


    I think it was both, setting English as default, and disabling all of
    the keyboard language change keys, thanks to everyone who replied.
     

Share This Page