1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Internet Explorer ver 7 "View, Source" question

Discussion in 'Internet Explorer' started by kraut, Apr 6, 2010.

  1. kraut

    kraut Flightless Bird

    I am running Windows XP Home Edition Version 2002 service pack 3 and
    Internet Explorer ver 7.

    When I used to be at a web site with Internet Explorer and click on
    "View, Source" the source or HTML code for the site used to open in
    Notepad. I do not know what happened but now when I click on "View,
    Source" a Windows Explorer" type window titled "Desktop" opens that
    lists all the programs I have on the desktop.

    Can someone tell me how to get it back to where when I click "View,
    Source" it will open in Notepad again like it used to??

    TIA
     
  2. Robert Aldwinckle

    Robert Aldwinckle Flightless Bird

    "kraut" <kraut3852@yahoo.comg> wrote in message
    news:rhtmr510krjv2lnl4fi27a48qi524nn1sq@4ax.com...

    > Can someone tell me how to get it back to where when I click "View,
    > Source" it will open in Notepad again like it used to??



    I can't remember if IE7 has this but if you installed IE8 instead you could
    use its Developer Tools to switch source viewers easily. (F12, Alt-F,C,N)

    ---
     
  3. G. R. Woodring

    G. R. Woodring Flightless Bird

    Date: 4/6/2010 2:10 PM, Author: kraut Wrote:
    >
    > I am running Windows XP Home Edition Version 2002 service pack 3 and
    > Internet Explorer ver 7.
    >
    > When I used to be at a web site with Internet Explorer and click on
    > "View, Source" the source or HTML code for the site used to open in
    > Notepad. I do not know what happened but now when I click on "View,
    > Source" a Windows Explorer" type window titled "Desktop" opens that
    > lists all the programs I have on the desktop.
    >
    > Can someone tell me how to get it back to where when I click "View,
    > Source" it will open in Notepad again like it used to??
    >
    > TIA
    >
    >


    In Internet Explorer open [Tools]>[Internet Options], "Programs" tab. What do you
    have for HTML Editor? Your description suggests it has been set to "Windows
    Explorer" or "explorer.exe".

    --
    G. R. Woodring
     
  4. PA Bear [MS MVP]

    PA Bear [MS MVP] Flightless Bird

    G. R. Woodring wrote:
    > Date: 4/6/2010 2:10 PM, Author: kraut Wrote:
    >>
    >> I am running Windows XP Home Edition Version 2002 service pack 3 and
    >> Internet Explorer ver 7.
    >>
    >> When I used to be at a web site with Internet Explorer and click on
    >> "View, Source" the source or HTML code for the site used to open in
    >> Notepad. I do not know what happened but now when I click on "View,
    >> Source" a Windows Explorer" type window titled "Desktop" opens that
    >> lists all the programs I have on the desktop.
    >>
    >> Can someone tell me how to get it back to where when I click "View,
    >> Source" it will open in Notepad again like it used to??

    >
    > In Internet Explorer open [Tools]>[Internet Options], "Programs" tab.
    > What do you have for HTML Editor? Your description suggests it has been
    > set to "Windows Explorer" or "explorer.exe".


    +1
     
  5. kraut

    kraut Flightless Bird

    Re: Internet Explorer ver 7 "View, Source" question - Update

    On Tue, 6 Apr 2010 22:08:42 -0400, "PA Bear [MS MVP]"
    <PABearMVP@gmail.com> wrote:

    >>>
    >>> I am running Windows XP Home Edition Version 2002 service pack 3 and
    >>> Internet Explorer ver 7.
    >>>
    >>> When I used to be at a web site with Internet Explorer and click on
    >>> "View, Source" the source or HTML code for the site used to open in
    >>> Notepad. I do not know what happened but now when I click on "View,
    >>> Source" a Windows Explorer" type window titled "Desktop" opens that
    >>> lists all the programs I have on the desktop.
    >>>
    >>> Can someone tell me how to get it back to where when I click "View,
    >>> Source" it will open in Notepad again like it used to??

    >>
    >> In Internet Explorer open [Tools]>[Internet Options], "Programs" tab.
    >> What do you have for HTML Editor? Your description suggests it has been
    >> set to "Windows Explorer" or "explorer.exe".

    >
    >+1



    Well no one seemed to be willing or able to help me out here (Have no
    idea what the hang +1 means) so I figured I would upgrade to version 8
    and fix it that way.

    I did not want to at first 'cause of problems others had with it but
    so far I have had no problems YET.

    Of cours I am not one to add this or that or to change things. I run
    it the way it is. Maybe that is why I have had no problems!!

    Thanks to those who tryed to help.
     
  6. G. R. Woodring

    G. R. Woodring Flightless Bird

    Re: Internet Explorer ver 7 "View, Source" question - Update

    Date: 4/9/2010 1:07 PM, Author: kraut Wrote:
    > On Tue, 6 Apr 2010 22:08:42 -0400, "PA Bear [MS MVP]"
    > <PABearMVP@gmail.com> wrote:
    >
    >>>> I am running Windows XP Home Edition Version 2002 service pack 3 and
    >>>> Internet Explorer ver 7.
    >>>>
    >>>> When I used to be at a web site with Internet Explorer and click on
    >>>> "View, Source" the source or HTML code for the site used to open in
    >>>> Notepad. I do not know what happened but now when I click on "View,
    >>>> Source" a Windows Explorer" type window titled "Desktop" opens that
    >>>> lists all the programs I have on the desktop.
    >>>>
    >>>> Can someone tell me how to get it back to where when I click "View,
    >>>> Source" it will open in Notepad again like it used to??
    >>> In Internet Explorer open [Tools]>[Internet Options], "Programs" tab.
    >>> What do you have for HTML Editor? Your description suggests it has been
    >>> set to "Windows Explorer" or "explorer.exe".

    >> +1

    >
    >
    > Well no one seemed to be willing or able to help me out here (Have no
    > idea what the hang +1 means) so I figured I would upgrade to version 8
    > and fix it that way.
    >
    > I did not want to at first 'cause of problems others had with it but
    > so far I have had no problems YET.
    >
    > Of cours I am not one to add this or that or to change things. I run
    > it the way it is. Maybe that is why I have had no problems!!
    >
    > Thanks to those who tryed to help.
    >
    >


    I asked : "What do you have for HTML Editor?". P A Bear responded +1 to add himself
    as one who agreed that this was a good setting to check. You didn't answer the
    question. Probably no one else responded because they wanted to know if this setting
    was or was not the problem before suggesting other possible solutions.

    As a rule IE8 would inherit any faulty settings from IE7 but as Windows Explorer
    would not be a valid choice as HTML editor, the new install might have restored the
    normal default of Notepad.

    --
    G. R. Woodring
     
  7. Jeff Strickland

    Jeff Strickland Flightless Bird

    "kraut" <kraut3852@yahoo.comg> wrote in message
    news:rhtmr510krjv2lnl4fi27a48qi524nn1sq@4ax.com...
    >
    >
    > I am running Windows XP Home Edition Version 2002 service pack 3 and
    > Internet Explorer ver 7.
    >
    > When I used to be at a web site with Internet Explorer and click on
    > "View, Source" the source or HTML code for the site used to open in
    > Notepad. I do not know what happened but now when I click on "View,
    > Source" a Windows Explorer" type window titled "Desktop" opens that
    > lists all the programs I have on the desktop.
    >
    > Can someone tell me how to get it back to where when I click "View,
    > Source" it will open in Notepad again like it used to??
    >
    > TIA
    >
    >



    Have you tried TOOLS>INTERNET OPTIONS>PROGRAMS, and set the default HTML
    editor to Notepad?
     
  8. Jeff Strickland

    Jeff Strickland Flightless Bird

    Re: Internet Explorer ver 7 "View, Source" question - Update

    "kraut" <kraut3852@yahoo.comg> wrote in message
    news:rcnur51e5g8ofqud7n639o3a8vd0fdmvc0@4ax.com...
    > On Tue, 6 Apr 2010 22:08:42 -0400, "PA Bear [MS MVP]"
    > <PABearMVP@gmail.com> wrote:
    >
    >>>>
    >>>> I am running Windows XP Home Edition Version 2002 service pack 3 and
    >>>> Internet Explorer ver 7.
    >>>>
    >>>> When I used to be at a web site with Internet Explorer and click on
    >>>> "View, Source" the source or HTML code for the site used to open in
    >>>> Notepad. I do not know what happened but now when I click on "View,
    >>>> Source" a Windows Explorer" type window titled "Desktop" opens that
    >>>> lists all the programs I have on the desktop.
    >>>>
    >>>> Can someone tell me how to get it back to where when I click "View,
    >>>> Source" it will open in Notepad again like it used to??
    >>>
    >>> In Internet Explorer open [Tools]>[Internet Options], "Programs" tab.
    >>> What do you have for HTML Editor? Your description suggests it has been
    >>> set to "Windows Explorer" or "explorer.exe".

    >>
    >>+1

    >
    >
    > Well no one seemed to be willing or able to help me out here (Have no
    > idea what the hang +1 means) so I figured I would upgrade to version 8
    > and fix it that way.
    >
    > I did not want to at first 'cause of problems others had with it but
    > so far I have had no problems YET.
    >
    > Of cours I am not one to add this or that or to change things. I run
    > it the way it is. Maybe that is why I have had no problems!!
    >
    > Thanks to those who tryed to help.
    >
    >


    You still will be required to visit TOOLS>INTERNET OPTIONS>PROGRAMS and set
    the HTML editor to Notepad.
     
  9. kraut

    kraut Flightless Bird

    Re: Internet Explorer ver 7 "View, Source" question - Update

    On Fri, 9 Apr 2010 18:17:26 -0700, "Jeff Strickland"
    <crwlrjeff@yahoo.com> wrote:

    >>>>>
    >>>>> I am running Windows XP Home Edition Version 2002 service pack 3 and
    >>>>> Internet Explorer ver 7.
    >>>>>
    >>>>> When I used to be at a web site with Internet Explorer and click on
    >>>>> "View, Source" the source or HTML code for the site used to open in
    >>>>> Notepad. I do not know what happened but now when I click on "View,
    >>>>> Source" a Windows Explorer" type window titled "Desktop" opens that
    >>>>> lists all the programs I have on the desktop.
    >>>>>
    >>>>> Can someone tell me how to get it back to where when I click "View,
    >>>>> Source" it will open in Notepad again like it used to??
    >>>>
    >>>> In Internet Explorer open [Tools]>[Internet Options], "Programs" tab.
    >>>> What do you have for HTML Editor? Your description suggests it has been
    >>>> set to "Windows Explorer" or "explorer.exe".
    >>>
    >>>+1

    >>
    >>
    >> Well no one seemed to be willing or able to help me out here (Have no
    >> idea what the hang +1 means) so I figured I would upgrade to version 8
    >> and fix it that way.
    >>
    >> I did not want to at first 'cause of problems others had with it but
    >> so far I have had no problems YET.
    >>
    >> Of cours I am not one to add this or that or to change things. I run
    >> it the way it is. Maybe that is why I have had no problems!!
    >>
    >> Thanks to those who tryed to help.
    >>
    >>

    >
    >You still will be required to visit TOOLS>INTERNET OPTIONS>PROGRAMS and set
    >the HTML editor to Notepad.
    >
    >


    Not so.

    When I upgraded to version 8 it set it so when I click "View, Source"
    it shows the the source or HTML code for the site in some kind of text
    viewer (Not Notepad) that evidently is part of version 8.

    As for TOOLS>INTERNET OPTIONS>PROGRAMS> HTML editor it is set to MS
    Front Page Editor as it has always been even when it used to open the
    source in Notepad. One day for whatever reason it just stopped
    showing it in Notepad.

    Anyways version 8 straightened it out so it makes no difference.
    TOOLS>INTERNET OPTIONS>PROGRAMS> HTML editor is still set to MS Front
    Page Editor.
     
  10. Jeff Strickland

    Jeff Strickland Flightless Bird

    Re: Internet Explorer ver 7 "View, Source" question - Update

    "kraut" <kraut3852@yahoo.comg> wrote in message
    news:01svr51c0rbkqa0tqhhpafr4nkmpnsf95r@4ax.com...
    > On Fri, 9 Apr 2010 18:17:26 -0700, "Jeff Strickland"
    > <crwlrjeff@yahoo.com> wrote:
    >
    >>>>>>
    >>>>>> I am running Windows XP Home Edition Version 2002 service pack 3 and
    >>>>>> Internet Explorer ver 7.
    >>>>>>
    >>>>>> When I used to be at a web site with Internet Explorer and click on
    >>>>>> "View, Source" the source or HTML code for the site used to open in
    >>>>>> Notepad. I do not know what happened but now when I click on "View,
    >>>>>> Source" a Windows Explorer" type window titled "Desktop" opens that
    >>>>>> lists all the programs I have on the desktop.
    >>>>>>
    >>>>>> Can someone tell me how to get it back to where when I click "View,
    >>>>>> Source" it will open in Notepad again like it used to??
    >>>>>
    >>>>> In Internet Explorer open [Tools]>[Internet Options], "Programs" tab.
    >>>>> What do you have for HTML Editor? Your description suggests it has
    >>>>> been
    >>>>> set to "Windows Explorer" or "explorer.exe".
    >>>>
    >>>>+1
    >>>
    >>>
    >>> Well no one seemed to be willing or able to help me out here (Have no
    >>> idea what the hang +1 means) so I figured I would upgrade to version 8
    >>> and fix it that way.
    >>>
    >>> I did not want to at first 'cause of problems others had with it but
    >>> so far I have had no problems YET.
    >>>
    >>> Of cours I am not one to add this or that or to change things. I run
    >>> it the way it is. Maybe that is why I have had no problems!!
    >>>
    >>> Thanks to those who tryed to help.
    >>>
    >>>

    >>
    >>You still will be required to visit TOOLS>INTERNET OPTIONS>PROGRAMS and
    >>set
    >>the HTML editor to Notepad.
    >>
    >>

    >
    > Not so.
    >
    > When I upgraded to version 8 it set it so when I click "View, Source"
    > it shows the the source or HTML code for the site in some kind of text
    > viewer (Not Notepad) that evidently is part of version 8.
    >
    > As for TOOLS>INTERNET OPTIONS>PROGRAMS> HTML editor it is set to MS
    > Front Page Editor as it has always been even when it used to open the
    > source in Notepad. One day for whatever reason it just stopped
    > showing it in Notepad.
    >
    > Anyways version 8 straightened it out so it makes no difference.
    > TOOLS>INTERNET OPTIONS>PROGRAMS> HTML editor is still set to MS Front
    > Page Editor.
    >
    >


    Okay, I'm confused.

    If Notepad is NOT the default viewer/editor of HTML, then it should not be
    the first to open when you right-click and select View Source. You can
    right-click and select Open With, and select Notepad, but if you select View
    Source, the default editor should be invoked. If something else happened,
    then you have finally fixed it.
     
  11. Jeff Strickland

    Jeff Strickland Flightless Bird

    Re: APPOLOGIES

    Sorry, I'm running IE8, and have Notepad set as the default HTML editor, yet
    View Source does not invoke Notepad. I get a Notepad-like editor, but it has
    line numbers and different colors of text -- both of these are features that
    Notepad does not support -- so that the code can be more easily read.





    "Jeff Strickland" <crwlrjeff@yahoo.com> wrote in message
    news:hpqeku$up5$1@news.eternal-september.org...
    >
    > "kraut" <kraut3852@yahoo.comg> wrote in message
    > news:01svr51c0rbkqa0tqhhpafr4nkmpnsf95r@4ax.com...
    >> On Fri, 9 Apr 2010 18:17:26 -0700, "Jeff Strickland"
    >> <crwlrjeff@yahoo.com> wrote:
    >>
    >>>>>>>
    >>>>>>> I am running Windows XP Home Edition Version 2002 service pack 3 and
    >>>>>>> Internet Explorer ver 7.
    >>>>>>>
    >>>>>>> When I used to be at a web site with Internet Explorer and click on
    >>>>>>> "View, Source" the source or HTML code for the site used to open in
    >>>>>>> Notepad. I do not know what happened but now when I click on "View,
    >>>>>>> Source" a Windows Explorer" type window titled "Desktop" opens that
    >>>>>>> lists all the programs I have on the desktop.
    >>>>>>>
    >>>>>>> Can someone tell me how to get it back to where when I click "View,
    >>>>>>> Source" it will open in Notepad again like it used to??
    >>>>>>
    >>>>>> In Internet Explorer open [Tools]>[Internet Options], "Programs"
    >>>>>> tab.
    >>>>>> What do you have for HTML Editor? Your description suggests it has
    >>>>>> been
    >>>>>> set to "Windows Explorer" or "explorer.exe".
    >>>>>
    >>>>>+1
    >>>>
    >>>>
    >>>> Well no one seemed to be willing or able to help me out here (Have no
    >>>> idea what the hang +1 means) so I figured I would upgrade to version 8
    >>>> and fix it that way.
    >>>>
    >>>> I did not want to at first 'cause of problems others had with it but
    >>>> so far I have had no problems YET.
    >>>>
    >>>> Of cours I am not one to add this or that or to change things. I run
    >>>> it the way it is. Maybe that is why I have had no problems!!
    >>>>
    >>>> Thanks to those who tryed to help.
    >>>>
    >>>>
    >>>
    >>>You still will be required to visit TOOLS>INTERNET OPTIONS>PROGRAMS and
    >>>set
    >>>the HTML editor to Notepad.
    >>>
    >>>

    >>
    >> Not so.
    >>
    >> When I upgraded to version 8 it set it so when I click "View, Source"
    >> it shows the the source or HTML code for the site in some kind of text
    >> viewer (Not Notepad) that evidently is part of version 8.
    >>
    >> As for TOOLS>INTERNET OPTIONS>PROGRAMS> HTML editor it is set to MS
    >> Front Page Editor as it has always been even when it used to open the
    >> source in Notepad. One day for whatever reason it just stopped
    >> showing it in Notepad.
    >>
    >> Anyways version 8 straightened it out so it makes no difference.
    >> TOOLS>INTERNET OPTIONS>PROGRAMS> HTML editor is still set to MS Front
    >> Page Editor.
    >>
    >>

    >
    > Okay, I'm confused.
    >
    > If Notepad is NOT the default viewer/editor of HTML, then it should not be
    > the first to open when you right-click and select View Source. You can
    > right-click and select Open With, and select Notepad, but if you select
    > View Source, the default editor should be invoked. If something else
    > happened, then you have finally fixed it.
    >
    >
    >
    >
    >
    >
    >
     
  12. Rob

    Rob Flightless Bird

    Re: APPOLOGIES

    Jeff Strickland <crwlrjeff@yahoo.com> wrote:
    > Sorry, I'm running IE8, and have Notepad set as the default HTML editor, yet
    > View Source does not invoke Notepad. I get a Notepad-like editor, but it has
    > line numbers and different colors of text -- both of these are features that
    > Notepad does not support -- so that the code can be more easily read.


    Of course. View source is not the same as Edit. View source invokes
    a built-in viewer. You get the HTML editor when you edit the page.
    (File->Edit)
     
  13. G. R. Woodring

    G. R. Woodring Flightless Bird

    Re: APPOLOGIES

    Date: 4/10/2010 2:13 PM, Author: Jeff Strickland Wrote:
    > Sorry, I'm running IE8, and have Notepad set as the default HTML editor, yet
    > View Source does not invoke Notepad. I get a Notepad-like editor, but it has
    > line numbers and different colors of text -- both of these are features that
    > Notepad does not support -- so that the code can be more easily read.
    >
    >


    Look closely, You may have Notepad++ as the HTML editor. I have Notepad++ set as the
    HTML editor at [Tools]>[Internet Options], "Programs", HTML editor: and when I view
    source I get the source code displayed in Notepad++. It has the line numbers and
    syntax coloring you describe. If Notepad _is_ selected, right-click on notepad.exe
    and check "Properties", "Version" tab. Another program may have been renamed as
    "notepad.exe".

    --
    G. R. Woodring (WinXP SP3,IE8 ver: 8.0.6001.18702)

    >
    >
    >
    > "Jeff Strickland" <crwlrjeff@yahoo.com> wrote in message
    > news:hpqeku$up5$1@news.eternal-september.org...
    >> "kraut" <kraut3852@yahoo.comg> wrote in message
    >> news:01svr51c0rbkqa0tqhhpafr4nkmpnsf95r@4ax.com...
    >>> On Fri, 9 Apr 2010 18:17:26 -0700, "Jeff Strickland"
    >>> <crwlrjeff@yahoo.com> wrote:
    >>>
    >>>>>>>> I am running Windows XP Home Edition Version 2002 service pack 3 and
    >>>>>>>> Internet Explorer ver 7.
    >>>>>>>>
    >>>>>>>> When I used to be at a web site with Internet Explorer and click on
    >>>>>>>> "View, Source" the source or HTML code for the site used to open in
    >>>>>>>> Notepad. I do not know what happened but now when I click on "View,
    >>>>>>>> Source" a Windows Explorer" type window titled "Desktop" opens that
    >>>>>>>> lists all the programs I have on the desktop.
    >>>>>>>>
    >>>>>>>> Can someone tell me how to get it back to where when I click "View,
    >>>>>>>> Source" it will open in Notepad again like it used to??
    >>>>>>> In Internet Explorer open [Tools]>[Internet Options], "Programs"
    >>>>>>> tab.
    >>>>>>> What do you have for HTML Editor? Your description suggests it has
    >>>>>>> been
    >>>>>>> set to "Windows Explorer" or "explorer.exe".
    >>>>>> +1
    >>>>>
    >>>>> Well no one seemed to be willing or able to help me out here (Have no
    >>>>> idea what the hang +1 means) so I figured I would upgrade to version 8
    >>>>> and fix it that way.
    >>>>>
    >>>>> I did not want to at first 'cause of problems others had with it but
    >>>>> so far I have had no problems YET.
    >>>>>
    >>>>> Of cours I am not one to add this or that or to change things. I run
    >>>>> it the way it is. Maybe that is why I have had no problems!!
    >>>>>
    >>>>> Thanks to those who tryed to help.
    >>>>>
    >>>>>
    >>>> You still will be required to visit TOOLS>INTERNET OPTIONS>PROGRAMS and
    >>>> set
    >>>> the HTML editor to Notepad.
    >>>>
    >>>>
    >>> Not so.
    >>>
    >>> When I upgraded to version 8 it set it so when I click "View, Source"
    >>> it shows the the source or HTML code for the site in some kind of text
    >>> viewer (Not Notepad) that evidently is part of version 8.
    >>>
    >>> As for TOOLS>INTERNET OPTIONS>PROGRAMS> HTML editor it is set to MS
    >>> Front Page Editor as it has always been even when it used to open the
    >>> source in Notepad. One day for whatever reason it just stopped
    >>> showing it in Notepad.
    >>>
    >>> Anyways version 8 straightened it out so it makes no difference.
    >>> TOOLS>INTERNET OPTIONS>PROGRAMS> HTML editor is still set to MS Front
    >>> Page Editor.
    >>>
    >>>

    >> Okay, I'm confused.
    >>
    >> If Notepad is NOT the default viewer/editor of HTML, then it should not be
    >> the first to open when you right-click and select View Source. You can
    >> right-click and select Open With, and select Notepad, but if you select
    >> View Source, the default editor should be invoked. If something else
    >> happened, then you have finally fixed it.
    >>
    >>
    >>
    >>
    >>
    >>
    >>

    >
    >
     
  14. Tom Lake

    Tom Lake Flightless Bird

    Re: APPOLOGIES

    "G. R. Woodring" <tejbbqevat@rneguyvax.arg> wrote in message
    news:-ORuITKa2KHA.4336@TK2MSFTNGP04.phx.gbl...
    > Date: 4/10/2010 2:13 PM, Author: Jeff Strickland Wrote:
    >> Sorry, I'm running IE8, and have Notepad set as the default HTML editor,
    >> yet View Source does not invoke Notepad. I get a Notepad-like editor, but
    >> it has line numbers and different colors of text -- both of these are
    >> features that Notepad does not support -- so that the code can be more
    >> easily read.
    >>
    >>

    >
    > Look closely, You may have Notepad++ as the HTML editor. I have Notepad++
    > set as the HTML editor at [Tools]>[Internet Options], "Programs", HTML
    > editor: and when I view source I get the source code displayed in
    > Notepad++. It has the line numbers and syntax coloring you describe. If
    > Notepad _is_ selected, right-click on notepad.exe and check "Properties",
    > "Version" tab. Another program may have been renamed as "notepad.exe".


    In Windows 7, if nothing is specified in Tools-Internet Options-Programs
    (the entry
    is blank), you get the line-numbered, color-coded editor when View Source
    is invoked.

    Tom Lake
     
  15. G. R. Woodring

    G. R. Woodring Flightless Bird

    Re: APPOLOGIES

    Date: 4/11/2010 3:27 PM, Author: Tom Lake Wrote:
    >
    > "G. R. Woodring" <tejbbqevat@rneguyvax.arg> wrote in message
    > news:-ORuITKa2KHA.4336@TK2MSFTNGP04.phx.gbl...
    >> Date: 4/10/2010 2:13 PM, Author: Jeff Strickland Wrote:
    >>> Sorry, I'm running IE8, and have Notepad set as the default HTML
    >>> editor, yet View Source does not invoke Notepad. I get a Notepad-like
    >>> editor, but it has line numbers and different colors of text -- both
    >>> of these are features that Notepad does not support -- so that the
    >>> code can be more easily read.
    >>>
    >>>

    >>
    >> Look closely, You may have Notepad++ as the HTML editor. I have
    >> Notepad++ set as the HTML editor at [Tools]>[Internet Options],
    >> "Programs", HTML editor: and when I view source I get the source code
    >> displayed in Notepad++. It has the line numbers and syntax coloring
    >> you describe. If Notepad _is_ selected, right-click on notepad.exe
    >> and check "Properties", "Version" tab. Another program may have been
    >> renamed as "notepad.exe".

    >
    > In Windows 7, if nothing is specified in Tools-Internet Options-Programs
    > (the entry
    > is blank), you get the line-numbered, color-coded editor when View
    > Source is invoked.
    >
    > Tom Lake


    The OP, kraut, offered the following:
    "I am running Windows XP Home Edition Version 2002 service pack 3 and
    Internet Explorer ver 7."

    Jeff Strickland stated that he was using IE8 but didn't specify the O/S, but he did
    specify that Notepad was set as HTML editor. It may be that Windows Seven uses a
    syntax-highlighting viewer for View Source and ignores the HTML editor setting. The
    HTML editor setting would probably be what is used for right-click, edit for .html
    files. I'm not quite ready for Win7, and neither is my system :-(

    --
    G. R. Woodring
     
  16. Jeff Strickland

    Jeff Strickland Flightless Bird

    Re: APPOLOGIES

    "G. R. Woodring" <tejbbqevat@rneguyvax.arg> wrote in message
    news:-OyuJWZb2KHA.6048@TK2MSFTNGP06.phx.gbl...
    > Date: 4/11/2010 3:27 PM, Author: Tom Lake Wrote:
    >>
    >> "G. R. Woodring" <tejbbqevat@rneguyvax.arg> wrote in message
    >> news:-ORuITKa2KHA.4336@TK2MSFTNGP04.phx.gbl...
    >>> Date: 4/10/2010 2:13 PM, Author: Jeff Strickland Wrote:
    >>>> Sorry, I'm running IE8, and have Notepad set as the default HTML
    >>>> editor, yet View Source does not invoke Notepad. I get a Notepad-like
    >>>> editor, but it has line numbers and different colors of text -- both of
    >>>> these are features that Notepad does not support -- so that the code
    >>>> can be more easily read.
    >>>>
    >>>>
    >>>
    >>> Look closely, You may have Notepad++ as the HTML editor. I have
    >>> Notepad++ set as the HTML editor at [Tools]>[Internet Options],
    >>> "Programs", HTML editor: and when I view source I get the source code
    >>> displayed in Notepad++. It has the line numbers and syntax coloring you
    >>> describe. If Notepad _is_ selected, right-click on notepad.exe and
    >>> check "Properties", "Version" tab. Another program may have been
    >>> renamed as "notepad.exe".

    >>
    >> In Windows 7, if nothing is specified in Tools-Internet Options-Programs
    >> (the entry
    >> is blank), you get the line-numbered, color-coded editor when View
    >> Source is invoked.
    >>
    >> Tom Lake

    >
    > The OP, kraut, offered the following:
    > "I am running Windows XP Home Edition Version 2002 service pack 3 and
    > Internet Explorer ver 7."
    >
    > Jeff Strickland stated that he was using IE8 but didn't specify the O/S,
    > but he did specify that Notepad was set as HTML editor. It may be that
    > Windows Seven uses a syntax-highlighting viewer for View Source and
    > ignores the HTML editor setting. The HTML editor setting would probably
    > be what is used for right-click, edit for .html files. I'm not quite
    > ready for Win7, and neither is my system :-(
    >



    Sorry about that, I have XP Pro, SP3 too, like the OP.

    I made a concrete statement that one couls set the HTML Editor to NotePad,
    and the result on View Source in IE8 would be that the source code would be
    displayed via NotePad. My appology is that this is an error on my part.

    I have NotePad set as the HTML editor, but View Source invokes a different
    program that is unnamed in the titlebar, and there is no Help>About to see
    what the program is.

    It is a text-based application, but it isn't NotePad because the file (HTML
    Code) is displayed (and can be edited) with line numbers and is in colors so
    the various parts of the code are set apart from each other. NotePad has no
    line numbers, and is all in one color. Whatever displays the source code is
    better than NotePad. The source code is displayed with a text editor that is
    more like CodeWrite than NotePad.
     
  17. Rob

    Rob Flightless Bird

    Re: APPOLOGIES

    G. R. Woodring <tejbbqevat@rneguyvax.arg> wrote:
    > Jeff Strickland stated that he was using IE8 but didn't specify the O/S, but he did
    > specify that Notepad was set as HTML editor. It may be that Windows Seven uses a
    > syntax-highlighting viewer for View Source and ignores the HTML editor setting. The


    Once again, the "View Source" menu option does NOT use the HTML editor.
    This does not depend on the OS.
     

Share This Page