1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

IE8 disables special keys on keyboard

Discussion in 'Internet Explorer' started by VolkerD, Jan 26, 2010.

  1. VolkerD

    VolkerD Flightless Bird

    Some time ago I noticed that all the special keys (media controls, IE, mail,
    calculator as well as Internet hot keys etc.) on the Natural Keyboard Pro are
    not working when and only when IE8 is running (foreground as well as
    background/task bar). This occurs with IntelliType Pro v5.50 as well as with
    the latest v7.1. The problem occurs in IE itself as well as any other
    program and the OS itself as long as IE is running.
    If IE is not running, the special keys are working as they should.
    This issue has occurred only a little while ago (I cannot say exactly when),
    and I supsect that some recent Microsoft update might be the culprit.
    Until a few weeks ago, this problem was not present.
    I would be grateful for help and a solution.
     
  2. Jeffrey W. Bowen

    Jeffrey W. Bowen Flightless Bird

    Hello VolkerD,

    Do you use Automatic updates, or do you visit the update site custom area to
    pick the updates you want? If you don't visit the website, then go there and
    choose "custom" and see if there is a driver update for your MS Natural
    Keyboard or see if there is a direct link you can go to for your keyboard to
    update the driver.

    Is your keyboard connected by usb, ps2 or wireless? If it is usb, or
    wireless disconnect the keyboard or wireless receiver for at least 20 or 30
    seconds and reconnect. Another thing you may want to do is shut down your
    system until the computer shuts off and disconnect or switch off its hard
    power switch (at the back of the computer box) for 20 to 30 seconds and turn
    it back on and see if that fixes your issue.

    Turning the power off on your computer may help clear out any 'old' memory
    about your keyboard that could be causing it to 'get confused' rendering
    your special keys to become useless even if only when a certain program
    runs. The 'old memory' may include IE information that may interfere with
    your special key assignments (imho).

    Does your keyboard include its own software that automatically makes these
    keyboard assignments? If so, uninstall and reinstall the software for your
    keyboard.

    If uninstalling/reinstalling software and updating drivers doesn't help,
    post back here and/or do a search for your problem on the Internet and the
    MS knowledgebase to see if you can find another solution for your problem.

    I hope this helps or someone else is able to provide a better solution.

    Good luck.

    --
    Peace,

    Jeffrey W. Bowen
    Remove NO SPAM entries from email address to send personal email.

    Please post replies of successes or failures so we all can benefit from each
    others' experiences.



    "VolkerD" <VolkerD@discussions.microsoft.com> wrote in message
    news:69BDC29F-93A7-4E28-A6E1-C7F793BD6A0A@microsoft.com...
    > Some time ago I noticed that all the special keys (media controls, IE,
    > mail,
    > calculator as well as Internet hot keys etc.) on the Natural Keyboard Pro
    > are
    > not working when and only when IE8 is running (foreground as well as
    > background/task bar). This occurs with IntelliType Pro v5.50 as well as
    > with
    > the latest v7.1. The problem occurs in IE itself as well as any other
    > program and the OS itself as long as IE is running.
    > If IE is not running, the special keys are working as they should.
    > This issue has occurred only a little while ago (I cannot say exactly
    > when),
    > and I supsect that some recent Microsoft update might be the culprit.
    > Until a few weeks ago, this problem was not present.
    > I would be grateful for help and a solution.
    >
     
  3. VolkerD

    VolkerD Flightless Bird

    Hello Jeffrey,

    thanks for your reply.

    I do not use Automatic updates but visit the update site custom area to pick
    the updates I want.
    I have tried the "old" driver (v5.50, the last one that "officially"
    supports the MS Natural Keyboard Pro) as well as the latest v7.1 that also
    supports it but does not show it as a choice of model in its scroll box any
    more.

    My keyboard is connected by USB.
    I have, of course, tried to shut down my system and restarted (several
    times, and with different driver configurations).

    The keyboard works without special drivers as a standard keyboard, but it
    includes its own software (IntelliType Pro) that automatically makes these
    keyboard assignments and supports the additional keys. I have uninstalled
    and reinstalled the software as well as tried different versions.

    As I mentioned, everything works fine as long as IE is not running, and it
    used to work fine also with IE until perhaps two weeks ago.

    So I still hope for some help.

    Best wishes
    VolkerD
     
  4. Jeffrey W. Bowen

    Jeffrey W. Bowen Flightless Bird

    Thanks for your reply VolkerD,

    I found a site that discusses how to use the MS Natural keyboard.

    According to the author of the site, Microsoft recommends that you connect
    your keyboard to both the usb and ps2 ports. Later the author states that it
    must be connected to the ps2 port for the hot keys to work. I don't know
    enough about this to say whether that is correct or not, . . . also because
    you did not have this problem before IE 8.

    You may wish to try this or check your instructions to see if that is the
    solution suggested in your manual or readme file of your keyboard although I
    am not confident that will solve your problem.

    Have you tested your keyboard with the latest Firefox version to see if it
    works with your keyboard? My guess is it will work fine with that. This is
    just a suggestion if you can't get help fixing the problem with IE. I use
    Firefox sometimes with Facebook instead of IE 8 because it seems to work a
    little smoother with some apps than IE does.

    It could be that this problem is so new that Microsoft may need to be
    directly alerted through their support technicians (this is just a newsgroup
    hosted by Microsoft) so they will know the issue exists. Once they know,
    they may be able to provide a patch.

    Anyway, I will continue to look for a solution. I'm sorry I couldn't provide
    much help for now.

    Good luck
    --
    Peace,

    Jeffrey W. Bowen
    Remove NO SPAM entries from email address to send personal email.

    Please post replies of successes or failures so we all can benefit from each
    others' experiences.


    "VolkerD" <VolkerD@discussions.microsoft.com> wrote in message
    news:FD668020-3EF8-41E6-AC48-661AA06AA8AC@microsoft.com...
    > Hello Jeffrey,
    >
    > thanks for your reply.
    >
    > I do not use Automatic updates but visit the update site custom area to
    > pick
    > the updates I want.
    > I have tried the "old" driver (v5.50, the last one that "officially"
    > supports the MS Natural Keyboard Pro) as well as the latest v7.1 that
    > also
    > supports it but does not show it as a choice of model in its scroll box
    > any
    > more.
    >
    > My keyboard is connected by USB.
    > I have, of course, tried to shut down my system and restarted (several
    > times, and with different driver configurations).
    >
    > The keyboard works without special drivers as a standard keyboard, but it
    > includes its own software (IntelliType Pro) that automatically makes these
    > keyboard assignments and supports the additional keys. I have uninstalled
    > and reinstalled the software as well as tried different versions.
    >
    > As I mentioned, everything works fine as long as IE is not running, and it
    > used to work fine also with IE until perhaps two weeks ago.
    >
    > So I still hope for some help.
    >
    > Best wishes
    > VolkerD
    >
     
  5. VolkerD

    VolkerD Flightless Bird

    Hello Jeffrey,

    thanks again for your reply.

    I was not quite precise when I described how my keyboard is connected - it
    is indeed (and has always been) connected to the PS2 (=keyboard) port and to
    the USB port. My mouse (Logitech G9) is (and has always been) connected to
    one of the USB ports on the keyboard. This configuration has never changed,
    and both the keyboard and the mouse (including the forward/back navigation
    buttons on the mouse also under IE) are working flawlessly.

    Normally I use IE (because there are several plugins that I do not want to
    miss, especially RoboForm and the Quero toolbar), bu I also use Opera, and in
    Opera all the special keys including Internet navigation are working without
    problem (as long as IE is not running in the background!).

    That is why I am reasonably sure that the problem is connected with some
    "keyboard hook" that has become integrated in IE, probably by one of the more
    recent security updates.

    I would be grateful for any other help.
    Best wishes
    VolkerD
     
  6. Jeffrey W. Bowen

    Jeffrey W. Bowen Flightless Bird

    Hello VolkerD,

    Thank you for your response and explanation why you prefer IE. I like IE
    better as well, but do use Firerfox when I suspect an issue is related to IE
    itself that may be fixed by a patch or until I can fix it myself.

    I don't know about the Quero toolbar, but I do know that Roboform has an
    adapter for Firefox that can be installed during installation or downloaded
    and installed at: http://www.roboform.com/browsers.html

    I use Roboform Pro for both IE and Firefox with all of my information and
    passwords saved on a flash drive so that none of my vital information is on
    my computer.

    I am going to take a shot in the dark though and suggest you try running IE
    without any add-ons running. Click on Start, and right click Internet
    Explorer and choose 'Browse without Add-ons'. If your keyboard works
    properly then, you know that one of your add-ons may be causing the problem.

    Another thing to try if you do not use the Roboform hot keys is to disable
    that feature in Roboform. So open Roboform and go to View - Options.

    Click on 'Keyboard', and clear the check box next to 'Enable Roboform
    Shortcuts in Browser'. It could be that Roboform uses some of the same key
    macros that your MS Natural Keyboard uses.

    I hope this helps. Good luck.

    --
    Peace,

    Jeffrey W. Bowen
    Remove NO SPAM entries from email address to send personal email.

    Please post replies of successes or failures so we all can benefit from each
    others' experiences.




    "VolkerD" <VolkerD@discussions.microsoft.com> wrote in message
    news:1CDC9CB3-9F50-4425-9D37-E63D17941350@microsoft.com...
    > Hello Jeffrey,
    >
    > thanks again for your reply.
    >
    > I was not quite precise when I described how my keyboard is connected - it
    > is indeed (and has always been) connected to the PS2 (=keyboard) port and
    > to
    > the USB port. My mouse (Logitech G9) is (and has always been) connected
    > to
    > one of the USB ports on the keyboard. This configuration has never
    > changed,
    > and both the keyboard and the mouse (including the forward/back navigation
    > buttons on the mouse also under IE) are working flawlessly.
    >
    > Normally I use IE (because there are several plugins that I do not want to
    > miss, especially RoboForm and the Quero toolbar), bu I also use Opera, and
    > in
    > Opera all the special keys including Internet navigation are working
    > without
    > problem (as long as IE is not running in the background!).
    >
    > That is why I am reasonably sure that the problem is connected with some
    > "keyboard hook" that has become integrated in IE, probably by one of the
    > more
    > recent security updates.
    >
    > I would be grateful for any other help.
    > Best wishes
    > VolkerD
    >
    >
     
  7. Robert Aldwinckle

    Robert Aldwinckle Flightless Bird

    "VolkerD" <VolkerD@discussions.microsoft.com> wrote in message news:1CDC9CB3-9F50-4425-9D37-E63D17941350@microsoft.com...
    > Hello Jeffrey,
    >
    > thanks again for your reply.
    >
    > I was not quite precise when I described how my keyboard is connected - it
    > is indeed (and has always been) connected to the PS2 (=keyboard) port and to
    > the USB port.



    Always disclose your OS when you are looking for help. ; }

    FWIW I have a Microsoft Internet keyboard (PS2) with IntelliType 7.0
    and a Microsoft Wireless keyboard with Intellitype 7.0 working on
    XPsp3, VistaSP2, and W7rc, and the same wireless keyboard working
    on a W7 Tablet with whatever default software it has in it. All OS have
    IE8 installed and all those combinations allow the function keys, e.g. Home
    and Mail button, etc to work as expected.

    So I suspect you will find that there is some other interference operating
    in your case which you will have to diagnose using clean-boot troubleshooting
    techniques.


    Good luck

    Robert Aldwinckle
    ---


    > My mouse (Logitech G9) is (and has always been) connected to
    > one of the USB ports on the keyboard. This configuration has never changed,
    > and both the keyboard and the mouse (including the forward/back navigation
    > buttons on the mouse also under IE) are working flawlessly.
    >
    > Normally I use IE (because there are several plugins that I do not want to
    > miss, especially RoboForm and the Quero toolbar), bu I also use Opera, and in
    > Opera all the special keys including Internet navigation are working without
    > problem (as long as IE is not running in the background!).
    >
    > That is why I am reasonably sure that the problem is connected with some
    > "keyboard hook" that has become integrated in IE, probably by one of the more
    > recent security updates.
    >
    > I would be grateful for any other help.
    > Best wishes
    > VolkerD
    >
    >
     
  8. Jeffrey W. Bowen

    Jeffrey W. Bowen Flightless Bird

    Hello Robert,

    VolkerD mentioned that the problem does not occur with other programs or the
    operating system itself. It only occurs when he is running IE 8.

    So in his previous posts he already established that it is *not* the OS that
    has the problem but that the problem only occurs when IE 8 is running
    regardless of what other programs he may or may not be running in the
    foreground.

    He mentioned that he uses Roboform which I know assigns its own browser hot
    keys. I have asked that he go into the Options menu of Roboform and disable
    this feature and see if the problem persists.

    I also asked him to try running the browser without add-ons and see if the
    problem disappears.

    He has not replied yet to say whether either of my suggestions helped or
    not. So I will assume either he hasn't seen my latest post or he hasn't had
    a chance to try my suggestions or reply back yet.

    If you can find any other suggestions for his problem related to conflicts
    with IE 8 and other add-ons that might interfere with his keyboard
    assignments, I am sure VolkerD would appreciate it very much, because if my
    suggestions don't work, I am out of any other suggestions but to contact
    Microsoft and let them know of the problem so they can provide a patch.

    I do agree though that it is always a good idea to state the brand of
    computer and its specs as well as the OS and other software being used
    besides the one in question. It does usually help get at solutions a little
    quicker. :)

    --
    Peace,

    Jeffrey W. Bowen
    Remove NO SPAM entries from email address to send personal email.

    Please post replies of successes or failures so we all can benefit from each
    others' experiences.


    "Robert Aldwinckle" <robald@techemail.com> wrote in message
    news:u7Rzr15nKHA.3664@TK2MSFTNGP04.phx.gbl...
    >
    > "VolkerD" <VolkerD@discussions.microsoft.com> wrote in message
    > news:1CDC9CB3-9F50-4425-9D37-E63D17941350@microsoft.com...
    >> Hello Jeffrey,
    >>
    >> thanks again for your reply.
    >>
    >> I was not quite precise when I described how my keyboard is connected -
    >> it
    >> is indeed (and has always been) connected to the PS2 (=keyboard) port and
    >> to
    >> the USB port.

    >
    >
    > Always disclose your OS when you are looking for help. ; }
    >
    > FWIW I have a Microsoft Internet keyboard (PS2) with IntelliType 7.0
    > and a Microsoft Wireless keyboard with Intellitype 7.0 working on
    > XPsp3, VistaSP2, and W7rc, and the same wireless keyboard working
    > on a W7 Tablet with whatever default software it has in it. All OS have
    > IE8 installed and all those combinations allow the function keys, e.g.
    > Home
    > and Mail button, etc to work as expected.
    >
    > So I suspect you will find that there is some other interference operating
    > in your case which you will have to diagnose using clean-boot
    > troubleshooting
    > techniques.
    >
    >
    > Good luck
    >
    > Robert Aldwinckle
    > ---
    >
    >
    >> My mouse (Logitech G9) is (and has always been) connected to
    >> one of the USB ports on the keyboard. This configuration has never
    >> changed,
    >> and both the keyboard and the mouse (including the forward/back
    >> navigation
    >> buttons on the mouse also under IE) are working flawlessly.
    >>
    >> Normally I use IE (because there are several plugins that I do not want
    >> to
    >> miss, especially RoboForm and the Quero toolbar), bu I also use Opera,
    >> and in
    >> Opera all the special keys including Internet navigation are working
    >> without
    >> problem (as long as IE is not running in the background!).
    >>
    >> That is why I am reasonably sure that the problem is connected with some
    >> "keyboard hook" that has become integrated in IE, probably by one of the
    >> more
    >> recent security updates.
    >>
    >> I would be grateful for any other help.
    >> Best wishes
    >> VolkerD
    >>
    >>

    >
    >
     
  9. VolkerD

    VolkerD Flightless Bird

    Hello Jeffrey,
    Hello Robert,

    Thank you for your kind and comprehensive replies.

    It seems I must apologize for not taking the time first to properly
    investigate the issue myself before asking for help. I should have thought
    of trying to start IE without add-ons before blaming Microsoft updates as the
    most “obvious†culprit.

    Well, that’s what I did now, I have started IE without add-ons and I was
    able to isolate the problem -- it was the FlashGet v3.3 BHO (after updating
    from the formerly rock-solid v1.96 to v3.3) which I did not think of before;
    it was the only new item except for Microsoft updates.

    Consequently I have first disabled and finally uninstalled FlashGet v3.3,
    and the problem is completely gone.

    Thanks for your support, and please again accept my apologies.
    I greatly appreciate sour support.

    Best Regards,

    VolkerD
     
  10. Jeffrey W. Bowen

    Jeffrey W. Bowen Flightless Bird

    VolkerD,

    You are very welcome. I am glad you were able to fix your problem. :)

    --
    Peace,

    Jeffrey W. Bowen
    Remove NO SPAM entries from email address to send personal email.

    Please post replies of successes or failures so we all can benefit from each
    others' experiences.

    "VolkerD" <VolkerD@discussions.microsoft.com> wrote in message
    news:83E448FF-38BD-48DE-B5EA-42F92691E4AE@microsoft.com...
    > Hello Jeffrey,
    > Hello Robert,
    >
    > Thank you for your kind and comprehensive replies.
    >
    > It seems I must apologize for not taking the time first to properly
    > investigate the issue myself before asking for help. I should have
    > thought
    > of trying to start IE without add-ons before blaming Microsoft updates as
    > the
    > most "obvious" culprit.
    >
    > Well, that's what I did now, I have started IE without add-ons and I was
    > able to isolate the problem -- it was the FlashGet v3.3 BHO (after
    > updating
    > from the formerly rock-solid v1.96 to v3.3) which I did not think of
    > before;
    > it was the only new item except for Microsoft updates.
    >
    > Consequently I have first disabled and finally uninstalled FlashGet v3.3,
    > and the problem is completely gone.
    >
    > Thanks for your support, and please again accept my apologies.
    > I greatly appreciate sour support.
    >
    > Best Regards,
    >
    > VolkerD
    >
     

Share This Page