1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Horizontal Scrollbar does not appear on some sites

Discussion in 'Internet Explorer' started by AirForce9797, Jun 12, 2010.

  1. AirForce9797

    AirForce9797 Flightless Bird

    I'm running Windows7 and if I dock IE8 to one side of my desktop there's no
    scrollbar to allow seeing all the content on the page. The vertical scrollbar
    is present. Is there a setting smoewhere that will correct this? Here's a
    sample URL:

    http://blogs.msdn.com/b/descapa/
     
  2. bwatkins0312

    bwatkins0312 Flightless Bird

    What program are you using to "dock" the IE window?

    You imply the vertical scollbar is still present so you can see up and down,
    but the horizontal scrollbar is missing so you can't see left to right?
    Increase your screen resolution.
     
  3. Robert Aldwinckle

    Robert Aldwinckle Flightless Bird

    "AirForce9797" <AirForce9797@discussions.microsoft.com> wrote in message
    news:555F1051-6901-41F6-84C5-D2D491566A47@microsoft.com...
    > I'm running Windows7 and if I dock IE8 to one side of my desktop there's
    > no
    > scrollbar to allow seeing all the content on the page. The vertical
    > scrollbar
    > is present. Is there a setting smoewhere that will correct this? Here's a
    > sample URL:
    >


    > http://blogs.msdn.com/b/descapa/


    It probably knows your screen size. E.g. pressing F11 makes horizontal
    scrollbars unnecessary for me.
     
  4. SC Tom

    SC Tom Flightless Bird

    "AirForce9797" <AirForce9797@discussions.microsoft.com> wrote in message
    news:555F1051-6901-41F6-84C5-D2D491566A47@microsoft.com...
    > I'm running Windows7 and if I dock IE8 to one side of my desktop there's
    > no
    > scrollbar to allow seeing all the content on the page. The vertical
    > scrollbar
    > is present. Is there a setting smoewhere that will correct this? Here's a
    > sample URL:
    >
    > http://blogs.msdn.com/b/descapa/
    >

    I think it's the fault of that website. I don't get the horizontal scrollbar
    on that page either, but other sites, such as Amazon, do have it when IE is
    docked to either side. Even if I just resize the IE window, there's no
    horizontal scrollbar on your link.

    To bwatkins0312: Windows 7 is the program used for docking. Use the Windows
    key+ the right arrow to dock to the right side of the screen. Screen
    resolution doesn't have anything to do with it in this case.
    --
    SC Tom
     
  5. VanguardLH

    VanguardLH Flightless Bird

    AirForce9797 wrote:

    > I'm running Windows7 and if I dock IE8 to one side of my desktop
    > there's no scrollbar to allow seeing all the content on the page. The
    > vertical scrollbar is present. Is there a setting smoewhere that
    > will correct this? Here's a sample URL:
    >
    > http:// blogs. msdn. com/ b/ descapa/


    Complain to the web page's owner. They deliberately chose NOT to allow
    scrolling.

    <iframe ... scrolling="no"></iframe>
     
  6. Jeff Strickland

    Jeff Strickland Flightless Bird

    If the Zoom Ratio allows a page to fit on the screen without the need to
    scroll to the side, the scroll bar will go away.


    "AirForce9797" <AirForce9797@discussions.microsoft.com> wrote in message
    news:555F1051-6901-41F6-84C5-D2D491566A47@microsoft.com...
    > I'm running Windows7 and if I dock IE8 to one side of my desktop there's
    > no
    > scrollbar to allow seeing all the content on the page. The vertical
    > scrollbar
    > is present. Is there a setting smoewhere that will correct this? Here's a
    > sample URL:
    >
    > http://blogs.msdn.com/b/descapa/
    >
     
  7. Jeff Strickland

    Jeff Strickland Flightless Bird

    "AirForce9797" <AirForce9797@discussions.microsoft.com> wrote in message
    news:555F1051-6901-41F6-84C5-D2D491566A47@microsoft.com...
    > I'm running Windows7 and if I dock IE8 to one side of my desktop there's
    > no
    > scrollbar to allow seeing all the content on the page. The vertical
    > scrollbar
    > is present. Is there a setting smoewhere that will correct this? Here's a
    > sample URL:
    >
    > http://blogs.msdn.com/b/descapa/
    >


    Against my better judgement, I followed the link you gave.

    The developer is an idiot, he/she left the horizontal scroll out of his/her
    code.

    If I view the page at 100% on a wide screen monitor, there is no need to
    scroll at 100% Zoom. What the developer did not accomodate is a 4:3 display
    or a Zoom Ratio that causes the right side margin to go off the screen.

    My original answer remains, if the page fits within the window, the scroll
    bar will go away -- assuming the page was written properly.

    Visit a well-regarded Website -- Yahoo, MSN, Google, etc. -- and experiment
    with setting the Zoom Level. Also switch between Normal Window and
    Maximized, and drag the sides in and out of the Normal Window.

    The fact that you notice this on some sites but not others indicates the
    sites themselves are causing the problem.
     
  8. Jeff Strickland

    Jeff Strickland Flightless Bird

    <undisclosed> wrote in message
    news:25905d4dc80188eb151576462a8217a6@nntp-gateway.com...
    >
    > Hi
    >
    > They have this code in there site
    > frameborder="0" width="400" scrolling="no"></iframe></p>*
    >
    > Thats what causing it not to work, it is not a setting you can change.
    > *
    >


    Yeah, I saw that.

    I can't imagine why a developer would use that line of code without also
    constraining the size of the window and the space that the page demands to
    display properly. But, some developers know more than they understand, I
    suppose.
     

Share This Page