1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

"Hide empty drives in my computer folder"

Discussion in 'Windows 7' started by Derek, Oct 15, 2010.

  1. Derek

    Derek Flightless Bird

    If there's no disc inserted on my D: drive, the drive doesn't appear in my
    "computer folder", even when I leave the "Hide empty drives in my computer
    folder" checkbox unchecked in the folder options menu. Is there another
    setting somewhere to reveal my empty D: drive? I'm using Win 7 ultimate 64
    bit.
     
  2. R. C. White

    R. C. White Flightless Bird

    ?Hi, Derek.

    My Drive D: is a partition on my first hard disk drive. What kind of device
    is YOUR Drive D:? CD/DVD-ROM drive? USB Flash drive? SD card from your
    camera?

    What does Disk Management (diskmgmt.msc) say about that drive?

    RC
    --
    R. C. White, CPA
    San Marcos, TX
    rc@grandecom.net
    Microsoft Windows MVP (2002-9/30/10)
    Windows Live Mail Version 2011 (Build 15.4.3502.0922) in Win7 Ultimate x64
    SP1 beta


    "Derek" wrote in message news:hrggb6doeekv9mecc5nu153afife6d9q9c@4ax.com...

    If there's no disc inserted on my D: drive, the drive doesn't appear in my
    "computer folder", even when I leave the "Hide empty drives in my computer
    folder" checkbox unchecked in the folder options menu. Is there another
    setting somewhere to reveal my empty D: drive? I'm using Win 7 ultimate 64
    bit.
     
  3. Derek

    Derek Flightless Bird

    On Fri, 15 Oct 2010 07:44:04 -0500, "R. C. White" <rc@grandecom.net> wrote:

    >?Hi, Derek.


    Wotcha!

    >My Drive D: is a partition on my first hard disk drive. What kind of device
    >is YOUR Drive D:? CD/DVD-ROM drive? USB Flash drive? SD card from your
    >camera?


    It's a CD/DVD-ROM drive.

    >What does Disk Management (diskmgmt.msc) say about that drive?


    CD-ROM 0
    DVD (D:)

    No Media

    >RC
     
  4. Ed Cryer

    Ed Cryer Flightless Bird

    On 15/10/2010 13:06, Derek wrote:
    > If there's no disc inserted on my D: drive, the drive doesn't appear in my
    > "computer folder", even when I leave the "Hide empty drives in my computer
    > folder" checkbox unchecked in the folder options menu. Is there another
    > setting somewhere to reveal my empty D: drive? I'm using Win 7 ultimate 64
    > bit.



    This might seem a bit basic, but I've seen it happen
    Right click on "Devices with removable storage" and hit "Expand group".

    Ed
     
  5. skeeter

    skeeter Flightless Bird

    Derek <usenet.email@gmail.com> wrote in
    news:96sgb69uviqetlktv196390dqqrtkbgitc@4ax.com:

    > On Fri, 15 Oct 2010 07:44:04 -0500, "R. C. White" <rc@grandecom.net>
    > wrote:
    >
    >>?Hi, Derek.

    >
    > Wotcha!
    >
    >>My Drive D: is a partition on my first hard disk drive. What kind of
    >>device is YOUR Drive D:? CD/DVD-ROM drive? USB Flash drive? SD card
    >>from your camera?

    >
    > It's a CD/DVD-ROM drive.
    >
    >>What does Disk Management (diskmgmt.msc) say about that drive?

    >
    > CD-ROM 0
    > DVD (D:)
    >
    > No Media
    >
    >>RC

    >


    it doesn't make a whole lot of sense, but click computer and it will show
    in the right pane
     
  6. Derek

    Derek Flightless Bird

    On 15 Oct 2010 15:53:18 GMT, skeeter <nospam@???.net> wrote:

    >Derek <usenet.email@gmail.com> wrote in
    >news:96sgb69uviqetlktv196390dqqrtkbgitc@4ax.com:
    >
    >> On Fri, 15 Oct 2010 07:44:04 -0500, "R. C. White" <rc@grandecom.net>
    >> wrote:
    >>
    >>>?Hi, Derek.

    >>
    >> Wotcha!
    >>
    >>>My Drive D: is a partition on my first hard disk drive. What kind of
    >>>device is YOUR Drive D:? CD/DVD-ROM drive? USB Flash drive? SD card
    >>>from your camera?

    >>
    >> It's a CD/DVD-ROM drive.
    >>
    >>>What does Disk Management (diskmgmt.msc) say about that drive?

    >>
    >> CD-ROM 0
    >> DVD (D:)
    >>
    >> No Media
    >>
    >>>RC

    >>

    >
    >it doesn't make a whole lot of sense, but click computer and it will show
    >in the right pane


    Yes, it does show up in the R/H pane, but not in the left. In the L/H pane
    under "Computer" it shows;

    Local Disk (C:)
    CD Drive (E:) WD Smartware
    My Book (F:)
     
  7. Derek

    Derek Flightless Bird

    On Fri, 15 Oct 2010 16:45:28 +0100, Ed Cryer <ed@somewhere.in.the.uk>
    wrote:

    >On 15/10/2010 13:06, Derek wrote:
    >> If there's no disc inserted on my D: drive, the drive doesn't appear in my
    >> "computer folder", even when I leave the "Hide empty drives in my computer
    >> folder" checkbox unchecked in the folder options menu. Is there another
    >> setting somewhere to reveal my empty D: drive? I'm using Win 7 ultimate 64
    >> bit.

    >
    >
    >This might seem a bit basic, but I've seen it happen
    >Right click on "Devices with removable storage" and hit "Expand group".
    >

    Yep, tried that but Drive D: still fails to show in the L/H pane.

    >Ed
     
  8. jbm

    jbm Flightless Bird

    "Derek" <usenet.email@gmail.com> wrote in message
    news:hrggb6doeekv9mecc5nu153afife6d9q9c@4ax.com...
    > If there's no disc inserted on my D: drive, the drive doesn't appear in my
    > "computer folder", even when I leave the "Hide empty drives in my computer
    > folder" checkbox unchecked in the folder options menu. Is there another
    > setting somewhere to reveal my empty D: drive? I'm using Win 7 ultimate 64
    > bit.


    Organise > Folder and search options

    View tab >

    In the "Advanced settings", under the "Hidden files and folders" item, check
    the "Show hidden files, folders or drives".

    Apply > OK

    That should do what you want. Took me ages to find it when I set this up.

    jim
     
  9. Stan Brown

    Stan Brown Flightless Bird

    On Fri, 15 Oct 2010 17:21:38 +0100, Derek wrote:
    >
    > On 15 Oct 2010 15:53:18 GMT, skeeter <nospam@???.net> wrote:
    > >it doesn't make a whole lot of sense, but click computer and it will show
    > >in the right pane

    >
    > Yes, it does show up in the R/H pane, but not in the left. In the L/H pane
    > under "Computer" it shows;
    >
    > Local Disk (C:)
    > CD Drive (E:) WD Smartware
    > My Book (F:)


    Weird! Mine empty CD/DVD drive shows up in both left and right
    panes. Maybe it's because I used diskmgmt to assign it the non-
    default drive letter Z.

    --
    Stan Brown, Oak Road Systems, Tompkins County, New York, USA
    http://OakRoadSystems.com
    Shikata ga nai...
     
  10. johnbee

    johnbee Flightless Bird

    "jbm" <not@home.ok> wrote in message
    news:i9ak41$h21$1@news.eternal-september.org...
    >
    > "Derek" <usenet.email@gmail.com> wrote in message
    > news:hrggb6doeekv9mecc5nu153afife6d9q9c@4ax.com...
    >> If there's no disc inserted on my D: drive, the drive doesn't appear in
    >> my
    >> "computer folder", even when I leave the "Hide empty drives in my
    >> computer
    >> folder" checkbox unchecked in the folder options menu. Is there another
    >> setting somewhere to reveal my empty D: drive? I'm using Win 7 ultimate
    >> 64
    >> bit.

    >
    > Organise > Folder and search options
    >
    > View tab >
    >
    > In the "Advanced settings", under the "Hidden files and folders" item,
    > check the "Show hidden files, folders or drives".
    >
    > Apply > OK
    >
    > That should do what you want. Took me ages to find it when I set this up.
    >
    > jim
    >
    >


    In the same section one of the boxes to optionally check is: 'Show empty
    drives in the computer folder'. I don't know what it means because it seems
    not to do anything, but it certainly sounds as though checking it would
    solve the OP's question.
     
  11. Derek

    Derek Flightless Bird

    On Fri, 15 Oct 2010 23:20:51 +0100, "jbm" <not@home.ok> wrote:

    >
    >"Derek" <usenet.email@gmail.com> wrote in message
    >news:hrggb6doeekv9mecc5nu153afife6d9q9c@4ax.com...
    >> If there's no disc inserted on my D: drive, the drive doesn't appear in my
    >> "computer folder", even when I leave the "Hide empty drives in my computer
    >> folder" checkbox unchecked in the folder options menu. Is there another
    >> setting somewhere to reveal my empty D: drive? I'm using Win 7 ultimate 64
    >> bit.

    >
    >Organise > Folder and search options
    >
    >View tab >
    >
    >In the "Advanced settings", under the "Hidden files and folders" item, check
    >the "Show hidden files, folders or drives".
    >
    >Apply > OK
    >
    >That should do what you want. Took me ages to find it when I set this up.
    >
    >jim


    I've toggled that checkbox on and off, and the other checkbox - 'Show empty
    drives in the computer folder', but the L/H pane still fails to show an
    empty D: drive. I've also tried uninstalling the drive, rebooting so that
    the drive is found and installed, but the problem (if indeed it is one
    because the drive is included when loaded with a disc) remains. Also, when
    inserting a USB memory stick with data, it's identified as drive D:.
     
  12. Derek

    Derek Flightless Bird

    On Sat, 16 Oct 2010 10:49:47 -0400, Stan Brown <the_stan_brown@fastmail.fm>
    wrote:

    >On Fri, 15 Oct 2010 17:21:38 +0100, Derek wrote:
    >>
    >> On 15 Oct 2010 15:53:18 GMT, skeeter <nospam@???.net> wrote:
    >> >it doesn't make a whole lot of sense, but click computer and it will show
    >> >in the right pane

    >>
    >> Yes, it does show up in the R/H pane, but not in the left. In the L/H pane
    >> under "Computer" it shows;
    >>
    >> Local Disk (C:)
    >> CD Drive (E:) WD Smartware
    >> My Book (F:)

    >
    >Weird! Mine empty CD/DVD drive shows up in both left and right
    >panes. Maybe it's because I used diskmgmt to assign it the non-
    >default drive letter Z.


    I might try that. Cheers.
     
  13. Derek

    Derek Flightless Bird

    On Sat, 16 Oct 2010 19:05:15 +0100, "johnbee" <johnbrockbank@com.invalid>
    wrote:

    >
    >"jbm" <not@home.ok> wrote in message
    >news:i9ak41$h21$1@news.eternal-september.org...
    >>
    >> "Derek" <usenet.email@gmail.com> wrote in message
    >> news:hrggb6doeekv9mecc5nu153afife6d9q9c@4ax.com...
    >>> If there's no disc inserted on my D: drive, the drive doesn't appear in
    >>> my
    >>> "computer folder", even when I leave the "Hide empty drives in my
    >>> computer
    >>> folder" checkbox unchecked in the folder options menu. Is there another
    >>> setting somewhere to reveal my empty D: drive? I'm using Win 7 ultimate
    >>> 64
    >>> bit.

    >>
    >> Organise > Folder and search options
    >>
    >> View tab >
    >>
    >> In the "Advanced settings", under the "Hidden files and folders" item,
    >> check the "Show hidden files, folders or drives".
    >>
    >> Apply > OK
    >>
    >> That should do what you want. Took me ages to find it when I set this up.
    >>
    >> jim
    >>
    >>

    >
    >In the same section one of the boxes to optionally check is: 'Show empty
    >drives in the computer folder'. I don't know what it means because it seems
    >not to do anything,


    You're right: it doesn't.

    >but it certainly sounds as though checking it would
    >solve the OP's question.


    That's what I was hoping. The problem doesn't present me with any
    difficulties. I can still write to and read from D: when I insert a disk. I
    might just have to live with it until my next clean-install.
     
  14. johnbee

    johnbee Flightless Bird

    "Derek" <usenet.email@gmail.com> wrote in message
    news:jotjb6pl18khe26avnrcrcduv5b147nmbs@4ax.com...
    > On Sat, 16 Oct 2010 19:05:15 +0100, "johnbee" <johnbrockbank@com.invalid>
    > wrote:
    >
    >>
    >>"jbm" <not@home.ok> wrote in message
    >>news:i9ak41$h21$1@news.eternal-september.org...
    >>>
    >>> "Derek" <usenet.email@gmail.com> wrote in message
    >>> news:hrggb6doeekv9mecc5nu153afife6d9q9c@4ax.com...
    >>>> If there's no disc inserted on my D: drive, the drive doesn't appear in
    >>>> my
    >>>> "computer folder", even when I leave the "Hide empty drives in my
    >>>> computer
    >>>> folder" checkbox unchecked in the folder options menu. Is there another
    >>>> setting somewhere to reveal my empty D: drive? I'm using Win 7 ultimate
    >>>> 64
    >>>> bit.
    >>>
    >>> Organise > Folder and search options
    >>>
    >>> View tab >
    >>>
    >>> In the "Advanced settings", under the "Hidden files and folders" item,
    >>> check the "Show hidden files, folders or drives".
    >>>
    >>> Apply > OK
    >>>
    >>> That should do what you want. Took me ages to find it when I set this
    >>> up.
    >>>
    >>> jim
    >>>
    >>>

    >>
    >>In the same section one of the boxes to optionally check is: 'Show empty
    >>drives in the computer folder'. I don't know what it means because it
    >>seems
    >>not to do anything,

    >
    > You're right: it doesn't.
    >
    >>but it certainly sounds as though checking it would
    >>solve the OP's question.

    >
    > That's what I was hoping. The problem doesn't present me with any
    > difficulties. I can still write to and read from D: when I insert a disk.
    > I
    > might just have to live with it until my next clean-install.


    I am not sure whether this has been said, but I will in case it hasn't.

    The bad news is that there is a Registry entry, in 'Current user', explorer,
    advanced, named hidedriveswithnomedia. Mine is set to be zero. I suspect
    yours is set to 1. Start regedit and have a look - you won't do any harm if
    you just look.

    I reckon whoever installed the drive set that value. Look on the bright
    side - at least you don't have to open it to see if the drive has an empty
    disk inside.

    Anyway, you can change it with Regedit if you don't mind having a go.

    Alternatively of course you can google the term and find a utility to do it
    for you.
     
  15. Derek

    Derek Flightless Bird

    On Sun, 17 Oct 2010 20:11:12 +0100, "johnbee" <johnbrockbank@com.invalid>
    wrote:

    >
    >"Derek" <usenet.email@gmail.com> wrote in message
    >news:jotjb6pl18khe26avnrcrcduv5b147nmbs@4ax.com...
    >> On Sat, 16 Oct 2010 19:05:15 +0100, "johnbee" <johnbrockbank@com.invalid>
    >> wrote:
    >>
    >>>
    >>>"jbm" <not@home.ok> wrote in message
    >>>news:i9ak41$h21$1@news.eternal-september.org...
    >>>>
    >>>> "Derek" <usenet.email@gmail.com> wrote in message
    >>>> news:hrggb6doeekv9mecc5nu153afife6d9q9c@4ax.com...
    >>>>> If there's no disc inserted on my D: drive, the drive doesn't appear in
    >>>>> my
    >>>>> "computer folder", even when I leave the "Hide empty drives in my
    >>>>> computer
    >>>>> folder" checkbox unchecked in the folder options menu. Is there another
    >>>>> setting somewhere to reveal my empty D: drive? I'm using Win 7 ultimate
    >>>>> 64
    >>>>> bit.
    >>>>
    >>>> Organise > Folder and search options
    >>>>
    >>>> View tab >
    >>>>
    >>>> In the "Advanced settings", under the "Hidden files and folders" item,
    >>>> check the "Show hidden files, folders or drives".
    >>>>
    >>>> Apply > OK
    >>>>
    >>>> That should do what you want. Took me ages to find it when I set this
    >>>> up.
    >>>>
    >>>> jim
    >>>>
    >>>>
    >>>
    >>>In the same section one of the boxes to optionally check is: 'Show empty
    >>>drives in the computer folder'. I don't know what it means because it
    >>>seems
    >>>not to do anything,

    >>
    >> You're right: it doesn't.
    >>
    >>>but it certainly sounds as though checking it would
    >>>solve the OP's question.

    >>
    >> That's what I was hoping. The problem doesn't present me with any
    >> difficulties. I can still write to and read from D: when I insert a disk.
    >> I
    >> might just have to live with it until my next clean-install.

    >
    >I am not sure whether this has been said, but I will in case it hasn't.
    >
    >The bad news is that there is a Registry entry, in 'Current user', explorer,
    >advanced, named hidedriveswithnomedia.


    I found the entry by navigating to
    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced,
    and it was set to 0, like yours.

    >Mine is set to be zero. I suspect
    >yours is set to 1. Start regedit and have a look - you won't do any harm if
    >you just look.
    >
    >I reckon whoever installed the drive set that value. Look on the bright
    >side - at least you don't have to open it to see if the drive has an empty
    >disk inside.
    >
    >Anyway, you can change it with Regedit if you don't mind having a go.
    >
    >Alternatively of course you can google the term and find a utility to do it
    >for you.


    Cheers, John. Looks like I might have to live with it.
     
  16. johnbee

    johnbee Flightless Bird

    "Derek" <usenet.email@gmail.com> wrote in message
    news:5gqmb6tgvlb0nhhdelo2hh93g3c2ifv59g@4ax.com...
    > On Sun, 17 Oct 2010 20:11:12 +0100, "johnbee" <johnbrockbank@com.invalid>
    > wrote:
    >
    >>
    >>"Derek" <usenet.email@gmail.com> wrote in message
    >>news:jotjb6pl18khe26avnrcrcduv5b147nmbs@4ax.com...
    >>> On Sat, 16 Oct 2010 19:05:15 +0100, "johnbee"
    >>> <johnbrockbank@com.invalid>
    >>> wrote:
    >>>
    >>>>
    >>>>"jbm" <not@home.ok> wrote in message
    >>>>news:i9ak41$h21$1@news.eternal-september.org...
    >>>>>
    >>>>> "Derek" <usenet.email@gmail.com> wrote in message
    >>>>> news:hrggb6doeekv9mecc5nu153afife6d9q9c@4ax.com...
    >>>>>> If there's no disc inserted on my D: drive, the drive doesn't appear
    >>>>>> in
    >>>>>> my
    >>>>>> "computer folder", even when I leave the "Hide empty drives in my
    >>>>>> computer
    >>>>>> folder" checkbox unchecked in the folder options menu. Is there
    >>>>>> another
    >>>>>> setting somewhere to reveal my empty D: drive? I'm using Win 7
    >>>>>> ultimate
    >>>>>> 64
    >>>>>> bit.
    >>>>>
    >>>>> Organise > Folder and search options
    >>>>>
    >>>>> View tab >
    >>>>>
    >>>>> In the "Advanced settings", under the "Hidden files and folders" item,
    >>>>> check the "Show hidden files, folders or drives".
    >>>>>
    >>>>> Apply > OK
    >>>>>
    >>>>> That should do what you want. Took me ages to find it when I set this
    >>>>> up.
    >>>>>
    >>>>> jim
    >>>>>
    >>>>>
    >>>>
    >>>>In the same section one of the boxes to optionally check is: 'Show
    >>>>empty
    >>>>drives in the computer folder'. I don't know what it means because it
    >>>>seems
    >>>>not to do anything,
    >>>
    >>> You're right: it doesn't.
    >>>
    >>>>but it certainly sounds as though checking it would
    >>>>solve the OP's question.
    >>>
    >>> That's what I was hoping. The problem doesn't present me with any
    >>> difficulties. I can still write to and read from D: when I insert a
    >>> disk.
    >>> I
    >>> might just have to live with it until my next clean-install.

    >>
    >>I am not sure whether this has been said, but I will in case it hasn't.
    >>
    >>The bad news is that there is a Registry entry, in 'Current user',
    >>explorer,
    >>advanced, named hidedriveswithnomedia.

    >
    > I found the entry by navigating to
    > HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced,
    > and it was set to 0, like yours.
    >
    >>Mine is set to be zero. I suspect
    >>yours is set to 1. Start regedit and have a look - you won't do any harm
    >>if
    >>you just look.
    >>
    >>I reckon whoever installed the drive set that value. Look on the bright
    >>side - at least you don't have to open it to see if the drive has an empty
    >>disk inside.
    >>
    >>Anyway, you can change it with Regedit if you don't mind having a go.
    >>
    >>Alternatively of course you can google the term and find a utility to do
    >>it
    >>for you.

    >
    > Cheers, John. Looks like I might have to live with it.


    I reckon that you have unearthed a bug. That registry entry presumably is
    supposed to be altered by the 'folder options' interface, and surely must be
    the thing that is supposed to control the behaviour. My guess is that
    altering the interface check box does nothing (or even changes the wrong
    thing) and that behaviour is actually controlled by something else entirely.
    Probably both done by the same programmer on a day when the next Grand Theft
    Auto was released.
     

Share This Page