1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

"files based on content, not file extension" option issue

Discussion in 'Internet Explorer' started by yyy, May 21, 2010.

  1. yyy

    yyy Flightless Bird

    Hi,
    I met a strange question. When I disable "files based on content, not file
    extension" option in IE browser (IE -->Tools Options-->Security-->Internet
    zone-->Custom level --> "files based on content, not file extension"
    disable).

    When I used IE to access ftp://ftp.microsoft.com via. proxy, such as:
    ccproxy..etc.

    IE browser shows HTML source code instead of normal html webpage.

    Could you take a look?
     
  2. PA Bear [MS MVP]

    PA Bear [MS MVP] Flightless Bird

    Always state your full Windows version (e.g., WinXP SP3; WinXP 64-bit SP2;
    Vista SP1; Vista 64-bit SP2; Win7; Win7 64-bit) as well as your IE version
    when posting in an IE-specific forum or newsgroup. Please do so in your next
    reply.

    What anti-virus application or security suite is installed and is your
    subscription current? What anti-spyware applications (other than Defender)?
    What third-party firewall (if any)?

    Has a(nother) Norton or McAfee application ever been installed on this
    machine (e.g., a free-trial version that came preinstalled when you bought
    it)?
    --
    ~PA Bear


    yyy wrote:
    > I met a strange question. When I disable "files based on content, not
    > file
    > extension" option in IE browser (IE -->Tools Options-->Security-->Internet
    > zone-->Custom level --> "files based on content, not file extension"
    > disable).
    >
    > When I used IE to access ftp://ftp.microsoft.com via. proxy, such as:
    > ccproxy..etc.
    >
    > IE browser shows HTML source code instead of normal html webpage.
    >
    > Could you take a look?
     
  3. Jeff Strickland

    Jeff Strickland Flightless Bird

    "yyy" <yyy@discussions.microsoft.com> wrote in message
    news:EB569BFA-97E6-470A-839F-71CDD01EF2B1@microsoft.com...
    > Hi,
    > I met a strange question. When I disable "files based on content, not
    > file
    > extension" option in IE browser (IE -->Tools Options-->Security-->Internet
    > zone-->Custom level --> "files based on content, not file extension"
    > disable).
    >
    > When I used IE to access ftp://ftp.microsoft.com via. proxy, such as:
    > ccproxy..etc.
    >
    > IE browser shows HTML source code instead of normal html webpage.
    >
    > Could you take a look?
    >
    >



    The CONTENT of an HTML file is text -- or source code. The PRESENTATION of
    an HTML file, based on the extension, is a Webpage.

    You got what you asked for.
     
  4. Dan

    Dan Flightless Bird

    "yyy" <yyy@discussions.microsoft.com> wrote in message
    news:EB569BFA-97E6-470A-839F-71CDD01EF2B1@microsoft.com...
    > Hi,
    > I met a strange question. When I disable "files based on content, not
    > file
    > extension" option in IE browser (IE -->Tools Options-->Security-->Internet
    > zone-->Custom level --> "files based on content, not file extension"
    > disable).
    >
    > When I used IE to access ftp://ftp.microsoft.com via. proxy, such as:
    > ccproxy..etc.
    >
    > IE browser shows HTML source code instead of normal html webpage.
    >
    > Could you take a look?
    >
    >


    As Jeff has already replied, you got exactly what you asked for. There is no
    "content-type" header when using FTP because it is a protocol for
    transferring files. If viewed over HTTP then the HTTP server adds the
    appropriate "content-type" header to tell the browser what the file contains
    so it will render it as HTML rather than treat is as plain text.

    Why did you change this setting?

    --
    Dan
     

Share This Page