1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

File/Send/Link by Email greyed out

Discussion in 'Internet Explorer' started by Niall, Apr 7, 2010.

  1. Niall

    Niall Flightless Bird

    I have Win 7 (upgraded from Vista) and IE 8.
    On any web page when I click File/Send the options "Link by E-mail" and
    "Page by E-mail" are greyed out. It worked in Vista. Is there any way I can
    enable those commands again?
    Thanks
     
  2. Robert Aldwinckle

    Robert Aldwinckle Flightless Bird

    "Niall" <nospam@here.com> wrote in message
    news:55AF1874-D5C3-4D24-B38B-03D035D97943@microsoft.com...
    > I have Win 7 (upgraded from Vista) and IE 8.
    > On any web page when I click File/Send the options "Link by E-mail" and
    > "Page by E-mail" are greyed out. It worked in Vista. Is there any way I
    > can
    > enable those commands again?
    > Thanks



    Re-register your mail client for all its protocols.
     
  3. Niall

    Niall Flightless Bird

    What on earth does that mean?

    "Robert Aldwinckle" <robald@techemail.com> wrote in message
    news:#9GswSp1KHA.3828@TK2MSFTNGP04.phx.gbl...
    >
    > "Niall" <nospam@here.com> wrote in message
    > news:55AF1874-D5C3-4D24-B38B-03D035D97943@microsoft.com...
    >> I have Win 7 (upgraded from Vista) and IE 8.
    >> On any web page when I click File/Send the options "Link by E-mail" and
    >> "Page by E-mail" are greyed out. It worked in Vista. Is there any way I
    >> can
    >> enable those commands again?
    >> Thanks

    >
    >
    > Re-register your mail client for all its protocols.
     
  4. Jeff Strickland

    Jeff Strickland Flightless Bird

    One, you should post at the bottom, not the top. Having said that, you
    should follow the posting scheme of those that you are following. I'm
    following a top post, so I reply in kind. You posted on top, and that was an
    error because the person you follow posted at the bottom.

    Two, your Default E-mail client in IE is not valid, so you cannot Send Link
    By E-mail. You need to click Tools>Internet Options>Programs, and set your
    e-mail client as the default.



    "Niall" <nospam@here.com> wrote in message
    news:2302C6B6-3B8D-4D2E-8A63-33DE270AA3D4@microsoft.com...
    > What on earth does that mean?
    >
    > "Robert Aldwinckle" <robald@techemail.com> wrote in message
    > news:#9GswSp1KHA.3828@TK2MSFTNGP04.phx.gbl...
    >>
    >> "Niall" <nospam@here.com> wrote in message
    >> news:55AF1874-D5C3-4D24-B38B-03D035D97943@microsoft.com...
    >>> I have Win 7 (upgraded from Vista) and IE 8.
    >>> On any web page when I click File/Send the options "Link by E-mail" and
    >>> "Page by E-mail" are greyed out. It worked in Vista. Is there any way I
    >>> can
    >>> enable those commands again?
    >>> Thanks

    >>
    >>
    >> Re-register your mail client for all its protocols.

    >
     
  5. Robert Aldwinckle

    Robert Aldwinckle Flightless Bird

    "Niall" <nospam@here.com> wrote in message
    news:2302C6B6-3B8D-4D2E-8A63-33DE270AA3D4@microsoft.com...

    >> Re-register your mail client for all its protocols.



    > What on earth does that mean?



    You're in W7. You use its Defaults Programs tool to register a
    program's defaults. You haven't told us what your mail client is, probably
    WLMail. So, pick it and set *all* its defaults.


    ---
     
  6. PA Bear [MS MVP]

    PA Bear [MS MVP] Flightless Bird

    Unlike Vista & WinXP, Win7 doesn't include a default Mail Client. [What were
    they thinking?]

    You will have to install one (e.g., MS Outlook; Windows Live Mail;
    Thunderbird) and then set it as your default for Mail in the CUSTOM
    (<=important!) section of Set Program Access and Computer Defaults before
    any Send To or MailTo functions will become available.

    You'll find support for Win7 Mail Clients in this forum:
    http://social.answers.microsoft.com/Forums/en-US/w7network/threads

    You will find support for Windows Live Mail in this public newsgroup:
    http://www.microsoft.com/communitie...dg=microsoft.public.windows.live.mail.desktop

    . Via your newsreader (i.e., Windows Live Mail):
    news://msnews.microsoft.com/microsoft.public.windows.live.mail.desktop

    And in Windows Live Mail Support Forums (new 08 March 2010)
    http://windowslivehelp.com/forums.aspx?productid=15
    --
    ~Robear Dyer (PA Bear)
    MS MVP-IE, Mail, Security, Windows Client - since 2002

    Niall wrote:
    > I have Win 7 (upgraded from Vista) and IE 8.
    > On any web page when I click File/Send the options "Link by E-mail" and
    > "Page by E-mail" are greyed out. It worked in Vista. Is there any way I
    > can
    > enable those commands again?
    > Thanks
     
  7. Niall

    Niall Flightless Bird

    "PA Bear [MS MVP]" <PABearMVP@gmail.com> wrote in message
    news:eElhKCu1KHA.1420@TK2MSFTNGP02.phx.gbl...
    > Unlike Vista & WinXP, Win7 doesn't include a default Mail Client. [What
    > were they thinking?]
    >
    > You will have to install one (e.g., MS Outlook; Windows Live Mail;
    > Thunderbird) and then set it as your default for Mail in the CUSTOM
    > (<=important!) section of Set Program Access and Computer Defaults before
    > any Send To or MailTo functions will become available.
    >
    > You'll find support for Win7 Mail Clients in this forum:
    > http://social.answers.microsoft.com/Forums/en-US/w7network/threads
    >
    > You will find support for Windows Live Mail in this public newsgroup:
    > http://www.microsoft.com/communitie...dg=microsoft.public.windows.live.mail.desktop
    >
    > . Via your newsreader (i.e., Windows Live Mail):
    > news://msnews.microsoft.com/microsoft.public.windows.live.mail.desktop
    >
    > And in Windows Live Mail Support Forums (new 08 March 2010)
    > http://windowslivehelp.com/forums.aspx?productid=15
    > --
    > ~Robear Dyer (PA Bear)
    > MS MVP-IE, Mail, Security, Windows Client - since 2002
    >
    > Niall wrote:
    >> I have Win 7 (upgraded from Vista) and IE 8.
    >> On any web page when I click File/Send the options "Link by E-mail" and
    >> "Page by E-mail" are greyed out. It worked in Vista. Is there any way I
    >> can
    >> enable those commands again?
    >> Thanks


    Got it, guys. Thanks a lot. I use WLM and I never set it as default before.
    I can't find a newsgroup for another problem I have so I'll post it here and
    ask if anyone can send me to the right place. (It does not involve IE.)
    When I right click a file or folder and select "Sent to" I don't get the
    "Desktop (Create shortcut)" option. It is not there at all. How can I get
    that option back?
    Sorry for not observing the right etiquette of posting my message at the
    bottom.
    Niall
    >
     
  8. Jeff Strickland

    Jeff Strickland Flightless Bird

    "Niall" <nospam@here.com> wrote in message
    news:3284164F-4B70-4168-BD8E-BCE8F831B381@microsoft.com...
    >
    >
    > "PA Bear [MS MVP]" <PABearMVP@gmail.com> wrote in message
    > news:eElhKCu1KHA.1420@TK2MSFTNGP02.phx.gbl...
    >> Unlike Vista & WinXP, Win7 doesn't include a default Mail Client. [What
    >> were they thinking?]
    >>
    >> You will have to install one (e.g., MS Outlook; Windows Live Mail;
    >> Thunderbird) and then set it as your default for Mail in the CUSTOM
    >> (<=important!) section of Set Program Access and Computer Defaults before
    >> any Send To or MailTo functions will become available.
    >>
    >> You'll find support for Win7 Mail Clients in this forum:
    >> http://social.answers.microsoft.com/Forums/en-US/w7network/threads
    >>
    >> You will find support for Windows Live Mail in this public newsgroup:
    >> http://www.microsoft.com/communitie...dg=microsoft.public.windows.live.mail.desktop
    >>
    >> . Via your newsreader (i.e., Windows Live Mail):
    >>
    >> news://msnews.microsoft.com/microsoft.public.windows.live.mail.desktop
    >>
    >> And in Windows Live Mail Support Forums (new 08 March 2010)
    >> http://windowslivehelp.com/forums.aspx?productid=15
    >> --
    >> ~Robear Dyer (PA Bear)
    >> MS MVP-IE, Mail, Security, Windows Client - since 2002
    >>
    >> Niall wrote:
    >>> I have Win 7 (upgraded from Vista) and IE 8.
    >>> On any web page when I click File/Send the options "Link by E-mail" and
    >>> "Page by E-mail" are greyed out. It worked in Vista. Is there any way I
    >>> can
    >>> enable those commands again?
    >>> Thanks

    >
    > Got it, guys. Thanks a lot. I use WLM and I never set it as default
    > before.
    > I can't find a newsgroup for another problem I have so I'll post it here
    > and ask if anyone can send me to the right place. (It does not involve
    > IE.)
    > When I right click a file or folder and select "Sent to" I don't get the
    > "Desktop (Create shortcut)" option. It is not there at all. How can I get
    > that option back?
    > Sorry for not observing the right etiquette of posting my message at the
    > bottom.
    > Niall
    >>



    In XP Pro, one Right Clicks and selects Create Shortcut, NOT Send To. You
    don't want to Send To a shortcut, you want to Create a shortcut. You can
    press and hold the CTRL Key and drag the file to the new location, and a
    shortcut will be created automatically.

    Open Windows Explorer in a Normal Window, and drag the desired file(s) to
    the Desktop while holding the CTRL Key.

    Turns out, my advise is not entirely correct. You can hold the CTRL Key
    while you drag files and folders, but this makes copies of the files and
    folders, not shortcuts to them. The distinction is that the copy can be
    changed while leaving the original intact; when the shortcut is created, the
    original file is changed when the shortcut is opened. But you can right
    click the file or folder in Windows Explorer and select Create Shortcut,
    then drag the result to the Desktop.
     
  9. PA Bear [MS MVP]

    PA Bear [MS MVP] Flightless Bird

    Niall wrote:
    >>> I have Win 7 (upgraded from Vista) and IE 8.
    >>> On any web page when I click File/Send the options "Link by E-mail" and
    >>> "Page by E-mail" are greyed out. It worked in Vista. Is there any way I
    >>> can
    >>> enable those commands again?

    >>
    >> Unlike Vista & WinXP, Win7 doesn't include a default Mail Client. [What
    >> were they thinking?]
    >>
    >> You will have to install one (e.g., MS Outlook; Windows Live Mail;
    >> Thunderbird) and then set it as your default for Mail in the CUSTOM
    >> (<=important!) section of Set Program Access and Computer Defaults before
    >> any Send To or MailTo functions will become available.
    >>
    >> You'll find support for Win7 Mail Clients in this forum:
    >> http://social.answers.microsoft.com/Forums/en-US/w7network/threads
    >>
    >> You will find support for Windows Live Mail in this public newsgroup:
    >> http://www.microsoft.com/communitie...dg=microsoft.public.windows.live.mail.desktop
    >>
    >> . Via your newsreader (i.e., Windows Live Mail):
    >>
    >> news://msnews.microsoft.com/microsoft.public.windows.live.mail.desktop
    >>
    >> And in Windows Live Mail Support Forums (new 08 March 2010)
    >> http://windowslivehelp.com/forums.aspx?productid=15

    >
    > Got it, guys. Thanks a lot. I use WLM and I never set it as default
    > before.
    > I can't find a newsgroup for another problem I have so I'll post it here
    > and
    > ask if anyone can send me to the right place. (It does not involve IE.)
    > When I right click a file or folder and select "Sent to" I don't get the
    > "Desktop (Create shortcut)" option. It is not there at all. How can I get
    > that option back?
    > Sorry for not observing the right etiquette of posting my message at the
    > bottom.


    [Adjustments have been made.]

    Post about your other problem here:
    http://social.answers.microsoft.com/Forums/en-US/w7performance/threads

    Windows 7-specific Support Forums (no newsgroups)
    http://social.answers.microsoft.com/Forums/en-US/category/windows7
     
  10. Niall

    Niall Flightless Bird

    "Jeff Strickland" <crwlrjeff@yahoo.com> wrote in message
    news:hpkuid$vfs$1@news.eternal-september.org...
    >
    > "Niall" <nospam@here.com> wrote in message
    > news:3284164F-4B70-4168-BD8E-BCE8F831B381@microsoft.com...
    >>
    >>
    >> "PA Bear [MS MVP]" <PABearMVP@gmail.com> wrote in message
    >> news:eElhKCu1KHA.1420@TK2MSFTNGP02.phx.gbl...
    >>> Unlike Vista & WinXP, Win7 doesn't include a default Mail Client. [What
    >>> were they thinking?]
    >>>
    >>> You will have to install one (e.g., MS Outlook; Windows Live Mail;
    >>> Thunderbird) and then set it as your default for Mail in the CUSTOM
    >>> (<=important!) section of Set Program Access and Computer Defaults
    >>> before any Send To or MailTo functions will become available.
    >>>
    >>> You'll find support for Win7 Mail Clients in this forum:
    >>> http://social.answers.microsoft.com/Forums/en-US/w7network/threads
    >>>
    >>> You will find support for Windows Live Mail in this public newsgroup:
    >>> http://www.microsoft.com/communitie...dg=microsoft.public.windows.live.mail.desktop
    >>>
    >>> . Via your newsreader (i.e., Windows Live Mail):
    >>>
    >>> news://msnews.microsoft.com/microsoft.public.windows.live.mail.desktop
    >>>
    >>> And in Windows Live Mail Support Forums (new 08 March 2010)
    >>> http://windowslivehelp.com/forums.aspx?productid=15
    >>> --
    >>> ~Robear Dyer (PA Bear)
    >>> MS MVP-IE, Mail, Security, Windows Client - since 2002
    >>>
    >>> Niall wrote:
    >>>> I have Win 7 (upgraded from Vista) and IE 8.
    >>>> On any web page when I click File/Send the options "Link by E-mail" and
    >>>> "Page by E-mail" are greyed out. It worked in Vista. Is there any way I
    >>>> can
    >>>> enable those commands again?
    >>>> Thanks

    >>
    >> Got it, guys. Thanks a lot. I use WLM and I never set it as default
    >> before.
    >> I can't find a newsgroup for another problem I have so I'll post it here
    >> and ask if anyone can send me to the right place. (It does not involve
    >> IE.)
    >> When I right click a file or folder and select "Sent to" I don't get the
    >> "Desktop (Create shortcut)" option. It is not there at all. How can I get
    >> that option back?
    >> Sorry for not observing the right etiquette of posting my message at the
    >> bottom.
    >> Niall
    >>>

    >
    >
    > In XP Pro, one Right Clicks and selects Create Shortcut, NOT Send To. You
    > don't want to Send To a shortcut, you want to Create a shortcut. You can
    > press and hold the CTRL Key and drag the file to the new location, and a
    > shortcut will be created automatically.
    >
    > Open Windows Explorer in a Normal Window, and drag the desired file(s) to
    > the Desktop while holding the CTRL Key.
    >
    > Turns out, my advise is not entirely correct. You can hold the CTRL Key
    > while you drag files and folders, but this makes copies of the files and
    > folders, not shortcuts to them. The distinction is that the copy can be
    > changed while leaving the original intact; when the shortcut is created,
    > the original file is changed when the shortcut is opened. But you can
    > right click the file or folder in Windows Explorer and select Create
    > Shortcut, then drag the result to the Desktop.


    Hi Jeff,
    Thanks for your input. I am pretty sure I could always right click a file,
    select "Send to" and see the option "Desktop (Create shortcut)". I've had
    Win 95, 98, XP and Vista and now 7. You just click that option and the
    shortcut is created on the desktop without any further work. I know your way
    works - I could still create a shortcut on the desktop and I usually "right
    dragged" the file to the desktop and clicked "create shortcut here". But it
    was a hassle to reduce the window to normal and drag the file like that when
    I knew I could do it a simpler way.
    Anyway I learned how to get it back. I clicked the Start button, typed
    "shell:sendto" and there I created the file "Desktop (Create
    shortcut).desklink".
    Thanks everybody for your help.
    Niall
     

Share This Page