1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Facebook, IE8, Windows 7 and Addons

Discussion in 'Internet Explorer' started by Frosty, Mar 1, 2010.

  1. Frosty

    Frosty Flightless Bird

    I updated to Windows 7 about a week ago. For the first few days, Facebook
    site was working fine. Now I cannot login ... it throws an error telling me
    that I don't have cookies enabled in my browser (even though I do).

    What I have tried:
    -- running "IE8 with addons disabled" (this works)
    -- configuring IE8 so that all known addons are disabled (this doesn't work)
    -- using https://www.facebook.com instead of http://www.facebook.com (this
    works)
    -- uninstalling and reinstalling Java, Flash, Shockware, etc (none of this
    made any difference)
    -- full virus/malware scans with both AVG (licensed version) and
    Malwarebytes (didn't find anything)
    -- clearing caches, temp files, etc (made no difference)

    I don't understand why disabling all the addons in IE8 is not the same as
    running IE8 with the switch that tells it not to load any addons ... however
    there obviously is a difference in this case.

    The only conclusion I can reach at this point is that there is some other
    piece of software intefering with IE8, but only when its using HTTP and not
    HTTPS. Any suggestions as to where to look next?

    I saw someone in another thread had an issue with a "DivX Web Player" and
    when I get home I will have a look for applications similar to that and will
    try uninstalling them if I find any.
     
  2. Frosty

    Frosty Flightless Bird

    Oh, I should also mention I have tried resetting IE8 to defaults multiple
    times with multiple reboots, but this makes no difference to the behaviour on
    Facebook.

    Is there an application I could run (e.g. SysInternals Process Explorer)
    that would tell me what's running along with IE8 which is different when I
    run it in no-addons mode?
     
  3. rob^_^

    rob^_^ Flightless Bird

    Hi Frosty,

    There is a known fault with the facebook sites when you don't have Active
    Scripting enabled.

    Tools>Internet Options - Security tab, click "Reset all zones to default"

    Check that you do not have Facebook in your Restricted Sites Zone. If using
    a work computer your System Admin may have placed it there and it will not
    be visible to you. Contact your network administrators.

    Check your Addons that enable/disable javascripts. IE7Pro? and enable
    javascript.

    I am reluctant to recommend that you place facebook in your Trusted Sites
    security zone as there are many sites now that use the facebook API's
    (americangreetings for one) and navigating between sites from different
    security zones may give you unexpected results.

    Your Cookies slider should be set to the default of "Medium".

    If you have InPrivate Filtering turned on (aka. ad blocker) choose the
    option to select content to block/allow and make sure that you are not
    blocking any content from Facebook. (.js files).

    Regards.

    "Frosty" <stephen.frost.removethisbit@frostbyte.com.au> wrote in message
    news:43BF5B5A-A8AE-48FB-AB15-3B27F629C434@microsoft.com...
    > I updated to Windows 7 about a week ago. For the first few days, Facebook
    > site was working fine. Now I cannot login ... it throws an error telling
    > me
    > that I don't have cookies enabled in my browser (even though I do).
    >
    > What I have tried:
    > -- running "IE8 with addons disabled" (this works)
    > -- configuring IE8 so that all known addons are disabled (this doesn't
    > work)
    > -- using https://www.facebook.com instead of http://www.facebook.com (this
    > works)
    > -- uninstalling and reinstalling Java, Flash, Shockware, etc (none of this
    > made any difference)
    > -- full virus/malware scans with both AVG (licensed version) and
    > Malwarebytes (didn't find anything)
    > -- clearing caches, temp files, etc (made no difference)
    >
    > I don't understand why disabling all the addons in IE8 is not the same as
    > running IE8 with the switch that tells it not to load any addons ...
    > however
    > there obviously is a difference in this case.
    >
    > The only conclusion I can reach at this point is that there is some other
    > piece of software intefering with IE8, but only when its using HTTP and
    > not
    > HTTPS. Any suggestions as to where to look next?
    >
    > I saw someone in another thread had an issue with a "DivX Web Player" and
    > when I get home I will have a look for applications similar to that and
    > will
    > try uninstalling them if I find any.
    >
     
  4. Frosty

    Frosty Flightless Bird

    Hi Rob,

    THANK YOU!!!

    I thought I had checked everything, but I clearly hadn't. Something in your
    previous post mentioned Trusted Sites and caused me to check:

    In IE8, Tools, Internet Options, Security, Trusted Sites, Sites

    In there I found: www.facebook.com ... and the checkbox for "Require server
    verification (https)" was CHECKED.

    I removed the facebook URL from the list and of course now everything is
    working just fine. I don't know whether my kids were fiddling with the
    settings, or whether Windows 7 reset this checkbox itself ... but anyway,
    PROBLEM SOLVED.

    Thanks again,

    Steve
     
  5. rob^_^

    rob^_^ Flightless Bird

    Hi,

    Thanks for the feedback..... it was not the response I was expecting. Rather
    I thought you may have tried to fix things by fiddling with IE's security
    zone settings and had turned off Active Scripting in the Internet zone, or
    one of your Addons was disabling scripting... now we know another reason why
    some users may not be able to logon to facebook + we know the symptoms -
    facebook complains that cookies need to be enabled when IE says they are.

    Thanks again, and YW.

    Regards.

    "Frosty" <Frosty@discussions.microsoft.com> wrote in message
    news:F3D32498-AE1B-4CA6-8761-82576492CB95@microsoft.com...
    > Hi Rob,
    >
    > THANK YOU!!!
    >
    > I thought I had checked everything, but I clearly hadn't. Something in
    > your
    > previous post mentioned Trusted Sites and caused me to check:
    >
    > In IE8, Tools, Internet Options, Security, Trusted Sites, Sites
    >
    > In there I found: www.facebook.com ... and the checkbox for "Require
    > server
    > verification (https)" was CHECKED.
    >
    > I removed the facebook URL from the list and of course now everything is
    > working just fine. I don't know whether my kids were fiddling with the
    > settings, or whether Windows 7 reset this checkbox itself ... but anyway,
    > PROBLEM SOLVED.
    >
    > Thanks again,
    >
    > Steve
    >
     
  6. Frosty

    Frosty Flightless Bird

    Perhaps what it also shows that the starting IE8 using the command line
    option which disables addons, which is demonstrably different to using IE's
    interface to disable all the addons manually, is different because using the
    command line option somehow disables IE's security settings not just its
    addons? That would require a bit more testing to prove though.
     
  7. rob^_^

    rob^_^ Flightless Bird

    Hi,

    That is probably one of your Addons trying to read the cookie from a site
    that is in your Trusted Zone with https checked.

    You could test it for us by re-Adding facebook to your Trusted Sites zone,
    but switching off the https checkbox (temporarily).

    or

    Starting IE in InPrivate mode and with the setting "Disable toolbars and
    extensions when InPrivate Browsing starts" checked (default is checked).

    Typically it would be one of your 'Social' sharing addons like LinkedIn.

    "Frosty" <stephen.frost.removethisbit@frostbyte.com.au> wrote in message
    news:F583C55C-1B65-4A4C-837F-D93DE9D43271@microsoft.com...
    > Perhaps what it also shows that the starting IE8 using the command line
    > option which disables addons, which is demonstrably different to using
    > IE's
    > interface to disable all the addons manually, is different because using
    > the
    > command line option somehow disables IE's security settings not just its
    > addons? That would require a bit more testing to prove though.
    >
     
  8. Frosty

    Frosty Flightless Bird

    I've now tried adding www.facebook.com back in to the Trusted Sites, without
    the https required checkbox, and it demonstrates the fault every time ... IE
    "forgets" that it knows how to login to facebook and fails every time.

    As soon as I take the site out of Trusted Sites, it works.

    I've tried deleting every addon I can find within IE, meaning all the Adobe
    addons (Flash, Shockware, PDF, etc), Silverlight, all the Windows Live stuff,
    accelerators, etc. Nothing makes any difference. I have reset IE to
    defaults again, multiple times, no difference.

    Anyway, I'm happy to just leave it out of Trusted Sites and move on. But
    hopefully this discussion will help someone else if it happens to them.

    Thanks for your input!
     
  9. Frosty

    Frosty Flightless Bird

    Oh, one other thing I did notice.

    When IE is working correctly and Facebook is loading, it loads in the same
    TAB that has the current focus.

    When IE is not working correctl and Facebook won't load (e.g. when
    www.facebook.com is in the Trusted Sites list), when I click on the Facebook
    shortcut in my Favorites it loads (or tries to load) in a new TAB.

    It does this consistently. I don't know why, nor do I know whether it has
    any significance.
     
  10. rob^_^

    rob^_^ Flightless Bird

    Hi,

    Thanks, yes the loading in a new tab depends upon the security zone of your
    currently loaded page (assuming that you are using also the default security
    zone settings for IE).

    I was erring on recommending that users should add FB to their Trusted Sites
    zone, since there are so many other sites now using their API's to suck
    information from them.

    I think your experience means a definitive NO for everyone. Like any free
    service it should not be afforded any additional trust, just because it is
    popular. On the contrary, you don't know what is leaking out of there or who
    you are dealing with.

    Thanks for the feedback, yes... lets move on.

    Regards.

    "Frosty" <stephen.frost.removethisbit@frostbyte.com.au> wrote in message
    news:41A80A56-60C9-4DF3-A2BB-49575ABCBCBE@microsoft.com...
    > Oh, one other thing I did notice.
    >
    > When IE is working correctly and Facebook is loading, it loads in the same
    > TAB that has the current focus.
    >
    > When IE is not working correctl and Facebook won't load (e.g. when
    > www.facebook.com is in the Trusted Sites list), when I click on the
    > Facebook
    > shortcut in my Favorites it loads (or tries to load) in a new TAB.
    >
    > It does this consistently. I don't know why, nor do I know whether it has
    > any significance.
    >
     

Share This Page