1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Autoplay for USB disabled for XP Sp3

Discussion in 'Windows XP' started by Mint, Aug 25, 2010.

  1. Mint

    Mint Flightless Bird

    Has autoplay for XP Sp3 been disabled for USB drives?

    Setting NoDriveTypeAutoRun to 91 did not work.

    Thanks.
     
  2. PA Bear [MS MVP]

    PA Bear [MS MVP] Flightless Bird

    Any number of post-SP3 updates disable AutoPlay/AutoRun on removable drives.

    Mint wrote:
    > Has autoplay for XP Sp3 been disabled for USB drives?
    >
    > Setting NoDriveTypeAutoRun to 91 did not work.
    >
    > Thanks.
     
  3. ju.c

    ju.c Flightless Bird

  4. Mint

    Mint Flightless Bird

    On Aug 26, 4:41 am, "ju.c" <bibidybubidyb...@mailinator.com> wrote:
    > Try this:
    >
    > AutoRun Settings  11 KB  (Freeware)
    > Web:http://www.uwe-sieber.de/drivetools_e.html
    > Download:http://www.uwe-sieber.de/files/autorunsettings.zip
    >
    > ju.c
    >
    > "Mint" <chocolatemint77...@yahoo.com> wrote in messagenews:21445db1-2196-41d6-883e-5b4314044ec1@m1g2000yqo.googlegroups.com...
    > > Has autoplay for XP Sp3 been disabled for USB drives?

    >
    > > Setting NoDriveTypeAutoRun to 91 did not work.

    >
    > > Thanks.


    Sorry ju.c, but the program doesn't work.

    As PA Bear said, they have done broke it for the honest folks.

    Andy
     
  5. PaulM

    PaulM Flightless Bird

    Have you tried the script here, EnableAutoRunXP: you can download it here:

    http://www.paulsxp.com/forum/viewtopic.php?f=11&t=47

    --
    Paul's XP and Vista Help
    -----------------------------------------
    www.paulsxp.com
    ---------------------------------------
    Paul's Forum
    --------------------------------------
    www.paulsxp.com/forum
    --------------------------------------


    "Mint" <chocolatemint77581@yahoo.com> wrote in message
    news:21445db1-2196-41d6-883e-5b4314044ec1@m1g2000yqo.googlegroups.com...
    > Has autoplay for XP Sp3 been disabled for USB drives?
    >
    > Setting NoDriveTypeAutoRun to 91 did not work.
    >
    > Thanks.
     
  6. Mint

    Mint Flightless Bird

    On Aug 26, 7:10 am, "PaulM" <Pa...@noplace.net> wrote:
    > Have you tried the script here, EnableAutoRunXP: you can download it here:
    >
    > http://www.paulsxp.com/forum/viewtopic.php?f=11&t=47
    >
    > --
    > Paul's XP and Vista Help
    > -----------------------------------------www.paulsxp.com
    > ---------------------------------------
    > Paul's Forum
    > --------------------------------------www.paulsxp.com/forum
    > --------------------------------------
    >
    > "Mint" <chocolatemint77...@yahoo.com> wrote in message
    >
    > news:21445db1-2196-41d6-883e-5b4314044ec1@m1g2000yqo.googlegroups.com...
    >
    > > Has autoplay for XP Sp3 been disabled for USB drives?

    >
    > > Setting NoDriveTypeAutoRun to 91 did not work.

    >
    > > Thanks.


    The script disables autorun.
     
  7. PaulM

    PaulM Flightless Bird

    Which script did you try??? One script will enable and the other will
    disable autorun.

    --
    Paul's XP and Vista Help
    -----------------------------------------
    www.paulsxp.com
    ---------------------------------------
    Paul's Forum
    --------------------------------------
    www.paulsxp.com/forum
    --------------------------------------


    "Mint" <chocolatemint77581@yahoo.com> wrote in message
    news:19352716-9140-407c-be9a-0739ec0ecdc0@a36g2000yqc.googlegroups.com...
    > On Aug 26, 7:10 am, "PaulM" <Pa...@noplace.net> wrote:
    >> Have you tried the script here, EnableAutoRunXP: you can download it
    >> here:
    >>
    >> http://www.paulsxp.com/forum/viewtopic.php?f=11&t=47
    >>
    >> --
    >> Paul's XP and Vista Help
    >> -----------------------------------------www.paulsxp.com
    >> ---------------------------------------
    >> Paul's Forum
    >> --------------------------------------www.paulsxp.com/forum
    >> --------------------------------------
    >>
    >> "Mint" <chocolatemint77...@yahoo.com> wrote in message
    >>
    >> news:21445db1-2196-41d6-883e-5b4314044ec1@m1g2000yqo.googlegroups.com...
    >>
    >> > Has autoplay for XP Sp3 been disabled for USB drives?

    >>
    >> > Setting NoDriveTypeAutoRun to 91 did not work.

    >>
    >> > Thanks.

    >
    > The script disables autorun.
    >
     
  8. Daave

    Daave Flightless Bird

    Mint wrote:
    > Has autoplay for XP Sp3 been disabled for USB drives?
    >
    > Setting NoDriveTypeAutoRun to 91 did not work.


    I actually like having autoplay disabled. It makes malware less likley
    to invade my PC.

    And it's not much more work to open Windows Explorer to see what's on
    the external drive (I either double-click My Computer or press the
    Windows key + E combination.)

    That being said, it's pretty easy to toggle Autoplay on and off if you
    install Tweak UI:

    http://windowsxp.mvps.org/tweakui.htm

    http://www.microsoft.com/windowsxp/downloads/powertoys/xppowertoys.mspx
     
  9. Mint

    Mint Flightless Bird

    On Aug 26, 7:53 pm, "Daave" <da...@example.com> wrote:
    > Mint wrote:
    > > Has autoplay for XP Sp3 been disabled for USB drives?

    >
    > > Setting NoDriveTypeAutoRun to 91 did not work.

    >
    > I actually like having autoplay disabled. It makes malware less likley
    > to invade my PC.
    >
    > And it's not much more work to open Windows Explorer to see what's on
    > the external drive (I either double-click My Computer or press the
    > Windows key + E combination.)
    >
    > That being said, it's pretty easy to toggle Autoplay on and off if you
    > install Tweak UI:
    >
    > http://windowsxp.mvps.org/tweakui.htm
    >
    > http://www.microsoft.com/windowsxp/downloads/powertoys/xppowertoys.mspx


    I am not using autoplay for viewing files.

    I want to run my own program on my USB disk.

    Upgrading to XP Sp3 made autoplay on USB sticks unavailable.

    It's a shame.
     
  10. Tim Meddick

    Tim Meddick Flightless Bird

    If you reset the following values to 0 [zero] in the registry, you will
    re-enable autoplay on all removable media - including USB drives.

    Or simply copy / past the following into a simple text file, using Notepad,
    and re-name it, making sure you give it a .reg extension. Then
    double-click to import it.


    ------------------- copy between lines -------------------
    REGEDIT4

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
    "NoDriveTypeAutoRun"=dword:00000000
    "NoDriveAutoRun"=hex:00,00,00,00

    [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
    "NoDriveTypeAutoRun"=dword:00000000

    ------------------- copy between lines -------------------

    ==

    Cheers, Tim Meddick, Peckham, London. :)




    "Mint" <chocolatemint77581@yahoo.com> wrote in message
    news:e7d621ea-c70e-4679-9003-310877c3698c@t20g2000yqa.googlegroups.com...
    On Aug 26, 7:53 pm, "Daave" <da...@example.com> wrote:
    > Mint wrote:
    > > Has autoplay for XP Sp3 been disabled for USB drives?

    >
    > > Setting NoDriveTypeAutoRun to 91 did not work.

    >
    > I actually like having autoplay disabled. It makes malware less likley
    > to invade my PC.
    >
    > And it's not much more work to open Windows Explorer to see what's on
    > the external drive (I either double-click My Computer or press the
    > Windows key + E combination.)
    >
    > That being said, it's pretty easy to toggle Autoplay on and off if you
    > install Tweak UI:
    >
    > http://windowsxp.mvps.org/tweakui.htm
    >
    > http://www.microsoft.com/windowsxp/downloads/powertoys/xppowertoys.mspx


    I am not using autoplay for viewing files.

    I want to run my own program on my USB disk.

    Upgrading to XP Sp3 made autoplay on USB sticks unavailable.

    It's a shame.
     
  11. Daave

    Daave Flightless Bird

    Mint wrote:
    > On Aug 26, 7:53 pm, "Daave" <da...@example.com> wrote:
    >> Mint wrote:
    >>> Has autoplay for XP Sp3 been disabled for USB drives?

    >>
    >>> Setting NoDriveTypeAutoRun to 91 did not work.

    >>
    >> I actually like having autoplay disabled. It makes malware less
    >> likley to invade my PC.
    >>
    >> And it's not much more work to open Windows Explorer to see what's on
    >> the external drive (I either double-click My Computer or press the
    >> Windows key + E combination.)
    >>
    >> That being said, it's pretty easy to toggle Autoplay on and off if
    >> you install Tweak UI:
    >>
    >> http://windowsxp.mvps.org/tweakui.htm
    >>
    >> http://www.microsoft.com/windowsxp/downloads/powertoys/xppowertoys.mspx

    >
    > I am not using autoplay for viewing files.
    >
    > I want to run my own program on my USB disk.
    >
    > Upgrading to XP Sp3 made autoplay on USB sticks unavailable.
    >
    > It's a shame.


    Why complain about it when all you need to do is install Tweak UI, which
    is useful for other things as well? This way autoplay will be available
    for you again.

    Or you could just copy the program (sounds like a standalone) to your
    PC.

    The bottom line is autoplay can be available if you choose to make it
    so. And with minimal effort, too.
     
  12. Mint

    Mint Flightless Bird

    On Aug 27, 4:55 pm, "Tim Meddick" <timmedd...@o2.co.uk> wrote:
    > If you reset the following values to 0 [zero] in the registry, you will
    > re-enable autoplay on all removable media - including USB drives.
    >
    > Or simply copy / past the following into a simple text file, using Notepad,
    > and re-name it, making sure you give it a .reg extension.  Then
    > double-click to import it.
    >
    > ------------------- copy between lines -------------------
    > REGEDIT4
    >
    > [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
    > "NoDriveTypeAutoRun"=dword:00000000
    > "NoDriveAutoRun"=hex:00,00,00,00
    >
    > [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
    > "NoDriveTypeAutoRun"=dword:00000000
    >


    It didn't work.
    MS disabled it completely in Sp3.

    [autorun]
    open=checka.exe
     
  13. Mint

    Mint Flightless Bird

    On Aug 27, 7:52 pm, "Daave" <da...@example.com> wrote:
    > Mint wrote:
    > > On Aug 26, 7:53 pm, "Daave" <da...@example.com> wrote:
    > >> Mint wrote:
    > >>> Has autoplay for XP Sp3 been disabled for USB drives?

    >
    > >>> Setting NoDriveTypeAutoRun to 91 did not work.

    >
    > >> I actually like having autoplay disabled. It makes malware less
    > >> likley to invade my PC.

    >
    > >> And it's not much more work to open Windows Explorer to see what's on
    > >> the external drive (I either double-click My Computer or press the
    > >> Windows key + E combination.)

    >
    > >> That being said, it's pretty easy to toggle Autoplay on and off if
    > >> you install Tweak UI:

    >
    > >>http://windowsxp.mvps.org/tweakui.htm

    >
    > >>http://www.microsoft.com/windowsxp/downloads/powertoys/xppowertoys.mspx

    >
    > > I am not using autoplay for viewing files.

    >
    > > I want to run my own program on my USB disk.

    >
    > > Upgrading to XP Sp3 made autoplay on USB sticks unavailable.

    >
    > > It's a shame.

    >
    > Why complain about it when all you need to do is install Tweak UI, which
    > is useful for other things as well? This way autoplay will be available
    > for you again.
    >
    > Or you could just copy the program (sounds like a standalone) to your
    > PC.
    >
    > The bottom line is autoplay can be available if you choose to make it
    > so. And with minimal effort, too.


    No is complaining.

    autorun.inf USED to be a legitimate way to autostart programs on CD/
    DVDs and USB sticks.
    They serve a useful purpose, but some evil people used it for harm.

    See previous post.
    MS disabled autoplay completely in Sp3.
     
  14. Daave

    Daave Flightless Bird

    Mint wrote:
    > On Aug 27, 7:52 pm, "Daave" <da...@example.com> wrote:
    >> Mint wrote:
    >>> On Aug 26, 7:53 pm, "Daave" <da...@example.com> wrote:
    >>>> Mint wrote:
    >>>>> Has autoplay for XP Sp3 been disabled for USB drives?

    >>
    >>>>> Setting NoDriveTypeAutoRun to 91 did not work.

    >>
    >>>> I actually like having autoplay disabled. It makes malware less
    >>>> likley to invade my PC.

    >>
    >>>> And it's not much more work to open Windows Explorer to see what's
    >>>> on the external drive (I either double-click My Computer or press
    >>>> the Windows key + E combination.)

    >>
    >>>> That being said, it's pretty easy to toggle Autoplay on and off if
    >>>> you install Tweak UI:

    >>
    >>>> http://windowsxp.mvps.org/tweakui.htm

    >>
    >>>> http://www.microsoft.com/windowsxp/downloads/powertoys/xppowertoys.mspx

    >>
    >>> I am not using autoplay for viewing files.

    >>
    >>> I want to run my own program on my USB disk.

    >>
    >>> Upgrading to XP Sp3 made autoplay on USB sticks unavailable.

    >>
    >>> It's a shame.

    >>
    >> Why complain about it when all you need to do is install Tweak UI,
    >> which is useful for other things as well? This way autoplay will be
    >> available for you again.
    >>
    >> Or you could just copy the program (sounds like a standalone) to your
    >> PC.
    >>
    >> The bottom line is autoplay can be available if you choose to make it
    >> so. And with minimal effort, too.

    >
    > No is complaining.
    >
    > autorun.inf USED to be a legitimate way to autostart programs on CD/
    > DVDs and USB sticks.
    > They serve a useful purpose, but some evil people used it for harm.
    >
    > See previous post.
    > MS disabled autoplay completely in Sp3.


    Not completely.

    Have you tried Tweak UI? There indeed is a setting for "Enable Autoplay
    for removable drives." And it does work. Even with SP3.

    Minimal effort, my friend. Are you willing to give it a try?
     
  15. Tim Meddick

    Tim Meddick Flightless Bird

    I agree, autoplay still executes Autorun.inf files (both on cd & pen
    drives) - What rubbish "they disabled it in sp3" ???!!!!

    ==

    Cheers, Tim Meddick, Peckham, London. :)




    "Daave" <daave@example.com> wrote in message
    news:eE%23$fRwRLHA.6004@TK2MSFTNGP02.phx.gbl...
    > Mint wrote:
    >> On Aug 27, 7:52 pm, "Daave" <da...@example.com> wrote:
    >>> Mint wrote:
    >>>> On Aug 26, 7:53 pm, "Daave" <da...@example.com> wrote:
    >>>>> Mint wrote:
    >>>>>> Has autoplay for XP Sp3 been disabled for USB drives?
    >>>
    >>>>>> Setting NoDriveTypeAutoRun to 91 did not work.
    >>>
    >>>>> I actually like having autoplay disabled. It makes malware less
    >>>>> likley to invade my PC.
    >>>
    >>>>> And it's not much more work to open Windows Explorer to see what's
    >>>>> on the external drive (I either double-click My Computer or press
    >>>>> the Windows key + E combination.)
    >>>
    >>>>> That being said, it's pretty easy to toggle Autoplay on and off if
    >>>>> you install Tweak UI:
    >>>
    >>>>> http://windowsxp.mvps.org/tweakui.htm
    >>>
    >>>>> http://www.microsoft.com/windowsxp/downloads/powertoys/xppowertoys.mspx
    >>>
    >>>> I am not using autoplay for viewing files.
    >>>
    >>>> I want to run my own program on my USB disk.
    >>>
    >>>> Upgrading to XP Sp3 made autoplay on USB sticks unavailable.
    >>>
    >>>> It's a shame.
    >>>
    >>> Why complain about it when all you need to do is install Tweak UI,
    >>> which is useful for other things as well? This way autoplay will be
    >>> available for you again.
    >>>
    >>> Or you could just copy the program (sounds like a standalone) to your
    >>> PC.
    >>>
    >>> The bottom line is autoplay can be available if you choose to make it
    >>> so. And with minimal effort, too.

    >>
    >> No is complaining.
    >>
    >> autorun.inf USED to be a legitimate way to autostart programs on CD/
    >> DVDs and USB sticks.
    >> They serve a useful purpose, but some evil people used it for harm.
    >>
    >> See previous post.
    >> MS disabled autoplay completely in Sp3.

    >
    > Not completely.
    >
    > Have you tried Tweak UI? There indeed is a setting for "Enable Autoplay
    > for removable drives." And it does work. Even with SP3.
    >
    > Minimal effort, my friend. Are you willing to give it a try?
    >
     

Share This Page